WiiMC DVD Video Playback problems...

Discussion in 'Wii - Emulation and Homebrew' started by w!!, Aug 20, 2010.

  1. w!!
    OP

    w!! GBAtemp Regular

    Member
    201
    4
    Apr 24, 2009
    United States
    I can't seem to get DVD videos to play smoothly with WiiMC 1.0.9. I've always had probs even with earlier versions. Most of my dvd's can't even make it to the menu screen. Once I do get it to start playing the movie, it's extremely choppy and especially choppy when it switches to the next chapter. I haven't been able to watch a full DVD with it, it freezes (Wii OSD controls freeze too). I can play the DVDs just fine with MPlayer CE. I've done a bit of searching, but just see people that say it works fine for them. Any suggestions? I've tried looking through the options screens, but there's not much in there that seems to help. Thanks in advance!
     
  2. w!!
    OP

    w!! GBAtemp Regular

    Member
    201
    4
    Apr 24, 2009
    United States
    bump... anyone else have this issue?
     
  3. FIX94

    FIX94 Global Moderator

    Global Moderator
    6,820
    8,121
    Dec 3, 2009
    Germany
    ???
    You must know that the performance and the stability is not so good in wiimc. Use mplayer-ce for now and wait until wiimc works better.
     
  4. w!!
    OP

    w!! GBAtemp Regular

    Member
    201
    4
    Apr 24, 2009
    United States
    Okay, I've just seen posts that it works well for other people and thought it might be some issue I was having... thnx for the response.
     
  5. Tantric

    Tantric GBAtemp Regular

    Member
    190
    46
    Feb 8, 2007
    Canada
    I beg to differ. WiiMC works perfectly well for what I do with it.
     
  6. wiixale

    wiixale GBAtemp Regular

    Member
    299
    0
    Dec 24, 2008
    Italy
    I think depends on the DVD.

    I have played DVDs flawlessly, while some DVDs didn't even boot.
     
  7. w!!
    OP

    w!! GBAtemp Regular

    Member
    201
    4
    Apr 24, 2009
    United States
    @tantric: I've tried the several of my dvds: Hitman, Primeval, Family Guy series and none would load smoothly... kept getting lock ups at the dvd menu, and when loading videos. MPlayer CE was able to play them all (still had some menu issues). I am loading from the original DVD discs, not ripping to an HDD and trying to play from there.

    In my experience, it seems to be with switching videos/chapters, for example, when the dvd starts and there's the up coming releases - if they are separate files, it locks up between them, displays black with choppy audio for the first bit of the next video, etc... some audio artifacts remain through out the video, like little tic sounds etc...

    Any suggestions as to possible setting changes or something that would improve my luck? I love the interface and options of WiiMC over Mplayer CE and would love to make it my default Media center app. I saw that 1.0.9 was the last release for a while which is why I'm asking for help on here... If there's any thing I can do to test/send debug info about what's going on when I try to play one, let me know. If it's just a wait until the next release for improved compatability, I'm cool with that too... just trying to see if it's something with my system or if others are having similar issues. Keep up the great work and Thanks!
     
  8. nagnose

    nagnose Advanced Member

    Newcomer
    59
    0
    May 1, 2009
    United States
    I was having the same problems so i changed the option for dvds to skip to main title and have had no problems since
     
  9. Alato

    Alato GBAtemp Regular

    Member
    221
    5
    Jun 25, 2008
    Canada
    You could try disabling frame dropping? Which may just make the movie lag behind the audio, but. I don't know.
    Otherwise, I just suggest using MPlayer-CE for now, until WiiMC gets updated some more.

    I have a few similar problems with actual video files if they're HD(black video, choppy video, etc.)- but I'm also streaming them from my computer which may or may not affect it.
     
  10. w!!
    OP

    w!! GBAtemp Regular

    Member
    201
    4
    Apr 24, 2009
    United States
    @nagnose: Thanks, I'll try that. Though with dvds that are compilations (tv series, etc...) this won't work

    @Alato: I tried to disable frame dropping and it didn't help. Thanks though. I am still using Mplayer as my primary dvd player for now...