wii usb loading problem

Discussion in 'Wii - Hacking' started by tommitek, Jan 10, 2011.

Jan 10, 2011

wii usb loading problem by tommitek at 4:12 PM (842 Views / 0 Likes) 3 replies

  1. tommitek

    Newcomer tommitek Advanced Member

    Aug 17, 2009
    Hey. I have spent the last 3 days straight, without sleep battling with my wii, and searching the net for answers that would help me to victory. So far no success at all. So i have started a new topic which will hopefully get me some answers directly and eventually will result in me being to play my backups off a HDD using configurable USB loader. here is the background info so anyone who knows there stuff doesnt have their time wasted by having to ask me a heap of questions about my system and what i have done so far. i know this i going to be a long-ass post, but i really just want to reach a solution, so i hope you all can bear with me, and stick it out and read this post to the end...

    my wii is originally a Japanese console, bought a while back now, maybe around the time of the 3.1J firmware update. Around the time of the 4.0 update i switched it to 4.1U using one of the guides on here. I had the homebrew channel installed, bootmii as both boot2 and IOS and i had preloader 0.29. I was able to play my backups via the neogamma launcher channel i had installled on the system menu also. i dont know exactly which custom IOS i had, but suffice it to say that there was enough of them that i didnt have any trouble playing my burnt backups through neogamma channel

    so about 3 days ago i decided that i was fed up of constantly having to rip my games to iso, and then burn my backups and basically constantly double the physical space my games take up, so i decided to try read up on how i would go about booting directly from a usb drive, with configurable USB loader (seems to be the most popular. plus the the little demo videos were awesome and i was sold). i jumped on gbatemp and started reading. it seemed then that my first step was to attempt to try and update my system firmware to the latest homebrew friendly version.

    i followed this guide


    but obviously i didnt need to install bootmii and the homebrew channel anymore because i already had them. here are the steps i followed ( i used links to files provided in the guide):

    - i ran the YAWM Multimod Batch, and installed all the wads to update my wii firmware to 4.2 (HBC friendly)

    - i skipped installing homebrew and bootmii (already had both), i skipped making a nand backup (already did this, thank goodness too, otherwise i would be posting if a bricked wii makes a good coaster or not...)

    - i ran IOS236 Installer v5 MOD

    - i ran YAWM Multimod Batch (not the same one as above, this one was from the second section of the guide which installed cIOS & Patched the System Menu IOS)

    - finally i installed the latest priiloader and turned on all the hacks i wanted (pretty much the ones the guide recommends)

    At this point everything is still super sweet. and i decided to create a nand backup at this point in case things started going haywire from here. which they did...

    So at this point (about 2 and a half days ago) my system was as follows

    firmware 4.2U, with the latest version of homebrew channel (running under IOS58), IOS249 (rev20) - to be honest i am a bit fuzzy on IOS249 but it has a shitload of revisions, and people keep talking about it when they experience troubles, so i thought i should mention it. I got this info from the bottom of the screen when i load the neogamma channel , the latest priiloader with hacks enabled. the ability to play my original games and my original import games through the disc channel, and the ability to play my backups through the neogamma channel i have installed on the system menu. everything went smoothly to this point.

    However, next is where things are just not working no matter what i try, no matter what i read. I want to be able to use configurable USB loader and play my backups so i decided to click the link at the bottom of the previous guide which took me to this page


    now here, my extensive reading led me to believe that using a hard drive formatted to FAT32 was the best way to go (I originally thought i would do the WBFS method, but apparently now that is not recommended anymore, and im not one to argue about stuff i have a shaky grasp of as it is) so i decided to click the FAT/NTFS for Windows link which took me to the next page which gave me link to the apps that support FAT32/NTFS from which i clicked the link for configurable USB loader, which took me here....


    i then proceeded to format a buffalo externally powered 250GB hdd (i live in japan, and its basically just buffalo or I-O data. both seemingly shit brands in a land of technology... hmmm) that i had spare. It was already formatted as FAT32 but had some old data on it. and just for no-mistakes' sake, i reformatted it using a partitioning program. No separate partitions or anything, just the whole drive as one partition and labelled it W:WIIDRIVE

    i then proceeded to follow the latest guide i was on, and got the latest cfgUSBloader zip, which was 62, set it up on my SD card as instructed, plugged my usb drive into the usb port closer to the underside edge of the console (ie. when you dont use the stand, and have it sitting like a regular dvd player the 2 usb ports are one on top of the other horizontally like an equals sign = from what i managed to pick up on the forums the usb port closer to the underside of the console is the port i am to use (0 port??) anyway i ran the cfgUSBloader. it loaded into the program fine(via 249), but then when trying to mount my device it timed out. i tried again, same deal. so i got back to reading. i learned that there are otherways that you can attempt to run the loader which may be more accepting of various usb drives. i basically read the following link a lot, and used the links and procedures stated here.


    this here is the final step, so i navigated backwards and realised i could try and run the cfgUSBloader via 248, or 222 or 223 or even 224, some of which i didnt have installed on my wii, and some of which i did. long story short (well... shorter... but still long...) i went about installing all of these, or reinstalling them, to make sure that if i used the corresponding .dol file of cfgUSBloader that it would not shit itself as the cIOS would be there installed, waiting. Once all this was done i tried to run the cfgUSBinstaller on all of these at least once maybe even 2 or 3 times, i tried it all again plugging the hdd into the other port, i then even grabbed a 8GB flash drive I had and formatted that FAT32 and tried all of the various ways ways of launching cfgUSBloader, and all with the same results.... timing out after 30 seconds. anyway, i decided after trying a million things that it was either my hdd is not compatible (and the USB flash drive also) or that i had stayed up all night and the no-sleep thing was making me make mistakes. so i had a couple of hours snooze this morning. i got up and tried again with a fresh noggin on my shoulders, but still no dice. so i decided that it was probably the incompatible drives. so this afternoon i went to buy a new hdd. i picked up an externally powered 1.5TB hdd (again buffalo, but it was basically all i could get, not much on choices here..) and i took it home, and again have had the exact same results. no matter which method (using cios 249, 222, 223, 224, 248. and yes i have made sure to have the corresponding .dol file and or/alternate meta.xl file etc etc) no matter which usb port i use, once the app loads it times out after 30 seconds of trying to mount my hdd.

    Now it might be that buffalo is just shit, and i got super unlucky. so i will be going back to the store tomorrow to return the drive i bought today. and i will try and find a different brand (i think i have seen lacie around somewhere).

    However, i am starting to think that it could be another problem, i mean, 3 different usb devices, all wont mount. i havent made any mistakes according to the guides, and ive read until my eyes have bled these last 3 days, but honestly, if a different drive doesnt do the trick, i really have no idea what to do next. i honestly cant find any other info on the net, in any forums. also i havent made any minor mistakes with the procedure. even as i have been writing this, i have anally double checked and attempted each method once more, just to make sure i didnt slip up these past few days and end up looking like a muppet after writing such a long post (although to be honest, my pride means very little to me if it means that i could get this thing to work)

    So i appeal to you all out there! anybody, anybody at all. even if you are not sure you know what the deal is, but know a guy who might, pass this on, until it gets to some super-guru who can put an end to the 3 darkest days of my life. I have failed, but not for lack of trying it on my own (by "own" i mean reading other peoples stuff... but you get the idea) more than many others would. whatever the solution is, its is well well well beyond me.

    I will be trying to find another hdd tomorrow after work, and hopefully it will do the trick. any suggestions as to what parameters i should stick to (ie. size, speed, usb2.0/3.0) just to try and eliminate any other source of uncertainty.

    Anyway, again i hope this post finds someone who can solve this problem for me (and anyone else who may be having it). Thanks for reading this post, i know it was super long. and thanks in advance to anyone who can come to my rescue

  2. burritoboy9984

    Member burritoboy9984 GBAtemp Advanced Fan

    Jan 24, 2009
    United States
    First off, you shouldn't makes posts so long on this site... 90% of the people on here, will click the topic, see it is longer than a college essay and close it instantly. With that said, I skimmed through it, and the buffalo drives, I can perhaps see having issues, but if you formatted the flash drive correctly, it should work.

    With that said, format the flash drive and sd card in windows to fat32.
    Grab this and this.
    Copy the contents to the root of their respective devices.
    Load up wii backup manager.
    Load the drive letter assigned to your flash drive.
    Copy over a game from your computer you have backed up.
    Place the usb drive and sd card in the wii.
    Launch the hbc and run Configurable USB Loader and see if it finds it.

    If it doesn't, then I honestly don't know.

  3. tommitek

    Newcomer tommitek Advanced Member

    Aug 17, 2009
    Hey Erik.

    Thanks for taking the time to get through my post. I knew it was stupidly long and was kind of worried that i wouldnt get replied to, but i guess i just wanted to get all the info out there so that this post wouldnt be wasted with having a whole lot of advice that i had already tried posted, followed by me saying tried that.

    Anyway, cheers for the reply and the links. i will try it tomorrow when i get a chance. i just have a couple of short questions.

    once i put the files you supplied onto the sd card, and the files you supplied on the usb drive, you say to load up wii backup manager choose the flash drive and copy one of my backups. so just to clarify.. i need to copy a the game folder with wbfs files in it (not .iso) onto the root of the sd card (not into the wbfs folder)?

    so on my usb drive (lets say W:/) i would have something that looks like this


    is this correct??
  4. person66

    Member person66 If it isn't edited, it isn't a true person66 post

    Jun 16, 2009
    no, the game folder goes in to the wbfs folder. Actually, you don't even need the game folder, if you want you can just put the wbfs files in to the wbfs folder and it should also work.

    so it should end up looking either like this:


    or like this:


Share This Page