Wii U: To wait or not to wait

Discussion in 'Wii U - Hacking & Backup Loaders' started by the_randomizer, Aug 28, 2014.

  1. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Okay, so I'm at a stalemate, a standstill if you will, on what I should truly do given the circumstance the Wii U hacking state is in. So what we know so far is that we have a webkit exploit for system update 5.00 and 5.1.0, and as of 5.11 and above, that particular webkit bug has been patched. In order for 5.1.1+ to work, another exploit has to be found, as there are undoubtedly more bugs, so who knows if and when another exploit will be found in the webkit itself, it may be soon, a long time, or never. This leads me to the meat of the topic, do I update or do I await the entire exploit?

    With the advent of the recent MK 8 DLC and the ones coming up later this year for the extra courses, karts and characters, not to mention Super Smash Bros, which will likely contain a system update on the disc itself, it begs the question, is it worth waiting? Not to mention I've been approached by some friends of mine and they have inquired as why I haven't been online in a long time, which I admit, I find to be heart-wrenching. Why? Because by my holding out on updating and getting online, they think I'm ignoring them when that's not my intent at all, I simply cannot explain why I'm waiting without telling them why only to have them call me out for wanting to hack the console.

    It doesn't help me any that the wireless in my apartment is horrendously bad and super slow (I'll spare the details for now), so online isn't that stable for me on the Wii U anyways. On the other hand, there is also the Trinux method of loading homebrew and the eventuality of installing a hack that way as well. I guess what I'm trying to figure out is, do I wait for a true exploit which can spoof the system update and have access to online games and not disappoint friends who have certain expectations, or, do I simply update to 5.1.2 and have false hope of seeing another webkit bug exploit? At this point, I don't even know what I want to do anymore. I bet anything Smash Bros will require a system update for some lame reason, such is the nature of new Nintendo games.

    Disclaimer: I await good N64 and PS1 emulators, menu spoofing, region lock removal, that's it. I do NOT want to use Wii U backups and therefore don't care about ODE/ODDE devices.
     
    Refriger8tor and SLiV3R like this.


  2. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    641
    Nov 2, 2008
    Cote d'Ivoire
    [​IMG]

    Update!
     
  3. nando

    nando GBAtemp Addict

    Member
    2,131
    395
    Jan 1, 2008
    United States
    the solution is 2 Wii Us
     
    google and Refriger8tor like this.
  4. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Conversely, the other side to the issue is that should I update, I have a high probability of permanently locking myself out of ever getting a proper Wii U hack, I just know someone will say "oh go ahead, they'll find another exploit I'm sure" only to have it become another 3DS 4.x situation, and have history repeat. So it's damned if I do, damned if I don't. I don't think there will ever be another easily-found exploit, much less people willing to find another bug in the web kit. Besides, I'll have to get a LAN adapter if I want to enjoy going online without the sodding connection dropping every five minutes in MK 8.

    I should note that I don't have the financial means of doing that, like, for a very long time; will post that fact in the OP.
     
  5. Gahars

    Gahars Bakayaro Banzai

    Member
    10,254
    17,403
    Aug 5, 2011
    United States
    New Jersey
    It's not like there's going to be that many games to pirate anyway.
     
  6. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    641
    Nov 2, 2008
    Cote d'Ivoire
    Well, I bet Smash Bros will have an update, to make that Amiibo thingy functional, though I don't think it's obligatory.
     
  7. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    6,463
    4,017
    Jan 17, 2013
    Mexico
    The 4.X thing will be forgotten past by next week.
    Smealum's exploit will be compatible with 8.1 I think.

    As for Wii U, I updated by mistake and I can't do anything now, but I'm not to worried since the hacking scene is far from now.
    If it lifts up, so will the exploit fir the system I hope...
     
  8. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Um, right, seeing as I don't even care about pirating Wii U games, mostly want to see emulators Nintendo will never release several games on the VC (due to licensing issues and other BS they won't deal with) not to mention region locking removal, I don't want there to be another PS3-like scenario and only have a very specific firmware hackable and non-downgradable (not easily anyway). I sure as hell can't afford another console to use for legit purposes and one for hacks.


    That's true, the 3DS sweet spot for hacking isn't as bad as it used to be as most firmware versions will work with hacks so at least there's that, but for the Wii U, not so much, I don't have the highest hopes, and I would need to get a LAN adapter to improve online stability, and yes, SSB will likely have update data on the disc, see, there's so much uncertainty in what can be done, when it will be released and to what extent the Wii U will be and so on, so I can't trust in certain things right now. Ugh, I just don't know what to do, I can't get a second console to use for legit and one for hacking, so I can't have both. Oh and I've given up on the VC altogether because I don't like the emulators they use.
     
  9. jalaneme

    jalaneme Female Gamer

    Member
    6,248
    195
    Nov 27, 2006
    London
    personally i would wait till smash bros comes out and worry about updating then, there is no reason to update right now, it will be a concern later though as more games come out though.
     
  10. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    6,463
    4,017
    Jan 17, 2013
    Mexico
    I don't have my hopes too high for the Wii U Homebrew.
    And most likely upcoming games will have the update, so that woul be inevitable.
    I am in the same spot as you are, I only want Homebre-U for the emulators and nothing else.
    We stlll need a proper DS and N64 emu :(
     
  11. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Ugh, yeah, but still, wish I had a second console to have both.


    Damn, that's what I was afraid of, not sure what's gonna happen in the hacking scene, much less for emulators in general. We have Linux emulators running (at least one so far) running in Trinux, so that might be a proper method, at least, via that way, but it needs to fix memory leaking issues and performance, but it's a viable means. There might be more console access via Trinux eventually, but who knows when for sure.
     
  12. NWPlayer123

    NWPlayer123 GBAtemp Addict

    Member
    2,629
    6,226
    Feb 17, 2012
    United States
    The Everfree Forest
    I would say just update. By the time we have good homebrew/a version spoofer/whatever else you could imagine, someone will have hacked the console wide open and found a game-based exploit like smea has, that hopefully will work on most versions. It's just that Webkit is the most reliable attack vector currently, which limits things a lot, along with the fact that we can't even load rpx files or really any files yet. There's no simple way to make homebrew in the first place.
     
    SLiV3R likes this.
  13. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Well, the thing is, I know that once I update, hackers will come out later and say, "Never mind, the Wii U can only be hacked on 5.1.1 and below lol", and well, yes, I'll end up paying the price, I just have rotten luck like that, you know? I don't feel 100% safe doing it yet, until there's a way to spoof the system update and access online services or at the very least, block updates permanently. Besides, I won't have much success online gaming until I get a LAN adapter, wireless is far too flaky where I live.
     
    mashiro21 likes this.
  14. Katsumi San

    Katsumi San GBAtemp Fan

    Member
    489
    213
    Jan 15, 2012
    Kyoto
    Perhaps it is best to do the firmware update. I think nintendo are make WiiU it should became when release. I buy WiiU last november and really enjoy it. Right now I see WiiU becoming very potential machine. Nintendo are late with the DLC thing, but they are really give money worth. Especially if dlc is become content of first nintendo IP.


    Imagine in MK8 link is throw boomerang but is not Blue? Perhaps is wind boomerang of twilight princess?

    P.S. I really wish they could do such cool thing.
     
    SLiV3R likes this.
  15. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Right, but at the same time, I wish to disable the asinine region locking as it's only an excuse to control sales (and bad logic as the PS3 was region free, as was DS, GBA, GB, PSP, etc). That and actual PSX and N64 emulators that run at full speed; is that so bad for me to expect? I update now and I permanently lock myself from ever getting a decent hack on the console.
     
  16. mightymuffy

    mightymuffy fatbaldpieeater

    Member
    GBAtemp Patron
    mightymuffy is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,312
    505
    Nov 6, 2002
    Wigan, UK
    This, and

    This! If the gang can only get homebrew running on the older firmware then the scene just won't get going at all - next to nobody will be using it, and emu authors will spend their time getting their work running on Android, or Pi, etc - the userbase is far larger there, and it's easier to develop/port in the first place.
    That said, at least when you fire up MK8 at the moment you're not getting bombarded with images for DLC you can't even fukkin have for another 3 months, half of that for another 6 months after that.... you should consider yourself lucky! :lol:
     
  17. Katsumi San

    Katsumi San GBAtemp Fan

    Member
    489
    213
    Jan 15, 2012
    Kyoto
    Hmm I understand your opinion. Also I am very nintendo fan but... I think it isla bullshit the region lock. I live in US, but It is not so easy play the games in english. It is double time the work to read and understand. Import of Japanese games is very high cost. I wish my father did not accept job to travel outside japan and work in US :-(
     
  18. Taleweaver

    Taleweaver Storywriter

    Member
    5,529
    1,584
    Dec 23, 2009
    Belgium
    Belgium
    So...since the vwii part is unaffected, you can still run all those emulators after updating, right? :unsure: And that's even assuming you got rid of your physical wii (who still have a massive amount of emulators).

    Anyway: in your case, I'd just update. I'd say there is even a moderate to good chance that the vwii exploits will never be fixed (it's not like ninty is THAT blind to not have noticed it :P ).
     
  19. the_randomizer
    OP

    the_randomizer The Temp's official fox whisperer

    Member
    20,755
    9,753
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Honestly, I don't have any clue as to why I'm so hesitant about updating, I guess I just see another PS3-like scenario and the fact there's no chance in hell of there being anything decent, at least, not from what I see as far as emulators go. Notably PSX and N64 emulation, something the Wii simply couldn't do that well at all due to lack of raw power, so both emulators had partial success, but many games ran slow and had a myriad of glitches. vWii is unaffected for now, but with the Gamecube adapter coming out, would it not require a patch to be made usable with Wii games run in vWii mode?

    Again, a lot of uncertainties and I'm on the fence still. vWii emulators for N64 and PSX are not nearly as good as the others and are more broken, I doubt they will get much better than they already are. Problem with vWii is it's capped at the Wii clock speed of 729 MHz per core, even with all three cores being used, each core is locked at 729 MHz. I just don't freaking know if it's worth it.




    Dude, that just sucks, and all the more proves that region locking benefits no one and should be abolished, hence why I await a hack.
     
  20. darkseekerliu

    darkseekerliu Advanced Player

    Member
    282
    86
    Jun 13, 2013
    Brazil
    Drakonia
    the_ramdomizer, I understand how you feel. But for me Mario Kart dlc is a must and I will update. As Gahars said, there will not be many games to pirate.

    The ps3 scene is much locked on ofw 3.55 (We are currently at 4.65) but people found ways to play backups even on newer models at the cost of buying
    a piece of hardware.

    Enjoy Wii u and your mario kart now, and worry yourself later... afterall there will be an ode for wii u as well... and eventually a new exploit for wii u just like in 3ds scene.