UStealth - Wii U 'Format Disk' Nag workaround :)

Discussion in 'Wii U - Hacking & Backup Loaders' started by jayjay123, Aug 11, 2013.

  1. jayjay123
    OP

    jayjay123 GBAtemp Regular

    Member
    2
    Jul 24, 2013
    Good plan - I'll do that
     
  2. OriginalHamster

    OriginalHamster UStealthy

    Member
    6
    Nov 2, 2008
    Cote d'Ivoire
    Made a quick icon in the mean time :P

    Edit: made a white background, cause it was kinda hard to see in HBC.
     

    Attached Files:

    • icon.
      icon.png
      File size:
      410 bytes
      Views:
      237
    jayjay123 and Onion_Knight like this.
  3. jayjay123
    OP

    jayjay123 GBAtemp Regular

    Member
    2
    Jul 24, 2013
    Nice icon :) permission to use as official ustealth icon (with acknowlegement to you)?
     
    OriginalHamster likes this.
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    I think it was meant to be used.

    Onion_Knight:
    I didn't test your homebrew yet, but I'm wondering:
    Does it use AHBPROT and IOS58?

    If there are two drives connected to USB, IOS58 always use Port1 instead of Port0.
    It's not a problem for users with a Y-cable, but maybe some users with two external powered drives could encounter problems if they can't select which drive to hide.

    if you use cIOS 10-alt, you can decide which port to use, but it won't work for users without the alt version or even without any cIOS who only want homebrew without USBloaders.
    I think IOS58 is better, but maybe inform the users that it will affect only one drive with priority to port1.

    Anyway, thanks for releasing it.
    (sources would be great too ;))
     
  5. Onion_Knight

    Onion_Knight GBAtemp Advanced Fan

    Member
    6
    Feb 6, 2014
    Honestly, I didn't try it with two Hard drives as I use a Y cable. It won't work for a second hard drive as I only call USBStorage_Open on the first USB Mass storage device found from USB_GetDeviceList. I've already heavily modified the source code for this as it was mostly done as a learning tool for me. I've only had my wiiU hacked for less than a month and downloaded DevKitPro about three weeks ago.
     
  6. OriginalHamster

    OriginalHamster UStealthy

    Member
    6
    Nov 2, 2008
    Cote d'Ivoire
    Sure, no problem ;)
     
    jayjay123 likes this.
  7. xellspooun

    xellspooun Member

    Newcomer
    2
    Mar 9, 2014
    Greece
    Hi, there. :)

    I am stuck. I have the forwader of USB LOADER GX from here and I need a step-by-step guide on what to do next in order to use U-Stealth. I have marked the hdd containing my wii game-backups as HIDDEN but USB LOADER GX does not recognize it.

    Keep in mind that the two .wad files of USB LOADER GX in links of the original post gave me black screens when I tried to enter the channel in vWii, so I returned back to the .wad of the other topic which works just fine with my vWii.

    So, any ideas?
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    I added stealth HDD support not long ago.
    update USBLoaderGX (not from the internal update menu, but manually).

    Download r1218, extract boot.dol located in /IOS249/ folder, and place it in your SD:/apps/usbloader_gx/ folder (replace the old one).
     
    jayjay123 and xellspooun like this.
  9. xellspooun

    xellspooun Member

    Newcomer
    2
    Mar 9, 2014
    Greece
    Yeap, that did the trick.

    Thank you so much :)
     
    jayjay123 likes this.
  10. KentaZX

    KentaZX GBAtemp Regular

    Member
    4
    Sep 13, 2009
    Canada
    So I just installed homebrew channel on my vwii no problem, but theres one thing i'm wondering still...

    you see i have my harddrive that i use for Wii backups, gamecube, and ps3 backups. if i tried to use this app, will it make it unable to load on the ps3 or the regular wii anymore? or it doesnt change much to the harddrive? This is what im a bit hesistant on continuing right now.
     
  11. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Another alternative method would be to hold B while the Wii U boots up and bypasses the Wii U menu; not the best solution, but it's a solution that will let your HDD show up on your PS3 and regular Wii.
     
  12. KentaZX

    KentaZX GBAtemp Regular

    Member
    4
    Sep 13, 2009
    Canada

    oh really thats it? alright then ill just do that.
     
  13. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    As long as the Wii U is on system 4.0.0 or above, then yeah, holding B during the boot up process should go straight to the vWii/Wii Mode, you'll see a little message that says "starting Wii menu" on the game pad:P

    Just don't go back to the Wii U menu from Wii Mode, otherwise, it will prompt the HDD to be formatted.
     
  14. KentaZX

    KentaZX GBAtemp Regular

    Member
    4
    Sep 13, 2009
    Canada

    Oh nice! i just hacked it today! and since youre on here might as well ask you this:

    1. can I use wads on the wii u if they worked on the wii perfectly? as in install them as normal? or do i need to edit the wads now?

    2. whats the latest CFG usbloader that works on the vwii? (or is the same thing itself works on both no problem?)

    3. does hermes 222 and 223 work on the wii U yet or no?
     
  15. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    Just so I don't accidentally misguide or say something off, I'd recommend reading these threads on what vWii can and can't do :P

    http://gbatemp.net/threads/basic-dos-and-do-nots-of-vwii-modding.339337/
    http://gbatemp.net/threads/hacking-the-wiiu-a-simple-progress-guide.338900/
     
  16. KentaZX

    KentaZX GBAtemp Regular

    Member
    4
    Sep 13, 2009
    Canada

    I read these two already, but it doesn't exactly answer my questions, because you see im a little behind on what happened very recently in the Vwii area so idk whats going on regarding hermes 222 and 223, yes i heard they dont work before, but what about now?

    EDIT: okay i tried putting in usbloader gx, it worked. cheats too. okay pretty much got everything needed except the homebrew browser...tried it before and it got dsi stack dump error....I'm guessing it doesnt work on the wii u or the one i used is just outdated?
     
  17. infinete

    infinete The Temp's cynic.

    Member
    5
    May 20, 2008
    London
    I have an issue. If I boot up the vwii with my "hidden" usb device attached I get the message "The system Files are corrupted. Please refer to the oppperations manual for help trouble shooting". If I unplug the hdd and reload vwii, all is good. Any ideas?

    This was done with Ustealth v7 on a windows 8.1 machine.
     
  18. Onion_Knight

    Onion_Knight GBAtemp Advanced Fan

    Member
    6
    Feb 6, 2014
    "unhide" the hard drive and plug it back in, launch vwii and hbc and see if it says that. You can use the .dol I created to "hide" the drive from within HBC. Ustealth can still see and unhide it as well.
     
  19. jayjay123
    OP

    jayjay123 GBAtemp Regular

    Member
    2
    Jul 24, 2013
    Are you using any particular USB port on the WiiU?
     
  20. infinete

    infinete The Temp's cynic.

    Member
    5
    May 20, 2008
    London
    Update: after some testing, it seems that this "corruption" is happening intermittently regardless, I think that Ustealth being the reason I found this is just a coincidence. I guess I may have to reinstall the wads from a backup I have made with FS-toolbox (by compiling the wads with "ShowMiiWads_Mod_v1.0_beta"). Or would it be better to find the wads elsewhere just encase my backup contains the corrupted files?
     
Loading...