Using Gateway on A9LH V2

Discussion in '3DS - Tutorials' started by Cosmic_Link, Jun 16, 2016.

  1. MelodySongz

    MelodySongz Newbie

    Newcomer
    1
    May 11, 2016
    United States
    Thank you.


    Yes, I have a9lh installed and recently updated to v2. I got the arm9loaderhax.bin. Thanks for the clarification.
     
  2. noctis90210

    noctis90210 GBAtemp Advanced Fan

    Member
    5
    Dec 24, 2013
    With these settings, which L and R and settings buttons are free... It means it will boot luma as same as using the original luma a9lh?
     
  3. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    9
    May 31, 2013
    Belarus
    Caves
    L & R are not used in that config, as they are omitted from it, as you can see. The original config by the OP boots GW by default, I just changed it so Luma defaults instead and removed L & R and you can alter it in anyway you want yourself.
     
  4. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    And to add to this, you don't have to have your a9lh.bin payloads on the root of your SD card. You could throw them into a payloads folder, or any folder for that matter, so long as you tell BootCtr9 where it is.
     
    Last edited by Temptress Cerise, Jun 19, 2016
  5. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    9
    May 31, 2013
    Belarus
    Caves
    Strange that D9 and Godmode would only boot from the luma/payloads folder and not from the root of the sd card, even though I told Ctr where to search them from and made sure they were on the root.

    Still haven't figured out why those particular ones caused an error??
     
  6. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    Odd. Did you have the / in front? Anyways. I don't have mine on the root. That's terribly messy and annoys me to no end. I have mine inside /k9lh/payloads :P I also have CtrBootManager9 on my BootCtr9 config, so when I want to look at a GUI menu for my payloads. ^_^
     
  7. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    9
    May 31, 2013
    Belarus
    Caves
    For example I had Decrypt9 labeled as "D9.bin" on the root and told Ctr that it was [KEY_X] path = /D9.bin, yet holding X on boot, threw an error and the system would shutdown. So i tested it with the other buttons and the same results but if I put say, Safe9installer on X, that would work and so a few others.
     
  8. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    Just tested this. Works fine on my end on root. However, I am using the latest released dev build, that was posted in the ARM9Loader Discussion thread.
    Link: https://gbatemp.net/threads/arm9loader-technical-details-and-discussion.408537/page-200#post-6373015

    My config.
    Code:
    [BOOTCTR9]
    screenEnabled = 1
    screenLog = 0
    fileLog = 0
    key_delay = 1000
    boot_splash = 1
    boot_splash_image = /k9lh/images/ctrbootmgr9_top.bin
    screenBrightness = 0xFF
    enableAutosoftboot = 0
    enableSoftbootSplash = 0
    
    ;BootAnim9 into Corbenik <3
    [DEFAULT]
    path = /k9lh/payloads/BootAnim9.bin
    delay = 200
    offset = 0
    payload = -1
    screenBrightness = 0xFF
    enableSoftbootSplash = 0
    
    ;CtrBootManager9 for Recovery Payloads + Luma3DS
    [KEY_DUP]
    path = /k9lh/payloads/CtrBootManager9.bin
    delay = 200
    offset = 0
    payload = -1
    screenEnabled = 1
    screenBrightness = 0xFF
    
    ;BrickWait Mode
    [KEY_DDOWN]
    path = /k9lh/payloads/GW9.bin
    delay = 200
    offset = 0
    payload = -1
    screenEnabled = 1
    screenBrightness = 0xFF
    
    ;Decrypt9WIP test on Key X
    [KEY_X]
    path = /D9.bin
    delay = 200
    offset = 0
    payload = -1
    screenEnabled = 1
    screenBrightness = 0xFF
     
  9. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    9
    May 31, 2013
    Belarus
    Caves
    lol @ brickwait mode.
     
  10. noctis90210

    noctis90210 GBAtemp Advanced Fan

    Member
    5
    Dec 24, 2013
    @retrofan_k just want to ask, im using no init a9lh, but using bootctr9, the backlight still blinks upon boot?
    any tips to turn it off?
     
  11. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    Set "screenEnabled = 1" to "screenEnabled = 0" and see if that works. Otherwise, no clue. As it does do it's own screen-initialization for payloads that do need it. Especially GW, which needs it.
     
  12. noctis90210

    noctis90210 GBAtemp Advanced Fan

    Member
    5
    Dec 24, 2013
    still with backlight blink upon boot...

    set screenBacklight = 0
    still with baclught blink upon boot...
    :-(
     
    Last edited by noctis90210, Jun 18, 2016
  13. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    I don't know, could look over the documentation for BootCTR9.
    Link: https://github.com/hartmannaf/BootCtr9

    Can't help you really. I use non-screen-init, but I actually just use BootAnim9 at boot, so it doesn't bother me one bit.
     
  14. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    9
    May 31, 2013
    Belarus
    Caves
    @noctis90210 I use screen-init a9lh and have the brightness @ 1x, so not really looked into that. I only tested the non-screen version to see if it worked.
     
  15. Neo Draven

    Neo Draven End Boss of the Entire Internet

    Member
    7
    May 3, 2010
    United States
    Everything I have seen says that if you use BootCTR, you can no longer play GBA or DSiWare games because of how much RAM the boot manager requires. That's not worth it for me to have Gateway mode.
     
  16. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    What? Where did you hear that? You should still be able to play GBA, DSiWare and games like Super Smash Bros. on Luma3DS while using BootCTR9. I am not sure about GW Mode, as we need a CFW that has reboot patches on o3DS. But on N3DS you really shouldn't have this problem in GW mode.
     
  17. TheBroCode

    TheBroCode GBAtemp Regular

    Member
    3
    Oct 31, 2012
    You just need to follow this extra step at the bottom of https://github.com/AuroraWright/Luma3DS/wiki/Installation-and-Upgrade

    then you can play GBA/DSi on Luma
     
  18. Neo Draven

    Neo Draven End Boss of the Entire Internet

    Member
    7
    May 3, 2010
    United States
    But if I can't even get the GW.3dsx file to boot from the HBL or from any other method, is there something I missed along the way? So far, nothing I've tried has given me anything but a black screen.

    I've tried both GW 3.71 and 4.0b2. I've tried replacing the armloader9hax.bin completely, tried renaming the GW payload to down_GW.bin and placing it in the Luma payloads folder, tried using the go-gateway-3ds.com site; nothing even lets me see the Gateway splash. No clue what I am doing wrong.
     
  19. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    9
    May 1, 2016
    United States
    I'll assume you are on v2 A9LH. In which case, you have to use BootCTR9 as this guide describes.

    Now if you don't want to use BootCTR9, and you want to use Luma3DS' chainloader for this, then you have to downgrade to v1 A9LH, or use a compatible v2 A9LH build.
    For a compatible v2 A9LH build, you have to compile it yourself.
    Link: https://gbatemp.net/threads/safea9lhinstaller.419577/page-29#post-6432075

    As for downgrading, your on your own for that.
     
    Neo Draven likes this.
  20. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    9
    May 31, 2013
    Belarus
    Caves
    Both of Gw's launcher.dat work when placed on the root using a 11.0 Luma sysnand i.e a cloned updated emunand to sysnand. Do you have a rednand/emunand setup, as there are supposedly problems using a emunand from what I saw, yet I never used a emunand on my setup because it's not needed really.

    If you want to downgrade to V1, flash the SysNand_Original.bin without keeping A9lh via Decrypt9 and start from there, since you have the OTP to do a V1 install. Use V1 (Data_input & Payload_input) files with Safea9lhinstaller 1.52.

    Imo, it is better do that above than actually uninstalling V2 and then installing V1 files.
     
    Last edited by retrofan_k, Jun 18, 2016
Loading...