USB Loader GX

By cyrex, Apr 19, 2009 6,127,259 27,249 40

  1. keyra

    keyra Spoderman self proclamed fan
    Member

    Joined:
    Dec 23, 2008
    Messages:
    820
    Country:
    France
    create a config folder on sdcard root
     
  2. Kittymat

    Kittymat GBAtemp Advanced Fan
    Member

    Joined:
    Oct 16, 2008
    Messages:
    589
    Country:
    Sideskroll - check this page out, make sure you delete ALL config files and the covers are not seen, you need to move them from the config folder to the GX folder in your apps folder, or just redownload them - http://code.google.com/p/usbloader-gui/iss...il?id=1718#c172

    SexyBack43 - what format is the HDD in (Fat32 - use 222 to start the loader) (WBFS use 222 or 249)
    Start the loader with NO drive connected, let it time out and it should let you in to the settings to check your config settings. Other choice delete your config files first then try again.
     
  3. sideskroll

    sideskroll GBAtemp Advanced Fan
    Member

    Joined:
    Aug 25, 2010
    Messages:
    652
    Country:
    Peru
    Tx Kittymat, I'll give it a try. I'm trying r1016 at the moment as I believe it is the latest rev.
    Any chance of "official" updates from the team? Like a new Windows installer etc? Thanks again.
     
  4. deakphreak

    deakphreak Spiffy Hacks
    Member

    Joined:
    Apr 21, 2009
    Messages:
    219
    Country:
    United States
  5. Kittymat

    Kittymat GBAtemp Advanced Fan
    Member

    Joined:
    Oct 16, 2008
    Messages:
    589
    Country:
  6. deakphreak

    deakphreak Spiffy Hacks
    Member

    Joined:
    Apr 21, 2009
    Messages:
    219
    Country:
    United States

    Thanks I will check it out. We need to be sure and keep up to date on changes so the themes through the downloader continue to work and we can continue to help out and provide themes for the software from our site.
     
  7. SexyBack43

    SexyBack43 Newbie
    Newcomer

    Joined:
    Dec 20, 2010
    Messages:
    4
    Country:
    Canada
    Thx everything perfect now, I had an old config file on my pc and it's working now!

    But now I have another problem. I'm trying to change my HDD. The new is formated on FAT32, then after that i formated it with WBFS Manager 3.0, everthing ok. I tested it with 1 game (NFS Nitro), plugged my hdd on my wii, and I was able to launch USB Loader GX and pla the game. No black screen, everything was fine.

    So I transfered some games from my old HDD to the new one that I tried this morning.... tried it just now and when I launch a game from USB Loader I got a black screen every time... on every game. Even NFS Nitro, the one that was working before.... I'm totally clueless on what I should do to make it work....
     
  8. doncaruana

    doncaruana Member
    Newcomer

    Joined:
    Dec 21, 2010
    Messages:
    38
    Country:
    United States
    I followed the updated guide for ios249 and I now have 249 rev 20 base 57 in slot 247 and base 56 in 248 along with 249 rev 17 in slot 249. In addition, I have hermes 224 v5.1 installed. Running it with GX r1016 and things seem to work okay with 248 (that's my base 56) as the default.

    Is there a recommended default given these ios? This is a new wii and while some things are working better (cake to get black ops working and mh3 required nothing), some others that worked on my other machine just black screen on me (Prince of Persia, several microphone games).

    So, a recommendation or even some hint on the black screen would be greatly appreciated!

    thanks
     
  9. PPSainity

    PPSainity Blinded by Science
    Member

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Got a question concerning the ReloadIosSafe function in IosLoader.cpp as of r1017. Of my concern is the handling of IOS250 in the else if(IsWaninkokoIOS(ios)) code segment. My understanding is that this code segment works for all Waninkoko's cIOS installed in any slot but 250. Waninkoko's cIOSx installer uses the actual cIOSx revision number as the IOS version when installing cIOS in all slots but 250. When Waninkoko's cIOSx installer installs a cIOS in 250 it will max out the version to 65535, which would pass the test clause (iosRev < 9 || iosRev > 30) and return a -22 as unsafe. Doesn't this cause a problem, maybe the problem I've been having???

    -[]D

    CODE/*
    * Reloads a certain IOS under the condition, that an appropriate version of the IOS is installed.
    * @return a negative value if a safe reload of the ios was not possible.
    */
    s32 IosLoader::ReloadIosSafe(s32 ios)
    {
    ÂÂÂÂif(IsHermesIOS(ios))
    ÂÂÂÂ{
    ÂÂÂÂÂÂÂÂs32 iosRev = NandTitles.VersionOf(TITLE_ID(1, ios));
    ÂÂÂÂÂÂÂÂif(iosRev != 4 && iosRev != 5 && iosRev != 65535)
    ÂÂÂÂÂÂÂÂÂÂÂÂreturn -11;
    ÂÂÂÂ}
    ÂÂÂÂelse if(IsWaninkokoIOS(ios))
    ÂÂÂÂ{
    ÂÂÂÂÂÂÂÂs32 iosRev = NandTitles.VersionOf(TITLE_ID(1, ios));
    ÂÂÂÂÂÂÂÂif(iosRev < 9 || iosRev > 30) //let's see if Waninkoko actually gets to 30
    ÂÂÂÂÂÂÂÂÂÂÂÂreturn -22;
    ÂÂÂÂ}
    ÂÂÂÂelse
    ÂÂÂÂ{
    ÂÂÂÂÂÂÂÂreturn -33;
    ÂÂÂÂ}

    ÂÂÂÂs32 r = IOS_ReloadIOS(ios);
    ÂÂÂÂif (r >= 0) WII_Initialize();

    ÂÂÂÂIosLoader::LoadIOSModules(IOS_GetVersion(), IOS_GetRevision());

    ÂÂÂÂreturn r;
    }
     
  10. outcast22

    outcast22 Advanced Member
    Newcomer

    Joined:
    Feb 2, 2009
    Messages:
    87
    Country:
    United States
    Sorry. Moved post
     
  11. dimok

    dimok GBAtemp Advanced Fan
    Member

    Joined:
    Jan 11, 2009
    Messages:
    728
    Country:
    United States
    @PPSainity
    I did not know that. I never used 250 and though it would show R20 or whatever the version is for all his IOSes. I will add a check for 65535 on Waninkokos IOSes too.
    Thanks for pointing it out.
     
  12. PPSainity

    PPSainity Blinded by Science
    Member

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Good timing Dude, I just made a post up on the 938+ thread...Were your ears twitching lol...

    Thanks for all your and everyone elses work on USB Loader GX. The new beta revisions are looking great! [​IMG]

    -Happy Holidays! []D
     
  13. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,307
    Country:
    France
    what's strange is that my reloading to 250 is working fine.
    I'll have to check my 250 version. Maybe the version is maxed out only when installing 249 and it creates 250 as a copy, and not when installing 250 alone ?

    I'll have to try cIOSr21 too [​IMG]
     
  14. davebaol

    davebaol GBAtemp Advanced Fan
    Member

    Joined:
    Sep 3, 2010
    Messages:
    912
    Country:
    Italy
    Well, only cios249 rev17 and lower revisions automatically install the cios in slot 250 with version v65535.
    Since rev18, which introduces slot and base selection, the version of the cios is the real one in every slot.
     
  15. PPSainity

    PPSainity Blinded by Science
    Member

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Waninikoko's cIOSx 20b Installer is weird in a few ways. When installing to IOS249, possibly others, but I haven't verified other cases, it will install something partial to IOS250. I say something partial because if you try to dump whatever it installs as IOS250 using BlueDump you get 0KB content oddly. If you explicitly use the installer to install IOS250 what it installs will always have a maxed out version number of 65535 and it will be the full pledged dump-able by BlueDump cIOS. At least this is the behavior I have always observed. I have yet to use the latest from Waninkoko, cIOSx rev21 and can't comment if these traits in the installer still persist.

    EDIT: Speaking of cIOSx rev21, has anyone took the bullet and try using it with any release of USB Loader GX? Anything to report?

    EDIT2: I thought I made an issue entry last night (admittedly I had a few special eggnogs) and I could not find it. So I made a new entry, issue #1752. Any information you can add will be appreciated. Also if everyone can confirm what version number their IOS250 has, and how it was installed, I'd appreciate that personally.

    -Happy Holidays! []D
     
  16. davebaol

    davebaol GBAtemp Advanced Fan
    Member

    Joined:
    Sep 3, 2010
    Messages:
    912
    Country:
    Italy
    Just checked.
    I can confirm the version is the real one when installing waninkoko's cios in slot 250:
    rev20b -> IOS250 v20
    rev21 -> IOS250 v21

    Oh, some games like Wii Fit Plus and New Super Mario Bross don't work anymore with rev21b and wbfs partition. Sorry I don't remember exactly the base I used when testing that games, maybe base 58 and that could be the problem.
    I've focused my test on usb device compatibility and rev21 seems to improve it a lot since 2 hd not working before now work great.
     
  17. PPSainity

    PPSainity Blinded by Science
    Member

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Can anyone else verify this. It can't be only me that Waninkoko's installer does this to...Is everyone using the installer from Waninikoko's blog???

    Just used Waninkoko's cIOSx rev20b Installer. I use IOS236 to do the install, and deleted IOS249/250 first using ATD. No matter if I installed IOS249 then IOS250 or vice-versa 250 had a max version number of 65535. I even installed IOS249, then deleted IOS250 using ATD, then installed IOS250, deleted using ATD, installed just IOS250, etc...each time 65535.

    davebaol can you provide more info please on what installer you used (a link to it would be nice), and any other info like a Syscheck report on IOS249/250.

    Here is the cIOSX_rev20b_Installer.zip I used from Waninkoko's Blog.

    Here's my Syscheck report, always the same...
    Code:
    "DOP-Mii Report"
    "Region", North America (U)
    "Hollywood Version", 0x11
    "Wii Unique DeviceID", xxxxxxxx
    
    IOS Version, FakeSign, ES_Identify, NAND, Flash
    "250 (v65535)",Enabled,Enabled,Enabled,Disabled
    "249 (v20)",Enabled,Enabled,Enabled,Disabled
    -Happy Holidays! []D
     
  18. Skiller

    Skiller GBAtemp Regular
    Member

    Joined:
    Mar 12, 2009
    Messages:
    146
    Country:
    Canada
    Humm never had the issue of when installing Ios 250 as something its being place as version 65535 it was normaly placed with version 20 .. but then again i always Delete Ios 250 before installing the Cios 250..
    but ya installing 249 does install 250 still as 65535..
     
  19. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,307
    Country:
    France
    Base 58 is currently less compatible than other base.
    The official USB support in IOS58 is different than the one in all other cIOS, so USBloaders will have to include the new code to their sources (Waiting for Waninkoko to release them).
    Until then, don't use base 58 to do loader's tests.



    About the 250, I don't remember any problem using cIOSrev20b installer. (I always use the official installer).
    Dop-Mii report 249 v17, and 250 v20

    I think (I don't remember well, sorry) I installed 249[56], then bluedump'ed 249 and 250.
    then re-installed 249rev17, and reinstalled 250[56] with a wad manager from my bluedump .wad
    Maybe I installed the 250 alone once, to try, and that's why I have v20.
     
  20. davebaol

    davebaol GBAtemp Advanced Fan
    Member

    Joined:
    Sep 3, 2010
    Messages:
    912
    Country:
    Italy
    @PPSainity
    Just used your link for rev20b and I always get the real version number v20.
    Don't know why you still get v65535, maybe a kind of bug in the installer.
    Oh I'm pal and you're ntsc but that should not be relevant.
    And I use wad install from sd and the base wad comes from nus.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Loader,