USB Loader GX

By cyrex, Apr 19, 2009 6,075,764 27,120 40

  1. CopyCaet

    CopyCaet Member
    Newcomer

    Joined:
    Jan 7, 2009
    Messages:
    35
    Country:
    Netherlands
    I just tried rev 995 and already ran into a couple of issues.
    First off all, at the first run, it took about 30-60 seconds before anything showed up at all besides the background and cursor. At the other runs, or when leaving the settings menu, it took about 10 seconds for the game list too load. I take it the extra delay at start has something to do with generating new configs.

    The games itself wouldn't run either. Not when using Hermes 222 with 38 base (v5,1, but also tried v4), and not when using latest cIOSx (rev20, also tried rev 17 and 19). This is an issue I've seen in every 990+ revision. Only with NTFS though, and I haven't tried anything between rev 938 and 990.

    I was about to say I didn't run into any issues when using a WBFS partition, although I just had a black screen with Toy Story 3.. AFTER the pixar cinematic. Other games seem to work fine though.. weird, as TS3 worked before.

    That's what I've encountered in the new revs so far, hope it's of some use. Running a 4.3E Wii btw.

    Edit: Forgot to mention that the long loading only occurred when using NTFS.

    Edit2: Looks like Toy Story 3 works with rev 994, but not in 995. Thing I noticed is that in rev 995, you get a black screen followed by the pixar cinematic. It skips the "strap your wii mote like this" and the "this game requires a nunchuck" pictures. So after starting it in USBGX its like Black - Pixar - Black freeze in rev 995. This is when running off of a WBFS partition. As i mentioned before, i cant get to load any game at all from NTFS or FAT32 in rev 990+
     
  2. r-win

    r-win GBAtemp Fan
    Member

    Joined:
    Oct 10, 2009
    Messages:
    453
    Country:
    Netherlands
    I totally love this dimok [​IMG]
    Anyway, well done
     
  3. bula

    bula GBAtemp Advanced Fan
    Member

    Joined:
    Feb 4, 2009
    Messages:
    812
    Country:
    United States
    I am getting a code dump when I download wiitd.

    [​IMG]
     
  4. dexter222

    dexter222 GBAtemp Fan
    Member

    Joined:
    Apr 19, 2009
    Messages:
    337
    Country:
    United States
    I'm an ass but I want to test anyways [​IMG]

    Let me know if there are any specific configurations you'd like tested.

    Thank you for taking the time to work on this.
     
  5. dimok

    dimok GBAtemp Advanced Fan
    Member

    Joined:
    Jan 11, 2009
    Messages:
    728
    Country:
    United States
    Thanks for testing but I opened up the issue because i wanted the people to post the problems there and not on this forum. I am not looking into this forum very often usually.

    Yep it's needed. Please post on the issue thread some link to the screenshot.
     
  6. dimok

    dimok GBAtemp Advanced Fan
    Member

    Joined:
    Jan 11, 2009
    Messages:
    728
    Country:
    United States
    @CopyCaet
    All your issues should be fixed with the R996. I uploaded the new test version. You can find a link in the issue thread.
     
  7. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,284
    Country:
    France
    I helped dimok to debug a lot of thing in the pre-pre-pre alpha r996 [​IMG]

    There's a lot of bugs fixed in 997.
    but mainly :
    - Language change fixed
    - Wiitdb download fixed (For Bula [​IMG] )
    - New file sorting options (you can now sort file even if favorite is ON, and you can sort by rank even if favorite is OFF)

    You can check the latest issue from google code for more info and if you want to help too.
    Just do many tests before reporting an issue (clean settings, different cIOS, different partition format, etc.), so you know what is causing the error. It will speed the problem resolution.
     
  8. bula

    bula GBAtemp Advanced Fan
    Member

    Joined:
    Feb 4, 2009
    Messages:
    812
    Country:
    United States
    Same thing with 997, I still get a code dump when download witdb..
     
  9. dun4cheap

    dun4cheap GBAtemp Regular
    Member

    Joined:
    Mar 15, 2009
    Messages:
    179
    Country:
    United States
    I tried r996 yesterday and it does not recognize my mixxed wbfs and ntsc drive. Went back to R899 and it works. Let me know if I can test anything regarding this scenario, but its pretty much a show stopper.
     
  10. TheWon

    TheWon GBAtemp Fan
    Member

    Joined:
    Sep 30, 2008
    Messages:
    384
    Country:
    United States
    Has anyone gotten Hawx 2 to work on GX. It seems to freeze after the Ubisoft logo.
     
  11. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,284
    Country:
    France
    Which size is your drive ?
    It seems 1.5Tb+ drive doesn't work with revisions past 899.
    If it's your case, then it's a known issue.

    If your drive is shorter, then I guess we will need to check this issue.
    I don't have a mixed NTFS one (only a 250Gb FAT32+WBFS) to test myself.
    Maybe we will need someone with a big drive willing to help with future test-revisions.


    PS for testers : Use 997 instead of 996 if you want to report your results, as few corrections has been made.
    If you have code dumps, take a screenshot, or report the "Stack dump" block.
     
  12. dun4cheap

    dun4cheap GBAtemp Regular
    Member

    Joined:
    Mar 15, 2009
    Messages:
    179
    Country:
    United States
    I will try 997 tonight or tomorrow, work is getting in the way.
     
  13. myron0815

    myron0815 Member
    Newcomer

    Joined:
    Feb 14, 2009
    Messages:
    40
    Country:
    United States
    oookay.
    Since its positive feedback, posting it here [​IMG]

    I'm on 4.1E, 249v20 (default base), 222v5, NTFS;
    Had extreme problems running games with rev ~900-990. Most of the time black screen regardless what cios used.
    Worked for some game, but not for others.

    But now... dont know how to say... EVERYTHING WORKS with r997 !!!
    Tried several games; this is the best version since latest stable ^^

    Thanks dimok et all for ending the summer hole [​IMG]
     
  14. dexter222

    dexter222 GBAtemp Fan
    Member

    Joined:
    Apr 19, 2009
    Messages:
    337
    Country:
    United States
    r997 didn't recognize the drive. With the forwarder it simply stalled at the "Loading..." screen. When 997 was loaded from homebrew it simply counted down. Drive is 2tb with a small FAT32 boot partition and the rest NTFS with a little over 900 NTSC-U games on it. Drive works with r899 (nothing after). I deleted config files, installed Hermes 222 V5.1 and cIOS 249 rev 20.
     
  15. halen

    halen GBAtemp Regular
    Member

    Joined:
    Oct 19, 2010
    Messages:
    135
    Country:
    Brazil
    My problem is the same of dexter 222. R997 e 996 didn't recognize the HD drive of 2tb with NTFS partition e games in iso files. When 997 was loaded from homebrew it simply counted down. Drive works with r899 (nothing after). I deleted config files, installed Hermes 222 V5.1 and cIOS 249 rev 20. Today CFG e Wiflow recognize the HD. I hope that the team get R998 to work with +2tb drivers.
     
  16. maceds

    maceds Newbie
    Newcomer

    Joined:
    Nov 10, 2010
    Messages:
    6
    Country:
    United States
    I have a problem with Sonic Colours(Pal) and USB Loader GX
    I used USB loader GX with the latest Cios and the game played smoothly until i got to the 3rd Act of Tropical Island. The level wont load ,the music stops and the screen goes black after about 10 seconds. After a few tries, I started a new game and used Gamma r9 to load the game this time and nothing changed? Is there a fix for this?
     
  17. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,284
    Country:
    France
    You are saying that using another loader doesn't fix your problem ?
    Then it's not a loader problem. it's more your game dump, or cIOS problem.
    Did you try other IOS base/version ?

    You have plenty to try out :
    hermes v4 (37+38)
    Hermes v5 (all based one)
    cIOS rev17
    cIOSx 20 (many base to try too)

    Note that official release of USBloader GX are not compatible cIOSx or Hermes v5.
    You can still try it with rev 921-930.

    Then, did you check the game release topic ?
    does anyone else have the same problem ?
     
  18. maceds

    maceds Newbie
    Newcomer

    Joined:
    Nov 10, 2010
    Messages:
    6
    Country:
    United States
    ok thanks ill try the different bases and see if that works
    thanks [​IMG]
     
  19. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,284
    Country:
    France
    the common bases are :
    Hermes v4 [37+38]
    Hermes v5 (all of them)
    cIOSx : 37, 38, 56 (Other bases are not really needed.)

    Problematic games usually require a base 37+38 for music games and Monster hunter tri.
    Only 1 game (which I know) need base 56 : Arc Rise Fantasia
     
  20. maceds

    maceds Newbie
    Newcomer

    Joined:
    Nov 10, 2010
    Messages:
    6
    Country:
    United States
    Awsome
    I got it to work
    I used CFG Loader and me and my friend figured it out with the bases
    thanks for all ur help [​IMG]
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Loader,