USB Loader GX doesn't mount my flash drive

Discussion in 'Wii - Backup Loaders' started by klinkowski, Jul 28, 2016.

  1. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    Hi everyone! I recently got a WII and I'm exploring this new world of wii hacking, homebrew and all that stuff. I have a strange issue with my wii and USB loader GX...

    My Flash Drive is a SanDisk Cruze Blade 16GB, it IS listed at the compatibility chart and it indeed works with homebrew channel and some music players, but not with USB Loader GX. The error message:

    "USB device not initilized. Switching to channel list mode"

    I have one game in wbfs format, The Legend of Zelda Twilight Princess. I've tried installing another versions of the cIOS 249 and 250. My initial config was with ModMii and everything went ok. I'm lost here...
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,913
    Oct 27, 2002
    France
    Engine room, learning
    Flash drives are known to be less compatible with Wii and WiiU.
    external hard drives (preferably usb2.0) have better compatibility.

    What you can try :
    in USBLoaderGX, go to the settings>loader settings>Loader's IOS : set the value to 58 and reboot the loader.
    You might have to re-enable the Wii game listing if the loader disabled them due to USB not detected on previous launch. (4th icon in the top menu)

    If it works and is detected, it will still have issues : you can't dump a disc to ISO with flash drive.
     
  3. Vishnoo

    Vishnoo Failure is success if we learn from it.

    Member
    261
    32
    Jun 1, 2016
    India
    Did you try using both slots.USB Loader GX supports only one slot.
     
  4. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    IOS 58 worked, thanks.
    Do you have any explanation about it? I would like to understand more

    And I will buy one ext HD for the wii, this is only a test to see if it would work
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,913
    Oct 27, 2002
    France
    Engine room, learning
    the cIOS are based on existing IOS (they are edited IOS).
    The IOS "base" used by USBLoaders doesn't have USB2.0 support (usually IOS56 and IOS57) and the homebrew developers added support for USB2.0 based on an open source library.
    It seems the flashdrive have issues with that library, or with the cIOS sources or implementation itself.

    Nintendo later released official devices which required USB2.0 (WiiSpeak) and released an official IOS with USB2.0 : IOS58 and even later IOS59.
    the IOS58 use its own official USB driver and is more compatible with existing devices than the USB library used in cIOS. Nintendo knows its hardware better than us, it's easier for them to develope better drivers.

    There is a cIOS based on IOS58, I think the cIOS doesn't "patch" the USB module as it's already present and it was decided to keep nintendo's driver for that cIOS.
    If you have cIOS base58 installed, you can try it too, but it's not compatible with many games so don't use it as "game's IOS", only as "Loader's IOS".

    The loader's IOS is the IOS loaded in memory while inside the loader. used to access the drive's file content, etc., You can use an official IOS (but only IOS58 is allowed in the settings)
    the Game's IOS is the IOS loaded in memory before booting a game and require additional patches, like "disc access redirection to USB" or "prevent HDD sleep mode" or "WBFS, FAT32 and NTFS support" etc., so only cIOS slot >200 are selectable in the settings.
     
  6. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    Great info sir.
    I will buy one HDD now, it needs an Y cable right? I only have usb 3.0 hds here and they don't work properly with the wii.

    I installed d2x cIOS 249 (base 56) and 250 (base 57), tried with v8, v10 beta52 and beta-alt53. The current one is v10 beta52
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,913
    Oct 27, 2002
    France
    Engine room, learning
    The Y cable is required on WiiU, but not always required on Wii (it depends how much power is needed by the HDD).
    If it makes clicking noises, or if the game freeze or doesn't boot, it's required.

    I know there is a problem with some USB3.0 (especially Western Digital Element), I don't know why yet. It's usually only an initialization issue, and using IOS58 fix the issue.
    Maybe I'll add an automatic "try to reload to IOS58" at launch if the drive is not detected.

    v8 and v10 are fine.
    Don't use v10-alt if you don't need dual USB port support, it will add issues with emuNAND feature.
     
  8. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    Now I have another problem...
    Black screen after trying to load a game
    Tried with internet iso using wii backup tool and a dump I made
    Now I'm using a HDD that only works with ios58 too
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,913
    Oct 27, 2002
    France
    Engine room, learning
    maybe the issue is that the wii reloading to cIOS before launching the game is the issue.
    if your drive works only with IOS58, then reloading to 249 will be an issue.
    You can try to install d2x base58, but it's not working with all games.

    sometime the issue is only "initializing" the drive, once it's spinning then the IOS reloading works fine.
    but maybe your drive is really not compatible with cIOS. that's strange if it's a USB2.0 as they are usually working fine.
     
  10. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    I will try with base 58 and report back. The drive I bought is from samsung, M2 Portable usb 2.0.

    cIOS 249 with base 58 started the game and gameplay was smooth. But everytime I open the usb loader GX settings the DSI exception error appears. I don't even need to change something. open the settings and close it equals to all icons disappearing and exception (DSI) occurred!
     
    Last edited by klinkowski, Jul 28, 2016
  11. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    cIOS 249 with base 58 started the game and gameplay was smooth. But everytime I open the usb loader GX settings the DSI exception error appears. I don't even need to change something. open the settings and close it equals to all icons disappearing and exception (DSI) occurred!
     
  12. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    USB2 device test program. v1.1
    ------------------------------
    usbstorage init
    status1: 0x1803
    status2: 0x1101
    port reseted status(0): 0x1803
    status2: 0x1101
    port reseted status(1): 0x1803
    status2: 0x1101
    port reseted status(2): 0x1803
    status2: 0x1101
    port reseted status(3): 0x1803
    PORT_PE, release USB11 status: 0x3002

    same problem: https://gbatemp.net/threads/increase-read-speed-cios-with-base-58.330542/
    Sad...
    I think I will sell it
    Or there's a solution to this?
     
  13. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,564
    8,913
    Oct 27, 2002
    France
    Engine room, learning
    I didn't thought about that issue. that was kind of rare.

    in that thread, I mentioned my cousin's Wii having the same issue.
    He bought a WiiU and as he could hack vWii he gave me that console, which supposedly wasn't working with cIOS. I thought I will be able to check more about that issue, but surprisingly, cIOS are working fine now ! without any changes or new IOS or cIOS install.
    I don't know what changed, except maybe the Wii settings itself.

    so before selling it, maybe try different things (reseting the wifi settings, or the console's name, etc.), because I really didn't do anything else.
    maybe he did something I don't know, but he is not capable of hacking it by himself, so he wouldn't have fix it. something happens, I don't know what.
     
  14. klinkowski
    OP

    klinkowski Newbie

    Newcomer
    8
    1
    Jul 28, 2016
    Brazil
    Tried everything, no progression... The only thing I didn't do was "updating" the wii. If somehow, someday, my wii happens to use the cIOS correctly I'll send you a message
     
    Cyan likes this.