USB Loader GX and d2x IOS installer problems

Discussion in 'Wii - Hacking' started by DragonSlaya76, Nov 25, 2015.

  1. DragonSlaya76
    OP

    DragonSlaya76 Newbie

    Newcomer
    2
    0
    Nov 25, 2015
    United States
    I got the Homebrew Channel and USB Loader GX, I used the WiiBackupManager and was able to make the game show up and I tried pressing play but there was a black screen and I was back in the Homebrew Channel.

    I looked around the forums here and I tried using the d2x cIOS installer and I tried following the directions but d2x v8 final was not an option because d2x v6 is the latest one I see on the d2x installer version: 3.1 (I have the folders for v7, v8, and v10 in the installer folder but they do not appear when I am on it).

    I was confused on why d2x v8 final was not an option and thought the installation was somewhere else and I pressed A and went to 249 on the slot map and pressed A again to install the cIOS to 249 on slots map. (249 and the rest were stubbed purple on the slot map.)

    Settings I installed to 249 on the slots map:
    Select cIOS <d2x v6>
    Select cIOS base <37>
    Select cIOS slot <249>
    Select cIOS revision <21006>

    The 249 turned red so it is now ACTIVE (c)IOS

    Then I tried:
    Select cIOS <d2x v6>
    Select cIOS base <56>
    Select cIOS slot <249>
    Select cIOS revision <65535>

    Because the forum told me so I tried what I could do...

    Select cIOS <d2x v8 final>
    Select cIOS base <56>
    Select cIOS slot <249>
    Select cIOS revision <21008>

    I know now that the right cIOS never showed and I found out later that USB Loader GX does not detect my HDD anymore so I am stuck really bad now so please help me and my lack of knowledge on this.

    Forum I used:
    https://gbatemp.net/threads/usb-loader-gx-kicking-me-back-to-homebrew-menu.396060/
     
  2. Subscriber0101

    Subscriber0101 GBAtemp Regular

    Member
    137
    13
    Jun 9, 2015
    United States
    USA
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,027
    8,549
    Oct 27, 2002
    France
    Engine room, learning
    v6 was the current available release when that installer was released. so by default it has v6 integrated.
    to add new version, you need new folders and a proper ciosmaps.xml

    The link found in the thread you linked is good.
    This is a compilation of installer and latest d2x I made.

    http://www.mediafire.com/download/5ggh53tj9hhp1tr/d2x-cios-installer-3.1-v6-v7-v8-v10-wii.7z

    It doesn't contain the Ustealth-emunand compatible d2x v10 r52, but you shouldn't need it if you are not on WiiU.

    if you extract all the content into a folder on /apps/ it should work.

    sd:/apps/installer/boot.dol
    sd:/apps/installer/meta.xml
    sd:/apps/installer/icon.png
    sd:/apps/installer/ciosmaps.xml
    sd:/apps/installer/7/
    sd:/apps/installer/8/
    sd:/apps/installer/10/
     
    cvskid likes this.
  4. pragmaticman

    pragmaticman Newbie

    Newcomer
    3
    0
    Nov 28, 2015
    United States
    Edit:
    So I ran another hack on my Wii using ModMii wizard installing WADs and upgrading to 4.1U. I still cannot get USB Loader GX to recognize any of my USB drives, I've tried 2. Also have tried both USB ports. WiiFlow reads my HDD but fails loading the game.

    I was able to get my game to load from the SD card by 'Configurable USB Loader' but I wish I could install the game to the Wii HDD. WiiFlow reads my HDD but fails loading the game.


    TLDR; USB Loader GX does not recognize my USB HDDs.



    Original:
    I am having the same trouble as OP. I launch a game from USB in the loader and it goes back to HBC. I started from v3.4U. Used BanneBomb to softmod, installed HBC, and IOS 58.

    I ran through the tutorial @Subscriber0101 posted above. @Cyan posted pretty much the same files from the tutorial. d2x says "Current IOS: 58 v6175." Do I need to 'load' the installed in slot 249?

    USB Loader GX no longer reads my USB drive (I tried 2 formatted FAT32) and WiiFlow takes me back to HBC when I try to launch a game. I'm at a loss. Installing emulators was very simple, this is more complex.

    Edit: @DragonSlaya76 have you got this working?

    System Check. It couldn't hurt :).
    Warning: Spoilers inside!
     
    Last edited by pragmaticman, Dec 3, 2015
  5. DaMan4169

    DaMan4169 Advanced Member

    Newcomer
    95
    4
    Aug 12, 2009
    United States
    Prag,
    Reinstall HBC so it runs on IOS58.
    If you don't already have a HackMii_Installer folder in your apps folder, create one and copy the boot.elf from HackMii installer there.

    Also if that is your current syscheck, you are still on 3.4 with a bunch of outdated/missing game IOSs, guess it's not really an issue if you play from USB but you haven't actually updated your Wii yet.
     
  6. pragmaticman

    pragmaticman Newbie

    Newcomer
    3
    0
    Nov 28, 2015
    United States
    I reinstalled HBC. USB Loader GX still doesn't work with any of my USB drives. Is it possible all the drives I'm using are incompatible?

    Another syscheck ran yesterday:
    Warning: Spoilers inside!

    --
    prag
     
  7. DaMan4169

    DaMan4169 Advanced Member

    Newcomer
    95
    4
    Aug 12, 2009
    United States
    It's possible all the drives are incompatible but make sure you also have the latest GX version this installer will download the latest version to your computer then just transfer to SD/USB, whichever you use for homebrew.

    edit to add:

    I use SanDisk for smaller capacity drives and WD My Book for larger capacity.
    I did have a couple of PNY drives that didn't work and a functional Transcend 2GB in the past.
     
    Last edited by DaMan4169, Dec 4, 2015
  8. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,943
    758
    Mar 2, 2015
    United States
    Google Code is no longer current. That installer downloads a version that's well over a year old.

    http://sourceforge.net/projects/usbloadergx/ is the current repository.
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,027
    8,549
    Oct 27, 2002
    France
    Engine room, learning
    I have to update the installer to download from sourceforge.
    Dimok made a version, but it's only for the dol, not the forwarders and only for wii not vWii.

    I wanted to update it but didn't do it yet.

    You can use any loader version, it will prompt you to update to r1256 if you enable online in the loader.
    the internal update from old versions will work until december 31 2015, after that Google will shutdown their servers.
     
  10. m4rc0175

    m4rc0175 Newbie

    Newcomer
    3
    1
    Oct 18, 2016
    Belgium
    Question:

    I have the USBloader_GX working via the HBC. All works fine.
    But The forwarder just resets the wii and get me back in the menu with all the channels.

    I'm sure I have all the latest versions of the loader and forwarder.

    My Wii is a 4.1e version. I softmodded it like 8 years ago I think... not sure but a long time.

    What can be wrong why the forwarder is just resetting to the menu with the channels instead of starting the loader... (loader via HBC works fine)
     
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,027
    8,549
    Oct 27, 2002
    France
    Engine room, learning
    two possibilities :

    1. you don't have IOS58 (I don't remember which version it was added). Check your HBC>Home button to see if it's using IOS58.

    2. you installed the forwarder, but you didn't place the actual homebrew on the SD or USB.
    You need to put the loader in this folder : /apps/usbloader_gx/boot.dol
     
  12. m4rc0175

    m4rc0175 Newbie

    Newcomer
    3
    1
    Oct 18, 2016
    Belgium
    I have the HBC 1.0.6 on ios61 v19.26

    I have the homebrew boot.idol in the usbloader_gx folder in apps

    How to I get that HBC on ios58?
     
  13. m4rc0175

    m4rc0175 Newbie

    Newcomer
    3
    1
    Oct 18, 2016
    Belgium
    Fixed it ;-)

    First I upgraded the HBC to version 1.1.2
    The I downloaded a ios58installer and ran it
    Then HBC was still on ios61
    The I "upgraded". HBC to version 1.1.2 again.

    Now forwarder is working

    Thanks for pointing out ios58!
     
    Cyan likes this.