Homebrew USB file browser WAY too slow in GenPlus.

PetMetroid

Active Member
OP
Newcomer
Joined
Mar 27, 2012
Messages
34
Trophies
0
Age
34
Location
Long Beach, CA
XP
87
Country
United States
I know I recently asked another question, sorry.
I have the latest version of GenPlus GX (1.6.0) and a USB drive with a FAT partition to load ROMs from, but it browses WAY too slow. I'm running it off the HBC with the latest version on IOS 58. On my other Wii, however, it has no problem (with a tiny bit of lag though) and that loads from a flash drive with the exact same files on it. And THAT one I use a forwarder with (using IOS 58). I tried searching for others with this problem, but I only see people having problems with forwarders, and mine is quite the opposite. The other Wii (working one) is newer so maybe it's IOS 58 is more updated than the other? (Going to bed, not gonna check.) IDK, any suggestions?
 

FIX94

Former Staff
Former Staff
Joined
Dec 3, 2009
Messages
7,284
Trophies
0
Age
28
Location
???
XP
11,223
Country
Germany
That can't be, IOS58 is IOS58 ;) You could also use wiiflow to play via genplus if you want, that might be faster.
 

Jacobeian

Well-Known Member
Member
Joined
May 15, 2008
Messages
1,893
Trophies
0
XP
386
Country
Cuba
I had this problem long time ago with emulators when loading large files after they switched to use IOS58 for usb2: you need to make sure HBC is actually running on IOS58 and if not, re-install HBC after installing IOS58 (if not already there) so it uses it when loading apps.
 

FIX94

Former Staff
Former Staff
Joined
Dec 3, 2009
Messages
7,284
Trophies
0
Age
28
Location
???
XP
11,223
Country
Germany
I had this problem long time ago with emulators when loading large files after they switched to use IOS58 for usb2: you need to make sure HBC is actually running on IOS58 and if not, re-install HBC after installing IOS58 (if not already there) so it uses it when loading apps.
AFAIK genplus doesnt even load USB if IOS58 is not used.
 

Jacobeian

Well-Known Member
Member
Joined
May 15, 2008
Messages
1,893
Trophies
0
XP
386
Country
Cuba
I don't see why it wouldn't, all ios can load from usb, and it's not related to the homebrew itself but libfat/libogc low-level drivers.

However, some hdd requires usb2 to work properly, which is only possible through ios58 for homebrew. I guess some homebrew automatically reload it on startup while some others let this task to the app loader itself...

Anyway, slower loading/browsing is definitively caused by the drive operating at usb1 speed, which means the emulator is not running on ios58. This one in partixuar is slow in browser probably because it loads screenshots file while browsing...
 

PetMetroid

Active Member
OP
Newcomer
Joined
Mar 27, 2012
Messages
34
Trophies
0
Age
34
Location
Long Beach, CA
XP
87
Country
United States
Yeah, it lags like it's thinking about something each time I hover over a file, like the stupid cover art I don't really care about. I could try reinstalling HBC (I'm not home) but it's already on IOS 58. I deleted the IOS reloading tag in the META file just in case. I have a small idea of what that's for, but I never seem to see a difference anyway. If it's any constellation, it's a large hardrive that came with a double plugged USB cable for more power. Would that help if I gave it more power or no?
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: Still banging chicks lol