Updating to 5.50

Discussion in 'PSP - Games & Content' started by blackhand89, Sep 21, 2009.

Sep 21, 2009

Updating to 5.50 by blackhand89 at 8:01 AM (1,098 Views / 0 Likes) 13 replies

  1. blackhand89
    OP

    Newcomer blackhand89 Newbie

    Joined:
    Sep 21, 2009
    Messages:
    7
    Country:
    United States
    I dont know if there is a legit one yet but my psp is at 5.00 M33-4 and at 1000 series and want to know how to update
    My friend helped me hacked it and want to know if doing a system update is ok to get the latest firmware or do i require to do something out of the ordinary.
     
  2. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom

    read the PSP section regarding updating to GEN custom firmware [​IMG]

    there is NO M33 5.50 firmware!
     
  3. Raika

    Member Raika uguu

    Joined:
    Sep 15, 2008
    Messages:
    4,864
    Location:
    uguu
    Country:
    Antarctica
    Dark Alex also said that there won't be a 6.00m33 I think. I just hope that we get a new CFW soon, there are so many good games that need 5.55 firmware.
     
  4. blackhand89
    OP

    Newcomer blackhand89 Newbie

    Joined:
    Sep 21, 2009
    Messages:
    7
    Country:
    United States
    will updating it cause the psp to brick cause i might tempt to try it out
     
  5. ConJ

    Member ConJ The Toker

    Joined:
    Jul 18, 2008
    Messages:
    918
    Location:
    Glastonbury
    Country:
    United Kingdom
    No it wont brick, if you update you will have M33-6.
     
  6. Raika

    Member Raika uguu

    Joined:
    Sep 15, 2008
    Messages:
    4,864
    Location:
    uguu
    Country:
    Antarctica
    If you do it correctly you won't brick, but if you update to OFW you won't be able to play downloaded games anymore.
     
  7. blackhand89
    OP

    Newcomer blackhand89 Newbie

    Joined:
    Sep 21, 2009
    Messages:
    7
    Country:
    United States
  8. nIxx

    Member nIxx GBAtemp Maniac

    Joined:
    Sep 30, 2007
    Messages:
    1,459
    Location:
    Germany
    Country:
    Germany
    I wouldn´t use the GEN CFW (it just have bugs) and it will anyway not help because most of the newer games use 5.55 and not 5.50
     
  9. Raika

    Member Raika uguu

    Joined:
    Sep 15, 2008
    Messages:
    4,864
    Location:
    uguu
    Country:
    Antarctica
    If we want to play the newer games we would have to wait for a new firmware to be released, and wait for DA to make a new CFW, although it won't happen soon.
    I suggest you don't use the GEN firmware, it has bugs, and like what n1xx said most new games require 5.55.
     
  10. blackhand89
    OP

    Newcomer blackhand89 Newbie

    Joined:
    Sep 21, 2009
    Messages:
    7
    Country:
    United States
    so is it a green light to update or wait a bit?
     
  11. Raika

    Member Raika uguu

    Joined:
    Sep 15, 2008
    Messages:
    4,864
    Location:
    uguu
    Country:
    Antarctica
    I suggest that you wait for a bit, but it's your choice.
     
  12. blackhand89
    OP

    Newcomer blackhand89 Newbie

    Joined:
    Sep 21, 2009
    Messages:
    7
    Country:
    United States
    hm i recently finish patapon 2(great game btw) and I wanted to try out Tales of VS but i need the update to play it
    is there any good rpgs coming out that doesnt need the update
     
  13. nIxx

    Member nIxx GBAtemp Maniac

    Joined:
    Sep 30, 2007
    Messages:
    1,459
    Location:
    Germany
    Country:
    Germany
    Most likely yes but who really knows anyway there is no real solution to play these games yet. Except you buy the game and use the OFW [​IMG]
     
  14. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    blackhand, It's certainly a green light to update to 5.00M33-6. There's no reason for you to remain of 5.00M33-4.
     

Share This Page