Updating Luma error

Discussion in '3DS - Flashcards & Custom Firmwares' started by vinstage, Aug 9, 2019.

  1. vinstage
    OP

    vinstage sweg

    Member
    7
    Jan 24, 2017
    Korea, North
    Attempting to update Luma after god knows how long of abandoning my 3DS (has b9s btw). On the Luma Updater it seems to fail due to incompatible update path, fix?
     
  2. NeoSDAP

    NeoSDAP Newbie

    Newcomer
    1
    May 8, 2019
    Guatemala
    Guatemala City
    Do you have the Luma3DS Updater app updated?

    You can also update it manually by downloading it from GitHub
     
  3. vinstage
    OP

    vinstage sweg

    Member
    7
    Jan 24, 2017
    Korea, North
    Yeah, the app is giving me the error. I'm trying it manually now, right now my payloads are on v7.1 iirc
     
  4. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    11
    Nov 21, 2005
    United States
    Quantumcat and tabzer like this.
  5. NeoSDAP

    NeoSDAP Newbie

    Newcomer
    1
    May 8, 2019
    Guatemala
    Guatemala City
    If you have Luma 7.1 you most likely have B9S 1.0/1.1 installed as well.

    Remember that Luma 8 onwards, require B9S 1.2 or higher to operate.

    I would recommend upgrading B9S first and then updating Luma
     
  6. vinstage
    OP

    vinstage sweg

    Member
    7
    Jan 24, 2017
    Korea, North
    Last edited by vinstage, Aug 9, 2019
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Additionally, the version of Luma Updater that was current back then no longer works as GitHub dropped support for older SSL/TLS versions (which is all the 3DS supports natively), so a manual update is required to get stuff like Luma Updater and FBI self-update and QR code installs working again.
     
  8. KleinesSinchen

    KleinesSinchen The backup reminder

    Member
    8
    Mar 28, 2018
    Germany
    Are you sure you are using B9S and Luma v7.1? Hold (Select) while booting to bring up the Luma settings. On the top of the upper screen it should say:
    Luma3DS v??? configuration

    If the version number is v7.0.5 or lower you have A9LH: A9LH → B9S
    For v7.1 → Updating B9S. (As this gave you trouble because no chainloader menu appearing there might be some problem with the SD)
    For v8.0 or higher → Replace boot.firm with the latest version.

    Please make sure to update GodMode9 as well as the boot.firm on the NAND.

    Huh?
     
  9. vinstage
    OP

    vinstage sweg

    Member
    7
    Jan 24, 2017
    Korea, North
    The chainloader menu loaded after renaming the B9S installer to 'start_SafeB9SInstaller.firm' and it seemed to install but now I'm receiving an unsupported launcher error (argc = 0)

    Fixed it. Thank you all.
     
    Last edited by vinstage, Aug 9, 2019
    KleinesSinchen likes this.
  10. NeoSDAP

    NeoSDAP Newbie

    Newcomer
    1
    May 8, 2019
    Guatemala
    Guatemala City
    That's because your installed version of B9S is incompatible with the version of Luma you have on your SD.

    You can easily fix it by updating B9S
     
  11. N7Kopper

    N7Kopper Proud lover of a three-inch girlfriend

    Member
    4
    Aug 24, 2014
    United Kingdom
    You could also switch to Fastboot 3DS. It's a more feature-filled alternative for boot9strap that natively supports multiple payloads; convenient for people who might need to boot an arbitrary .firm file, or for people like me who enjoy fancy menus.
     
  12. Mikitok

    Mikitok GBAtemp Regular

    Member
    1
    Jan 14, 2019
    New Zealand
    NEVER use Luma3DS Updater

    Update luma manual and 0 problems
     
  13. vinstage
    OP

    vinstage sweg

    Member
    7
    Jan 24, 2017
    Korea, North
    If I wasn’t so noob with a lot of this stuff it’d be really appealing but I’m just happy sticking to the common choice just because it seems more noob proof haha. Thank you though!
    How come could I ask? Aside from a couple of bumps I’ve had a rather easy time with it in the past but that could be why; outdated.
     
  14. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Luma Updater is fine, but it requires manual updates so frequently that it kind of defeats the purpose. It might be worth it for someone to make a Luma Updater Updater.
     
    vinstage likes this.
Loading...