Updating 3ds to newer CFW

Discussion in '3DS - Flashcards & Custom Firmwares' started by RyviusRan, Sep 9, 2019.

  1. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    I haven't really fiddled with my 3ds since 2016.
    I was using Cakes with arm9loaderhax and judging by my files I also had Luma and ReiNand in there at some point.

    I recently turned on my 3ds and noticed I couldn't load DS games on it anymore.
    3DS games run fine but when I load a DS game the system just shuts off.

    I learned that I need to use a newer version of Luma to run DS games.

    I am having trouble on where to start in the process.
    Since I already have a ton of stuff loaded on my 3DS I am not sure if I have to delete everything and start from scratch or I can just copy some files over and go from there.

    Anyone have advice?

    Here is what my SD card directory looks like currently.
    [​IMG]
     
  2. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    11
    Nov 21, 2005
    United States
    https://3ds.hacks.guide/a9lh-to-b9s
     
  3. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    5
    Jul 23, 2018
    Germany
    First things first...upgrade from a9lh to b9s. Follow this guide.
     
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    What the other people said. But also, you don't have an emuNAND right?
     
  5. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    Sorry been busy with work.
    I have an emuNAND.
    I also backed up everything when I did the whole process.
    I forget exactly everything I did but I know I had it so it boots straight to emuNAND and stays on emuNAND even when going in and out of the settings menu.
    Keep in mind I installed all this back in early 2016.

    — Posts automatically merged - Please don't double post! —

    For some reason when I get to the step that requires you to boot your 3DS back up while holding start it fails to go to the SafeB9SInstaller and just goes straight to the normal 3DS menu.
     
  6. Quantumcat

    Quantumcat Dead and alive

    Moderator
    20
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    What happens if you rename SafeB9SInstaller to arm9loaderhax.bin and put it at the root of your card?
     
    Hayato213 likes this.
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Well, DSiWare doesn't work on emuNAND. But cartridges should still work.
    Make sure you have the SafeB9SInstaller.bin in SD:\Luma\payloads and not the .firm version.
    When the guide suggests you to "move emuNAND" at the start of Finalizing Setup, Section II - Updating the System, you should do so, that will free up some space and ensure that DSiWare should work correctly, if it still doesn't after finishing the guide there are some steps you can do that should fix it. emuNAND no longer serves a purpose and only causes trouble, so it's best to get rid of it.
     
    Last edited by The Real Jdbye, Sep 12, 2019
  8. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    I followed the steps. And it boots up fine and I can play 3DS games but I am unable to do a system update from the settings. It says an error has occurred. Unable to update.
    I see that I am not running emuNAND when looking at the settings. I am on Sys 11.3.0-36U.
    Also when I try the MT card to run DS games it says.
    An error has occurred. Unable to mount CTRNAND or load the CTRNAND FIRM. Please use an external one.

    At first It said it failed to apply 4 firm patches.
    I read that to stop the blocking of DS games I should use the TWL_Firm.cia and then try to run a system update.
    Unfortunately I am unable to update my 3DS.
     
  9. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    5
    Jul 23, 2018
    Germany
    Failed to apply 1 firm patches means your luma version is too old for the installed firmware.
     
  10. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    Ok I got everything to work.
    DS and 3DS games run fine now.
    But it seems with one of the later updates nintendo made it so if the tickets are not legit for the game then it will not update the game.

    Looks like I will have to manually update each game via .cia.
     
  11. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    5
    Jul 23, 2018
    Germany
    Nope. You can update them via the eshop.
     
  12. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    I have never done that before.
    I've never used the eshop, that I remember...
     
  13. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    11
    Nov 21, 2005
    United States
    Yes u will have to find the update .cia's and update manually
     
  14. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    5
    Jul 23, 2018
    Germany
    Doesn't matter. Update the games via eshop and you are fine.
     
  15. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    Two conflicting answers...
     
  16. Quantumcat

    Quantumcat Dead and alive

    Moderator
    20
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    Well try the eShop and see. The eShop should always work unless there's a problem with the region of the game.
     
  17. BaamAlex

    BaamAlex (*(vu64 *)0x1FF81100)

    Member
    5
    Jul 23, 2018
    Germany
    Why?
     
  18. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    11
    Nov 21, 2005
    United States
    Just remember opening eshop if u have any DLC for any game they will be deleted
     
  19. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    2
    Jan 14, 2010
    United States
    Guess I will manually update the games.
    I don't want to lose my dlc.
    Although if that did happen I could just manually update with the .cia of the dlc like I am already doing.
     
    Last edited by RyviusRan, Sep 17, 2019 at 11:47 PM
Loading...