1. BTAxis

    OP BTAxis Member
    Newcomer

    Joined:
    Sep 4, 2015
    Messages:
    12
    Country:
    I have updated my A9LH using this guide, but now I find that although Luma3DS and various tools like Emunand9 will boot okay, the Gateway payload and CtrBootManager9 will no longer boot (I get stuck on a black screen). Can someone tell me why this is happening, and what I can do to fix it?

    [Edit]
    Just found this tutorial. I can now chainload GW via Luma at least. It also recommends a different boot loader, I'll try that next.
     
    Last edited by BTAxis, Jan 25, 2017
  2. Redferne

    Redferne GBAtemp Advanced Fan
    Member

    Joined:
    Oct 28, 2015
    Messages:
    845
    Country:
    United Kingdom
    Did you try to rename arm9loaderhax.bin to arm9loaderhax_si.bin?
     
  3. squall14716

    squall14716 GBAtemp Maniac
    Member

    Joined:
    May 16, 2011
    Messages:
    1,294
    Country:
    United States
    Yeah, if the payload doesn't handle screen initialization itself, it has to be named arm9loaderhax_si.bin with this version of A9LH.

    Also, older versions of CBM9 might have issues, try this fork: https://github.com/OperationNT414C/CtrBootManager/releases
     
    Last edited by squall14716, Jan 25, 2017
  4. Redferne

    Redferne GBAtemp Advanced Fan
    Member

    Joined:
    Oct 28, 2015
    Messages:
    845
    Country:
    United Kingdom
    Arf... I was about to link to that version of CTRBootManager :)
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - payloads, Updated, working