Update Failed (Luma Updater): Could not get A9LH Payload

Discussion in '3DS - Homebrew Development and Emulators' started by AyeeAyanna, May 20, 2017.

  1. AyeeAyanna
    OP

    AyeeAyanna Advanced Member

    Newcomer
    51
    2
    Feb 4, 2017
    United States
    I'm trying to update from 7.0.5-e029458b to 7.1 on Luma. And, I'm using 11.3U if that's relevant to any of this.
     


  2. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,714
    2,119
    Jan 11, 2016
    Japan
    日本
    7.1 luma no longer supports A9LH, you should update to boot9strap here: https://3ds.guide/updating-to-boot9strap
     
    B_E_P_I_S_M_A_N likes this.
  3. Giodude

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,785
    1,099
    May 17, 2015
    United States
    New York
    Might have something to do with sighax being released. If i were you i would update to sighax immediately for compatibilty.
     
    proflayton123 likes this.
  4. AyeeAyanna
    OP

    AyeeAyanna Advanced Member

    Newcomer
    51
    2
    Feb 4, 2017
    United States
    How long can I go without updating luma?
     
  5. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,714
    2,119
    Jan 11, 2016
    Japan
    日本
    Well, until you can't go online I guess?
     
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    Until a new 3DS firmware update comes out that you wish to update to.
     
  7. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,165
    667
    May 16, 2011
    United States
    Until a Luma update changes or fixes something you'd like fixed or changed?

    Luma 7.0.5 is probably pretty resilient, it won't stop working overnight or anything. Unless a new 3DS update breaks one of Luma's patches to the point that it stops working, you'll be fine. (Even then, you'd be fine after updating to B9S and a fixed version of Luma.)
     
    Last edited by squall14716, May 20, 2017
  8. sks316

    sks316 Retro Enthusiast

    Member
    1,506
    729
    Nov 28, 2013
    United States
    Hyrule
    pixelmasher and KunoichiZ like this.
  9. george1391

    george1391 Newbie

    Newcomer
    7
    0
    Sep 12, 2009
    I am getting the same problem trying to install the hourly build (currently just switched to boot9strap). On the Luma3DS menu, it still says it's payload is arm9?

    I followed the 3ds.guide to a tee...
     
  10. sks316

    sks316 Retro Enthusiast

    Member
    1,506
    729
    Nov 28, 2013
    United States
    Hyrule
    Read above.
     
  11. B_E_P_I_S_M_A_N

    B_E_P_I_S_M_A_N oh no

    Member
    689
    2,473
    Jun 7, 2016
    United States
    Sixth Circle of Hell
    You should probably be fine for a few weeks. Arm9 payloads are bound to support B9S-exclusive entrypoints, but if you don't mind using older versions, you should get by fairly well.
     
  12. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,714
    2,119
    Jan 11, 2016
    Japan
    日本
    Essentially, GodMode9 is an all-in-one kind of thing, tool wise.
     
    B_E_P_I_S_M_A_N likes this.
  13. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    7,872
    3,133
    Mar 16, 2012
    United States
    * for SigHax users, I might want to add. a9lh users are currently out of luck.
     
  14. sks316

    sks316 Retro Enthusiast

    Member
    1,506
    729
    Nov 28, 2013
    United States
    Hyrule
    Yes, I forgot to mention that. It was also posted on the changelog.
     
  15. Kyoux

    Kyoux Member

    Newcomer
    30
    0
    Jan 5, 2017
    Italy
    Rome
    I managed to install Luma updater 2.0 and Luma 7.1, but when trying to update to lastest hourly, It keeps failing to install, telling me that it couldn't find boot.firm in zip file or something. I also try to update to stable version and this work for me, but not the lastest hourly
     
  16. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,714
    2,119
    Jan 11, 2016
    Japan
    日本
    The latest hourly with the updated for BS9 is currently broken iirc


    Sent from my iPhone using Tapatalk
     
  17. proflayton123
    This message by proflayton123 has been removed from public view by Depravo, May 21, 2017.
    May 21, 2017
  18. MSco

    MSco GBAtemp Regular

    Member
    147
    25
    Nov 2, 2016
    Gambia, The
    I am sorry, but I am out of this scene for some months.
    Whats the problem with a9lh? Why isnt it supported anymore? Why shall we switch to boot9strap?
     
  19. Salfay

    Salfay GBAtemp Regular

    Member
    204
    118
    Jul 18, 2016
    France
    A9LH still runs, but Bootrap9 is now available. It uses a material breach, so Nintendo can't patch it.
    It gives more possibility to the developers too.

    So now, Luma3DS doesn't support A9LH anymore and only supports B9S
     
    MSco likes this.
  20. PatrickJr

    PatrickJr Advanced Member

    Newcomer
    60
    18
    Jan 5, 2017
    Bridgwater
    Followed the guide, got B9S installed, working fine, then all of a sudden when trying to turn on my N3DS the blue LED turns on and off. Not booting up the console at all.
     
  21. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,714
    2,119
    Jan 11, 2016
    Japan
    日本
    Do you have boot.firm on root?