Unable to play ISO games

Discussion in 'PSP - Hacking & Homebrew' started by lemon1, Feb 13, 2017.

  1. lemon1
    OP

    lemon1 Member

    Newcomer
    14
    0
    Feb 13, 2017
    United States
    Hello all,

    This is my first post so please go easy on me.

    I have two psp (1000 & 2000), I haven't used them in years charged them up and tried to play the ISO's on the memory stick but I kept on getting 'The game could not be started. (80020148).

    I have tried everything reformatted the memory stick, used a new memory stick, tried other iso files, upgraded the firmware from on one of the PSPs from 5.50 gen D full to 6.20pro-b6 still doesn't work. I went into the recovery menu and made sure that the M33 driver or NP9660 is enabled in the ISO mode. I tried an ISO tool to fix the issue still not working.

    Any ideas people?

    Thanks a lot!:D
     
  2. zfreeman

    zfreeman GBAtemp Fan

    Member
    413
    131
    Mar 9, 2013
    United States
    Pennsylvania
    Have you tried the inferno driver?
     
  3. DBlaze

    DBlaze I don't know what i'm doing.

    Member
    208
    72
    Nov 15, 2006
    Netherlands
    Settings aside, why don't you just update to the 6.60 cfw?
     
  4. lemon1
    OP

    lemon1 Member

    Newcomer
    14
    0
    Feb 13, 2017
    United States
    Thanks for your replies, I have tried the inferno driver no difference. Let me upgrade to 6.60 CFW and get back to you guys. Thanks a lot
     
  5. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,971
    2,681
    Jul 23, 2012
    United States
    Octo Canyon
    Yeah, 6.60 PRO-C CFW is what I run. I have two PSP-2001 units. One black, the other silver.
     
  6. lemon1
    OP

    lemon1 Member

    Newcomer
    14
    0
    Feb 13, 2017
    United States
    Thanks, I have found this software online
    6.60 PRO-C1, is this the one?
     
  7. zfreeman

    zfreeman GBAtemp Fan

    Member
    413
    131
    Mar 9, 2013
    United States
    Pennsylvania
  8. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Legend

    Member
    10,028
    5,072
    May 27, 2016
    United States
    New York
    Maybe try formatting the Memory stick first in the psp settings along with the system itself. Then try running the iso again. Or another memory stick. Or maybe the files are corrupted....
     
  9. lemon1
    OP

    lemon1 Member

    Newcomer
    14
    0
    Feb 13, 2017
    United States
    Hey everyone! Sorry for the delayed response. Thanks for all your help, i managed to get it fixed. The memory stick needed formatting with SD formatter. My mac for some reason wasn't doing the job properly. Thanks again