To anyone who had trouble playing Metroid Prime Trilogy - and the multiplayer - .. I FOUND THE FIX!

Discussion in 'Wii - Emulation and Homebrew' started by Entheopsybin, Jun 17, 2018.

  1. Entheopsybin
    OP

    Entheopsybin Newbie

    Newcomer
    1
    Jun 17, 2018
    Australia
    Okay, so ive been trying to get this game to work for a while now, have never been able to get the multiplayer working and the singleplayer games are buggy depending on the rom or settings. Anyways, im using an NTSC WBFS rom of Metroid Prime Trilogy on USBLoaderGX, all i did to get it to work (and the multilplayer!) is i changed the DOL settings to default in the game load settings. When loading the game. yes it fails to load and has a black screen as many of u have had. What i did then is pressed the reset button, and the game loaded fully functional and even the multiplayer loads and works perfect
     
  2. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    All MPT needs is a modern loader and cIOS and the settings need to be set to save to real NAND, not emulated. There should be no extra steps required.
     
  3. Entheopsybin
    OP

    Entheopsybin Newbie

    Newcomer
    1
    Jun 17, 2018
    Australia
    For those who dont succeed with that, what i did should work, but definitely try this first ^
     
  4. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    Check the disc image and make sure it's valid or try re-ripping it? There's no reason it shouldn't work.
     
Quick Reply
Draft saved Draft deleted
Loading...