System Menu 4.0 Auto-Installer++

Discussion in 'Wii - Hacking' started by icefireicefire, Mar 27, 2009.

  1. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    (Untested. This can potentially brick you, but I don't think it will. I am not responsible if it does, though I hope it doesn't.)

    This application will download (using PatchMii) and install stuff in this order. All IOS's downloaded will be trucha-patched:
    - IOS60 (then tests to make sure IOS60 is working, if not, then it exists for safety).
    - System Menu 4.0 (it will autodetect your region, so no worries there. It will also patch it to v285-v286-v287 so that many bricks can be still solved from the recovery menu with a game that has a newer version on it)
    - All the rest of the new IOS's (except IOS16, because it isn't used and would just take forever). These also are trucha-patched.
    - The new Wii Shop Channel. This will be installed as normal.

    Download (untested, but updated): http://freefile.kristopherw.us/uploads/icefire/updater.dol

    Edit: NO THIS DOES NOT DO DIP/CIOSCORP/ETC PATCHING...for now [​IMG].
     


  2. pebls123

    pebls123 GBAtemp Regular

    Member
    128
    0
    Sep 16, 2008
    United States
    So does this mean that preloader/starfall will work or is that just wishfall thinking?
     
  3. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    No, but it means you can recover from some bricks with a SaveMiiFrii.
     
  4. timtlm

    timtlm Advanced Member

    Newcomer
    96
    0
    Mar 5, 2008
    United States
    I'm already on 4.0 using kongsnutz guide, but I have a question that may help potential users. Does this install the cIOS rev8 that you need to make sure you can still install wads, or do you still need to install that first?
     
  5. shanefromoz

    shanefromoz GBAtemp Advanced Fan

    Member
    978
    34
    Jun 18, 2007
    timtlm you need to install cIOS rev 8 first
     
  6. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    Anyone try it yet?
     
  7. computerboy

    computerboy GBAtemp Advanced Fan

    Member
    802
    0
    Sep 20, 2008
    Swaziland
    Once this is installed can I install cIOS 38, 53 and 55 from CIOScorp again? Just want to make sure that I don't brick that's why. Except there isn't any point in doing so yet until somebody DIPs IOS 60. So if somebody can make an IOS60 with DIP module that would mean we would have CIOScorp again on 4.0


    EDIT: Anyone tried it yet? I don't like guinea pigs that's why I haven't tried it yet [​IMG]
     
  8. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    Fine, fine, I'll DIP IOS60...if someone tests this first [​IMG].

    And yes, you can install those IOS's again afterwards.
     
  9. computerboy

    computerboy GBAtemp Advanced Fan

    Member
    802
    0
    Sep 20, 2008
    Swaziland
     
  10. anaxs

    anaxs got milk, got candy

    Member
    2,208
    1
    Mar 23, 2009
    Canada
    your moms jeans pocket
    i dont get this ....wat is it...is it some new wii software
     
  11. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    lol. it is an upgrader to Wii Menu 4.0 that should work [​IMG]. You just install cIOS rev8 then run it.
     
  12. WiiMonkey

    WiiMonkey GBAtemp Fan

    Member
    408
    1
    Jan 16, 2009
    UK

    Im cleaning my Wii Up now and then ill test it..................... c u's in 15

    PS: im replacing all of my ios's with orignal 1s what ios's should i have

    IOS:- 9, 11, 12, 13, 14, 15, 17, 20, 21, 22, 28, 30, 31, 33, 35, 36, 37, 38, 53, 55

    should i add anymore to that list

    cheers
     
  13. axe97

    axe97 GBAtemp Regular

    Member
    121
    0
    Dec 28, 2008
    United States
    USA
    can i just use cIOS rev 7 instead?
    and also, what does the patching to 287 etc do?
     
  14. computerboy

    computerboy GBAtemp Advanced Fan

    Member
    802
    0
    Sep 20, 2008
    Swaziland
    EDIT: Internet trouble
     
  15. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    rev7 will work just as well, just nothing lower.
     
  16. axe97

    axe97 GBAtemp Regular

    Member
    121
    0
    Dec 28, 2008
    United States
    USA
    cool, but im still gonna wait for a DiP patch and preloader on 4.0
    nice job though
     
  17. icefireicefire
    OP

    icefireicefire GBATemp Fails.

    Member
    961
    0
    Dec 19, 2008
    United States
    Preloader will probably come whenever crediar updates it, and DiP comes when someone tests this [​IMG].
     
  18. MCorbet

    MCorbet Advanced Member

    Newcomer
    82
    0
    Feb 1, 2008
    Netherlands
    After installing rev 8 and this update. Can I install wads directly to the SD card ?

    Or should I install them on the wii first and move them to the SD card later ?
     
  19. kezm

    kezm Newbie

    Newcomer
    2
    0
    Mar 16, 2007
    ok total newb question i know but i have corrupted my system files but can load into homebrew channel would this be able to reinstall the system files
    flame away at will
     
  20. WiiMonkey

    WiiMonkey GBAtemp Fan

    Member
    408
    1
    Jan 16, 2009
    UK
    Im going to test it when i have a answer to my question thanks