Hacking Discussion SX OS - Error and Solutions Thread

Have you checked that your SD card Isn't Fake

  • Yes

    Votes: 195 76.2%
  • No

    Votes: 48 18.8%
  • Will verify soon

    Votes: 13 5.1%

  • Total voters
    256

pLaYeR^^

Doctor Switch
Member
Joined
Sep 18, 2014
Messages
3,132
Trophies
1
Age
25
Location
Austria
XP
3,173
Country
Austria
update to the last fw, or rest on 3.0?
Depends. If you wanna use SX OS, then you can update to latest firmware. If you care about the vulnerabilities in lower firmware, you should wait until there is more known. Lower firmware will probably offer a software solution.
 

SwitchHack

Well-Known Member
Member
Joined
Jan 20, 2018
Messages
149
Trophies
0
XP
933
Country
Japan
Depends. If you wanna use SX OS, then you can update to latest firmware. If you care about the vulnerabilities in lower firmware, you should wait until there is more known. Lower firmware will probably offer a software solution.
I only care about SX OS and backup.
 

PatrickD85

Well-Known Member
Member
Joined
Jul 4, 2012
Messages
912
Trophies
0
Age
36
Location
in front of a screen...
Website
www.nintendoreporters.com
XP
1,985
Country
Netherlands
Anyone getting "Server Response Error" when trying to input the code? Was it a bad code or something else going on?

Also, it seems like SX OS isn't saving the request file at all on my SD card. What the hell is happening?
Actually I tried disabling the Autorcm and after that I am running into this aswell ... what the ... f...
 

PatrickD85

Well-Known Member
Member
Joined
Jul 4, 2012
Messages
912
Trophies
0
Age
36
Location
in front of a screen...
Website
www.nintendoreporters.com
XP
1,985
Country
Netherlands
@OhhSheetz dear OP please include a "Server Response error / missing license_request.dat" in the Setup section.
It seems multiple users are having this happen.

I have reached out to Team Xecuter to see what to do in such a situation and will update here once I get feedback from them.
For now I am stuck with not being able to use SX OX, and I have been able to activate it fine earlier today.

In short my mail to Xecuter;

Hi Team Xecuter,

I seem to be running into a bit of a problem with my SX OS.
Earlier I activated it a work and enabled the Auto RCM feature.

All was fine but I wanted to disable the Auto RCM feature.
So once I got home I loaded the Team Xecuter payload and kept holding the plus so I got the options again.

I then disabled the Auto RCM and followed the process to boot into the Custom firmware but the payload does not seem to generate the license-request.dat on my SD or accept my SX OS license key once booted and selecting the Album. It results in a “server response error”.
As you can see in the below picture;
For quick reference a screenshot of the license as received from Online Trends;
The fingerprint noted by SX OS:


I verified my Nintendo Switch could acces the internet by connecting to the eshop and did a simple connection test for the internet connection.
If you could help me that would be awesome. If you need any additional info feel free to let me know.
Kind regards,​
 
  • Like
Reactions: OhhSheetz

OhhSheetz

Well-Known Member
OP
Member
Joined
Oct 27, 2015
Messages
105
Trophies
0
Age
31
XP
523
Country
Canada
@OhhSheetz dear OP please include a "Server Response error / missing license_request.dat" in the Setup section.
It seems multiple users are having this happen.

I have reached out to Team Xecuter to see what to do in such a situation and will update here once I get feedback from them.
For now I am stuck with not being able to use SX OX, and I have been able to activate it fine earlier today.

In short my mail to Xecuter;

Hi Team Xecuter,

I seem to be running into a bit of a problem with my SX OS.
Earlier I activated it a work and enabled the Auto RCM feature.

All was fine but I wanted to disable the Auto RCM feature.
So once I got home I loaded the Team Xecuter payload and kept holding the plus so I got the options again.

I then disabled the Auto RCM and followed the process to boot into the Custom firmware but the payload does not seem to generate the license-request.dat on my SD or accept my SX OS license key once booted and selecting the Album. It results in a “server response error”.
As you can see in the below picture;
For quick reference a screenshot of the license as received from Online Trends;
The fingerprint noted by SX OS:


I verified my Nintendo Switch could acces the internet by connecting to the eshop and did a simple connection test for the internet connection.
If you could help me that would be awesome. If you need any additional info feel free to let me know.
Kind regards,​
Thanks for your feedback Patrick, will add it once I get home in a few hours, there’s a lot of info I have to add, and this is one I want to investigate further about.
 

tellymaneli

Member
Newcomer
Joined
Jun 18, 2018
Messages
5
Trophies
0
Age
40
XP
69
Country
Germany
Hey, I do not get a license dat on the micro sd. Furthermore, I get the message "server response error" when entering the license.
 

PatrickD85

Well-Known Member
Member
Joined
Jul 4, 2012
Messages
912
Trophies
0
Age
36
Location
in front of a screen...
Website
www.nintendoreporters.com
XP
1,985
Country
Netherlands
Hey, I do not get a license dat on the micro sd. Furthermore, I get the message "server response error" when entering the license.
Yep, you are not the only one it seems. I can confirm that earlier my SX OS was working just fine but after my attempt to disable the autorcm feature ... well not so much.
As it seems to happen to a lot of people ... I am hoping it is just an API acting up on their end ;)
 
  • Like
Reactions: tellymaneli

Russkn87

Active Member
Newcomer
Joined
Aug 24, 2015
Messages
25
Trophies
0
Age
34
XP
328
Country
Rocket League doesn’t work for me, I deleted it in the end since there’s no point without online play.

It freezes at the black screen with Switch logos at the start.
 

tellymaneli

Member
Newcomer
Joined
Jun 18, 2018
Messages
5
Trophies
0
Age
40
XP
69
Country
Germany
Yep, you are not the only one it seems. I can confirm that earlier my SX OS was working just fine but after my attempt to disable the autorcm feature ... well not so much.
As it seems to happen to a lot of people ... I am hoping it is just an API acting up on their end ;)

Now the license got dat. Used a Mac. This did not show the file. The Windows computer but already. Now the rest is checked.
 

Puppydogpals

Well-Known Member
Member
Joined
Feb 19, 2018
Messages
186
Trophies
0
Age
41
XP
1,360
Country
United Kingdom
Mine crashed on that mini game too
Im guessing it's something to do with the camera on the joycon maybe? Or cause it's trimmed

Got another version to try a multi language one which is slightly different in size to the one I originally got

Sent from my SM-G935F using Tapatalk
 

frankGT

Well-Known Member
Member
Joined
Nov 21, 2009
Messages
237
Trophies
0
XP
501
Country
Portugal
QUESTION: Once i use the SX OS licence on the SX Pro, the SO stays linked to my console and i cant sell it in the future right?
 

PatrickD85

Well-Known Member
Member
Joined
Jul 4, 2012
Messages
912
Trophies
0
Age
36
Location
in front of a screen...
Website
www.nintendoreporters.com
XP
1,985
Country
Netherlands
Now the license got dat. Used a Mac. This did not show the file. The Windows computer but already. Now the rest is checked.
Hmm that could be the case ... OSX and Switch formatted SDXC cards work ...kinda weirdly sometimes. Will try that in a bit. Thanks for letting me know!
 

tellymaneli

Member
Newcomer
Joined
Jun 18, 2018
Messages
5
Trophies
0
Age
40
XP
69
Country
Germany
Hmm that could be the case ... OSX and Switch formatted SDXC cards work ...kinda weirdly sometimes. Will try that in a bit. Thanks for letting me know!
The backups work now too. I suspect that the server for the licenses is currently not working. Uploading the dat has worked. Thank you
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    NoobletCheese @ NoobletCheese: wont happen anytime soon as the size of games now is enormous and most people have speed and...