switch to emummc : "Game needs to be downloaded"

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by ooznerol, Aug 11, 2019.

  1. ooznerol
    OP

    ooznerol Newbie

    Newcomer
    1
    Aug 11, 2019
    France
    Hi all,

    I just migrate to emummc. (atmosphere 0.9.3 and FW 6.2)

    If i boot on sysnand (with atmosphere 0.9.3) all installed games are working.

    But If i boot to emummc (with atmosphere 0.9.3), no more games are running. I had the message "Game needs to be downloaded" (not sure the message in english is exactly this one).

    Can someone help me?

    thanks a lot
     
  2. ScrPotato

    ScrPotato GBAtemp Regular

    Member
    1
    Aug 3, 2019
    United States
    in your closet
    Was your emuMMC made before you downloaded the game in sysNAND?
     
  3. Gibdos

    Gibdos Newbie

    Newcomer
    2
    Mar 21, 2008
    Germany
    The emuMMCs uses a different folder for the Nintendo folder. It'll be in emuMMC/RAW1 or emuMMC/SD00 depending on your setup. You can just move / copy the Nintendo folder from the root of your SD card to the new location and it should work fine.

    You could also probably edit the /emummc/emummc.ini file and change the nintendo_path=emuMMC/RAW1/Nintendo entry to point to your former Nintendo folder. Didn't try that myself though.
     
    Last edited by Gibdos, Aug 11, 2019
    Slim45, Lacius and NoNAND like this.
  4. Kafluke

    Kafluke GBAtemp Guru

    Member
    14
    May 6, 2006
    United States
    Real question is why did you migrate to emuMMC if your sysnand is dirty?
     
  5. Steckbecken

    Steckbecken Advanced Member

    Newcomer
    4
    Jan 12, 2018
    Austria
    e.g. brick prevention
     
    Slim45 likes this.
  6. ooznerol
    OP

    ooznerol Newbie

    Newcomer
    1
    Aug 11, 2019
    France
    Hi,
    I had missed this information in all the different web page that i have read.......
    So I have moved my Nintendo folder to emuMMC/RAW1 and now I got an error when I try to launch games under emmumc (error code:2002-0001)

    Did i missed something?

    thanks

    — Posts automatically merged - Please don't double post! —

    because I have a clean nand backup that I plan to restore when emuMMC will be running without problem
     
  7. ScrPotato

    ScrPotato GBAtemp Regular

    Member
    1
    Aug 3, 2019
    United States
    in your closet
    Taken from Nintendo;
     
  8. ooznerol
    OP

    ooznerol Newbie

    Newcomer
    1
    Aug 11, 2019
    France
    thanks but......not working.... error still here
     
  9. ScrPotato

    ScrPotato GBAtemp Regular

    Member
    1
    Aug 3, 2019
    United States
    in your closet
    Don't know what to do then.
     
  10. Kafluke

    Kafluke GBAtemp Guru

    Member
    14
    May 6, 2006
    United States
    Is your clean nand backup the same version as your current nand? Did you preserve fuses if you upgraded? Do you have boot0 and boot1 also?
     
  11. ooznerol
    OP

    ooznerol Newbie

    Newcomer
    1
    Aug 11, 2019
    France
    for the moment the clean back up has not been use.
    I just create a emummc with hekate from my current version (6.2 not clean).

    So I have sysnand with 6.2 not clean
    end emummc with the same FW.

    Just try to play games with emummc
     
  12. Kafluke

    Kafluke GBAtemp Guru

    Member
    14
    May 6, 2006
    United States
    You said you were gonna restore a clean nand backup. I'm asking if the backup was made on a lower firmware than your sysnand. Downgrading is dangerous if you dont know what you're doing. Read the thread in my sig.
     
  13. ooznerol
    OP

    ooznerol Newbie

    Newcomer
    1
    Aug 11, 2019
    France
    OK Guys.

    I had restart from beginning.
    - Format my switch partition (not the emummc)
    - copy old need stuff into this partition (atmosphere and homebrew)
    - copy my saved nintendo folder into emuMMC/RAW1

    and now all is working fine : I can play games from my emummc partition ( and I have upgraded it to 8.1 too):hrth::hrth::hrth:

    thanks a lot for your help;

    Next step is to try to restore my 5.1 clear backup (but my fuses are in 6.2). I will read kafluke
    guide cautionly
     
Quick Reply
Draft saved Draft deleted
Loading...