Hacking Switch is very unstable while running Atmosphère

Sreve

New Member
OP
Newbie
Joined
Sep 22, 2019
Messages
3
Trophies
0
Age
47
XP
44
Country
Germany
Hi,

I am doing my first steps with hacking my switch. I successfully finished this guide: switch.homebrew.guide

But while running Atmoshère, I get frequently chrashes, mainly with homebrew apps. The "bluescreen" points me to error code: 2168-0002, Firmeware 9.0.0 (Atmoshère 0.9.4-master-c62c4846)

Can anyone give me a hint, what I can do?
 

xabier

Well-Known Member
Member
Joined
Dec 10, 2006
Messages
577
Trophies
0
XP
1,191
Country
United States
Did you install hbg shop or tinfoil? The first version for 9.0 was bugged and made atmosphere behave badly. It s already fixed, redownload tinfoil and overwrite the old version
 

XaneTenshi

Well-Known Member
Member
Joined
Nov 24, 2013
Messages
513
Trophies
0
Age
32
XP
1,097
Country
Denmark
Hi,

I am doing my first steps with hacking my switch. I successfully finished this guide: switch.homebrew.guide

But while running Atmoshère, I get frequently chrashes, mainly with homebrew apps. The "bluescreen" points me to error code: 2168-0002, Firmeware 9.0.0 (Atmoshère 0.9.4-master-c62c4846)

Can anyone give me a hint, what I can do?

Knowing which HomeBrew apps crashes would be a big help, but in all honesty, the problem is most likely that you are using Homebrew apps on FW 9.0. Many apps haven't been recompiled to work with 9.0 yet. I get that you are new, so you didn't know, but you should have stayed on any FW lower than 9.0 if you are using a lot of apps.
 

Sreve

New Member
OP
Newbie
Joined
Sep 22, 2019
Messages
3
Trophies
0
Age
47
XP
44
Country
Germany
Knowing which HomeBrew apps crashes would be a big help, but in all honesty, the problem is most likely that you are using Homebrew apps on FW 9.0. Many apps haven't been recompiled to work with 9.0 yet. I get that you are new, so you didn't know, but you should have stayed on any FW lower than 9.0 if you are using a lot of apps.

So far, I test to install different version of Atmoshpère. Some didn't boot, but all version that do run, have the same bluescrren-problem. Finally I stay at the latest Version.

The app store do start fine. The first run was without getting the error. I was able to install "Prince of Persia". I think, thats cause it is a small package. Installing RetroArch always fails in the middle of the download. Other larger packages failed too.

I have manually installed RetroArch. It runs, but I was not able to start an ISO. Sometimes it just do nothing, sometimes it chrashes to the BlueScreen.

* I found some Logfiles. The Exception is: Data Abort


What is running fine so far?

- Prince of Persia
- ScummVM
- The Homebrew Menu and preinstalled Apps

Today, I will test some Emualtor. Mainly I am interessted in Amiga, C64, N64, NDS, N3DS .... would be very nice if this will run stable.

- VBA Next can started by RetroArch and works fine ... Until I access the Quick Menü.
 
Last edited by Sreve,
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: Steam Deck The VR experience!!!