Hardware Switch gets no power, can't turn it on or charge it

dario3213

New Member
OP
Newbie
Joined
Aug 23, 2019
Messages
1
Trophies
0
Age
27
XP
61
Country
United Kingdom
I bought a faulty switch that doesn’t get any power and doesn’t charge. Seller claimed they just got an error one day and then it never came back on (it was a kids switch).

When I dock the switch, I get a quick green light flash on the dock LED, and that’s it. When I plug in the switch to charge (either the old or the new battery) it makes a feint, quiet buzzing noise.

To check the power, I used a USB voltage meter with a standard micro type C cable, and the reading I got was 0.43 when I plugged the type C into the switch. I got a brand new battery, and the reading moved up to 0.49 but still no power, no display and no fast charge. With the OLD battery, when I hold the power button down, the voltage goes down to 0.21 for a while and then goes back up, the new battery does not have the same effect.

I opened it up and stripped it completely, and it looks fine, no water damage or corrosion at all, it was just a bit dusty which I cleaned up. I also cleaned the board with isopropyl alcohol from both sides to make sure, but nothing changed when I hooked it back up.

What could the problem be? I ordered a multimeter and I will attempt to check for shorts, also ordered a charge port, but if that doesn't fix it I think I'm going to give up and re-sell it as faulty.

Thank you in advance
 
Last edited by dario3213,

Mocho

Active Member
Newcomer
Joined
Aug 28, 2019
Messages
27
Trophies
0
XP
100
Country
Spain
Maybe he bricked it trying to hack it?. Compare with other maybe is software and you get crazy looking for hardware
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    K3Nv2 @ K3Nv2: Mostly pronouns, fatshaming, his daughters, Christopher reeves, caitlyn Jenner usual stuff