1. Surexius

    OP Surexius Advanced Member
    Newcomer

    Joined:
    Nov 22, 2007
    Messages:
    65
    Country:
    Hey I haven't been on this in ages or messed around with flashcards for quite the while. Recently got back to playing my 3ds as my son wanted to play lugi's mansion (so was playing that Dark moon) but since then he has done something and it no longer boots up properly. The last time I did this was years ago so I can't even find the software on the gateway website and also from reading the wiki on it, it seems that version 4.2 of the software is out. The guide I used last time to sort out the flashcard is now marked as obsolete!

    My SysNAND is on version 4.5.0-10E and my serial number is SUF1036xxxx and I haven't upgraded. Is there any guides to reinstalling and getting gateway running that I have missed particularly for such an old version of software. Or should I upgrade to version 9? Also is there a way to upgrade to version 9 without upgrading past this point? With the new versions of the software can you play the more recent games without them trying to update your game version?

    Thanks in advance
     
    Scott_pilgrim likes this.
  2. KleinesSinchen

    KleinesSinchen GBAtemp's Backup Reminder + Fearless Testing Sina
    Member

    Joined:
    Mar 28, 2018
    Messages:
    1,941
    Country:
    Germany
    You will be told a million times that Gateway is no longer supported and you should install B9S by following:
    https://3ds.hacks.guide/

    There is a tutorial to get Gateway running on "latest" Frankenfirm only for EmuNAND. This makes sense if you want to recover saves.
    https://gbatemp.net/threads/gateway-gw3d-11-10-b9s-and-cfw.550040/


    Other than that I can't help you as I never owned a 3DS flashcart.

    Good luck and have fun!

    Edit:
    Getting to version 9.2 might be possible with cartridge updates. Other than that there are firmware packs online (counts as piracy so can't link).
    Before using SysUpdate for Up- or Downgrade create a NAND backup. You might need it.
    I don't recommend trying such things at all!
     
    Last edited by KleinesSinchen, Oct 11, 2020
  3. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,331
    Country:
    Italy
    The last operating system the last version of gateway CFW can run is in fact 10.2 - it could be a smart idea to leave your sysnand as-is and update the emunand to that version instead (you can likely find cia packs for that version online)

    After you get gateway running, it would be a smart idea to backup your saves in decrypted format (ie not .sav archives, but the loose files they contain) using a save manager like JKSV or Checkpoint, and afterwards to switch to a modern setup without emunand and titles installed to the console's SD (which will run the newest system version 11.13, is significantly technically cleaner implementation wise, and offers more convenience features)

    The gateway card is indeed outdated because the only cfw that supports it, gateway's, is outdated
    (it is not a traditional flashcard ie something that faithfully-enough simulates an original physical game, but rather a novel accessory that happens to fit in the gamecard slot and requires extra drivers)
     
  4. Surexius

    OP Surexius Advanced Member
    Newcomer

    Joined:
    Nov 22, 2007
    Messages:
    65
    Country:
    Yeah I'm well behind the times! What is B9s? DO I install it on the flashcard?
     
  5. Lacius

    Lacius GBAtemp Legend
    Member

    Joined:
    May 11, 2008
    Messages:
    14,214
    Country:
    United States
    B9S is something you install directly to the 3DS. Once it is installed, it will automatically load CFW (Luma3DS) off the SD card or NAND when you boot your system. There is no need for a flashcart anymore.
     
  6. godreborn

    godreborn Retired
    Member

    Joined:
    Oct 10, 2009
    Messages:
    12,994
    Country:
    United States
    I'd recommend getting those saves off of gateway. it's a pretty straight forward process of mounting the save, then using the card to decrypt it. it's almost exactly the same method used on the ps4. I wrote a tutorial on it, but it's not on here. I think @MattKimura wrote one as well. they're both essentially the same. I managed to get all saves off except etrian odyssey 4's, but it came up as corrupted with the gateway card itself as well, so I'm not sure what happened. that was my most important save, since it's my favorite series from the ds/3ds era, but it's okay as I wasn't very far.
     
    TurdPooCharger and Surexius like this.
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,048
    Country:
    Norway
    You won't be needing the flashcart anymore.
    Edit: :ninja:
     
    Surexius likes this.
  8. Surexius

    OP Surexius Advanced Member
    Newcomer

    Joined:
    Nov 22, 2007
    Messages:
    65
    Country:
    Yeah reading through this and some of the posts. Wow things have improved so much since over 5 years ago. I've already stumbled on the first hurdle. Getting the soundhax downloaded. Firstly there is none for EU 4.2 it just has 3.x-4.x (I assume thats the one I click on rather than the 5.0 one) yet when I click on it and in fact the others (I've tried different versions) it comes up with no video with supported format and MIME type file found...rather than downloading the file. Also I'll totally try to get my savefiles off the gateway...once I work out how to get the b9s working.

    By the way when you have it on B9S where do you get the games from if its not from the flashcard?
     
  9. godreborn

    godreborn Retired
    Member

    Joined:
    Oct 10, 2009
    Messages:
    12,994
    Country:
    United States
    you have no idea. I came from a9lh a precursor to b9s. installing that was a doozy. it took me six hours per system with over 200 steps. now, installing a full hack is fast, easy, and much, much safer than before. I'm afraid I can't help with specific hacks as I installed a9lh many years ago and the upgrade to b9s takes ten minutes or so.
     
    TurdPooCharger and Surexius like this.
  10. KleinesSinchen

    KleinesSinchen GBAtemp's Backup Reminder + Fearless Testing Sina
    Member

    Joined:
    Mar 28, 2018
    Messages:
    1,941
    Country:
    Germany
    Right-click and "Save as". Modern browsers try to play the sound file – since it is not a real sound file but an exploit for the 3DS there is nothing to play. No idea why a browser does not offer downloading a file if it can't open it.
    You can also download the complete archive from Github and extract the correct file (soundhax-eur.03ds-v3.xand4.x.m4a) if the soundhax page does not work.
    https://codeload.github.com/nedwill/soundhax/zip/master

    Games are installed to the console SD. The flashcart is not needed for that.

    Take your time reading the guide and don't skip any steps like the SD check and the NAND backup.
     
  11. Surexius

    OP Surexius Advanced Member
    Newcomer

    Joined:
    Nov 22, 2007
    Messages:
    65
    Country:
    Running through this guide. I'm at the NDS sound part and when I go to play the <3 Nedwill 2016 sound it just comes up with 'An error has occourred forcing the software to close. The system will now restart.

    Do I just keep trying lots of times or have i done something wrong? I used a blank SD card. Should I put the SD card in my console first before I put the programs on the root?
     
    Last edited by Surexius, Oct 11, 2020
  12. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,331
    Country:
    Italy
    Shouldn't matter...

    You could always try a different exploit - if you still have the blue card (which will still be useful after everything as a fair DS flashcard), I would recommend ntrboot (https://3ds.hacks.guide/ntrboot.html) as it is the fastest to use and is in fact independent of the system version :)
     
    TurdPooCharger, Surexius and wormdood like this.
  13. Surexius

    OP Surexius Advanced Member
    Newcomer

    Joined:
    Nov 22, 2007
    Messages:
    65
    Country:
    Hmm no joy with that method either. Unable support my gateway apparently... even though it is listed in the menu on the first page of the guide with my version as well.

    Might try updating my version on DS and try exploiting it. What is the easiest version to exploit and how can i update only to that version?

    Actually I have a game that will change it to 6.2.0-1E would it be worth doing that? As it looks like the method only changes after version 9
     
    Last edited by Surexius, Oct 11, 2020
  14. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,331
    Country:
    Italy
    The newest - there may be more steps to do, but a reliable starting point (which a possibly incomplete update is not) trumps all, and of course you don't have to hunt for illegal copies of software

    All gamecard updates are incomplete by definition
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - questions, Gateway, Super