Stuck at Save Saver! on boot

Discussion in 'Supercard' started by geokilla, Jun 13, 2009.

Jun 13, 2009
  1. geokilla
    OP

    Member geokilla GBAtemp Regular

    Joined:
    May 16, 2008
    Messages:
    257
    Location:
    Toronto, Canada
    Country:
    Canada
    So my Supercard DSONE SDHC has been working well since the first day I got it. However today when I boot up my Supercard, it says "Save Saver! Please wait." It stays like that and nothing happens. I've already formatted the SD card a couple times, reinstalled the firmware, but it's still stuck on boot.

    I'm currently using SP8 firmware. Will go back to SP7 and see what happens.
     
  2. vitius

    Newcomer vitius Newbie

    Joined:
    Dec 19, 2008
    Messages:
    8
    Country:
    Canada
    I haven't run into anything like that. I've had the save saver take as along as 5 seconds on startup but it never gets stuck for me. It's a new addition in SP8 so switching back to SP7 should fix your problem. I'd expect a solution/new update to come eventually to fix this.
     
  3. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    Make sure none of your buttons are stuck and that nothing is forcing the touchscreen to register a touch anywhere.
     
  4. geokilla
    OP

    Member geokilla GBAtemp Regular

    Joined:
    May 16, 2008
    Messages:
    257
    Location:
    Toronto, Canada
    Country:
    Canada
    The screen protector on the touch screen was causing the problem. It has now been fixed.

    Thanks.
     

Share This Page