SoftChip Linking Channel Problems

Discussion in 'Wii - Hacking' started by WiiShizzza, Dec 2, 2008.

?

Plz hit yes or no, if u experience any problems with the Linking Channel

  1. Yes

    0 vote(s)
    0.0%
  2. No

    0 vote(s)
    0.0%
Dec 2, 2008
  1. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    I heard some of you have errors with the SoftChip LinkingChannel.
    This thread is made for pointing out the issues, as not everybody has problems with the channel.
    Also it should prevent requiem4Ds Softchip Thread to be spammed.

    If you experience any problems with the SoftChipLinking Channel.
    plz shortly post your issues. We'll see if we can point it out.

    Good to know would be if you can give the revision of the Softchip.dol, you got errors with.
     


  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Could the people with the problems test these two versions?

    http://rapidshare.com/files/169662550/test.zip.html

    Please only download if you have a problem with the forwarder channel, there's a download limitation. There's a little change to the configuration class inside.
     
  3. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    [​IMG]

    What exactly did you do ?
    as i don't need to download it.
     
  4. djtaz

    Member djtaz PM's Full - Wadder Me

    Joined:
    Sep 21, 2008
    Messages:
    2,997
    Country:
    Ireland
    Do you want me to link from my site ?
    No limits on that ?
     
  5. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I only want somebody with that problem to test, 1 tester is enough, there's no need for anybody else to download it. If this works, it becomes the next revision.

    I changed the path to the configuration file, maybe there's a little problem.
     
  6. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    just to make it clear:
    the testing files are modded "SoftChip.dol"s to be on the SD or are these like the "forwarder.dol" inside the wad?
     
  7. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    SoftChip.dols which should be placed as /SoftChip/loader.dol, sorry i did not clarify that.
     
  8. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    Thought of a problem with the softChip rev file not with the loader.
    But good you cleared it.

    As I don't have problems I won't download it yet.
    Waiting for results.

    Any clue, why some have problems, some other doesn't ?
     
  9. stev418

    Member stev418 GBAtemp Fan

    Joined:
    Sep 25, 2007
    Messages:
    492
    Country:
    Australia
    No problems with the linker channel here, although i did replace the custom sound.bin as I found it not loud enough [​IMG]
     
  10. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    maybe another sound.bin is better anyway...
    Although, I like the beverly hills cop theme there^^
     
  11. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Oh i forgot the most important detail:

    The forwarder only executes the file /SoftChip/loader.dol, there's no special code or whatever for SoftChip loading, EVERY .dol placed as /SoftChip/loader.dol should work well with the forwarder channel, if not, the problem is inside the channel.
     
  12. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    exactly. But it has the path to \SoftChip\loader.dol in there.
     
  13. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    "\"s?
    I wouldn't be surprised if it's "fat:/SoftChip/loader.dol"

    Actually that's the change inside the test versions, i added the "fat:" to the path, as this is the absolute path and without it's a relative path which could cause problems when executed from /SoftChip/
     
  14. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    great you did it. so new softchip r65 should work without LinkingChannel problems, then?
    Well, if some tester gives positive comment...
     
  15. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I wrote i could cause problems, but i'm not very confident of it. Just wait for somebody with the problem testing other .dols and these 2 .dols then we will know.
     
  16. lolsjoel

    Member lolsjoel GBAtemp Advanced Fan

    Joined:
    Nov 19, 2003
    Messages:
    930
    Country:
    United States
    Both gave me a code dump [​IMG]
     
  17. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    And other apps?
     
  18. lolsjoel

    Member lolsjoel GBAtemp Advanced Fan

    Joined:
    Nov 19, 2003
    Messages:
    930
    Country:
    United States
    Just tried launching WAD Manager 1.3 as loader.dol and I get the code dump still. Must be a problem with the channel and not SoftChip. But that's weird because it definitely worked once after I had launched r64 from a WAD I made (not a linking channel).
     
  19. WiiShizzza
    OP

    Member WiiShizzza Graphics juggler

    Joined:
    Oct 10, 2008
    Messages:
    1,201
    Country:
    Germany
    that's really weird...
    could you try what happens if you remove the config file under SD:\Softchip\
    and then restart the channel?

    I give SpaceJump a call to have a look at the "forwarder.dol" inside the wad.
     
  20. lolsjoel

    Member lolsjoel GBAtemp Advanced Fan

    Joined:
    Nov 19, 2003
    Messages:
    930
    Country:
    United States
    When I tested those two .dol files, I had removed the .cfg file already.
     

Share This Page