Should I upgrade from 1.4.1

Discussion in 'NDS - Emulation and Homebrew' started by WanderingAi, Feb 10, 2014.

  1. WanderingAi
    OP

    WanderingAi Newbie

    Newcomer
    2
    0
    Feb 10, 2014
    United States
    I just dug my DSi out of the grave and noticed that it was on firmware 1.4.1 and was wondering if there was any reason to stay on 1.4.1. As far as I understand it, you need one of the four DSiWare games already purchased and downloaded in order to run on of the exploits, but I missed that train. Should I just move to the latest version?
     
  2. Technicmaster0

    Technicmaster0 GBAtemp Addict

    Member
    2,997
    598
    Oct 22, 2011
    Gambia, The
    NO!!!

    /edit
    Updating the DSi usually means that you will loose flashcard compatibility. Maybe you want to buy a CycloDS iEvolution which supports DS and DSi mode.
     
  3. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,714
    2,466
    Jul 23, 2012
    United States
    Octo Canyon
    As long as your flashcard can support the latest 1.4.5 DSi firmware, you're good to go. Update the flashcard first though, then update the system. Not all of Nintendo's updates are bullshit that blocks flashcards, there are also system speed and stability improvements, and I have noticed my system is rock solid on 1.4.5, whereas it used to lag a bit in the menu screen when I was on 1.4.4.
     
  4. Ulieq

    Ulieq GBAtemp Fan

    Member
    363
    73
    Jan 14, 2014
    United States
    Los Angeles, California
    I updated to 1.4.5 and use the newest r4i gold, works perfectly. But i heard you cannot update an old flashcart to 1.4.5, you must buy the new cart.
     
  5. WanderingAi
    OP

    WanderingAi Newbie

    Newcomer
    2
    0
    Feb 10, 2014
    United States
    Thanks for the feedback! I guess I'll get around to updating my system eventually as I don't feel like I have performance issues at the moment.