Should I Update System FW? (B9/Luma Installed)

Discussion in '3DS - Flashcards & Custom Firmwares' started by Skeet1983, Aug 13, 2017.

  1. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Hi guys. I have a N3DS with B9 installed. I only have a SysNAND and it is on either 11.3 or 11.4. Should I update to latest and is it also safe with a Luma and B9 setup? My Luma is on 7.x because when I was on 8.x, I kept getting Arm11 crashes. Will I still be able to use the following with latest System FW?:

    - CIA games
    - Freeshop
    - BootNTR
    - JKSV/JKSM
    - SC DSTwo (DS Cart)

    Thoughts and help on all of this greatly appreciated :)
     
    Last edited by Skeet1983, Aug 13, 2017


  2. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    First, if you are using Luma3DS and B9S, it is safe to update your sysNAND to 11.5 over the internet.

    To be able to use newer versions of Luma3DS, you need to update B9S to v1.2: https://3ds.guide/updating-b9s
     
  3. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Ok, thanks for the info. Is 11.5 still latest? Also, should I update Luma? I used to be on Luma 8.x, but went back to 7.x due to Arm11 crashes.
     
  4. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    Yes, 11.5 is still the latest. In principle, future 3DS updates should be compatible with Luma3DS, but it's always a good idea to check first before updating.

    If you are able to run Luma3DS 7.0.5 or lower, then you are using A9LH and should update to B9S in order to be able to use newer versions of Luma3DS.
    If you are able to run Luma3DS 7.1, then you are using B9S v1.0 and should update to B9S v1.2 in order to be able to use newer versions of Luma3DS.
     
  5. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Ok, thanks. But is there any reason/benefits to using newer B9S and Luma? I kept getting Arm11 crashes with Luma 8.x...
     
  6. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    To be clear, can you boot your 3DS with Luma3DS 8.X? Are you using a custom version of Luma3DS 7.1 modified to be compatible with B9S v1.2?

    If the answer is yes to these questions, then you should give Luma3DS 8.1.1 a try and see if it fixes your errors.
    If the answer is no to these questions, then the reason you can't use Luma3DS 8.X is because you need to update to B9S v1.2 first.
     
  7. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    I am not sure... How do I update luma? When I pressed Select at system boot, it said my Luma is 7.1-fc7d554a...
     
  8. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    Download Luma3DS 8.1.1 and put the boot.firm file onto your SD card.
    1. Can you boot your 3DS with this version of Luma3DS?
    2. Does it say Luma3DS 8.1.1 at the top of the confirguation settings screen when you hold Select at boot?
     
  9. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Ok, I will try that after I get back from work today. For step 1, what do I do if system does not boot? Am I screwed if that happens? Sorry, am new to using B9...
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    If your system does not boot with Luma3DS 8.1.1, then that means you likely have B9S 1.0 installed, which is incompatible with Luma3DS 8.X. You will need to put Luma3DS 7.1 back onto your SD card before following this guide to update B9S to v1.2. Following the guide to the end will update your B9S version to 1.2, and it will update your Luma3DS version to 8.1.1.
     
    Skeet1983 likes this.
  11. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Ok, I put Luma 8.1.1 on SD root. When I booted system, Luma config screen came up. It says Luma3DS 8.1.1 at top of screen. What options should I select?
     
  12. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    Good, that means you have B9S v1.2 installed. That made your job easy.

    The only option that should be selected is: “Show NAND or user string in System Settings”
     
  13. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Thanks for the help!! System booted fine after selecting option in Luma config (Show NAND String). What should I do now? Should I go ahead and update to FW 11.5?

    I just checked System Settings Menu. It says my SysNAND is on 11.4.
     
  14. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    Yes, you can go ahead and update to 11.5. With Luma3DS 8.1.1, I predict you aren't going to get the same ARM11 errors you got before. If you do get errors, then there's some other problem going on that's likely unrelated to Luma3DS.
     
  15. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Ok, thanks :)

    When I did get the Arm11 errors, it was when using LibRetro emulators mostly. I never got an Arm11 error/crash when playing a 3DS CIA game...
     
  16. HugaTheFox

    HugaTheFox GBAtemp Advanced Fan

    Member
    574
    139
    Feb 11, 2017
    United States
    Las Vegas
    Nightly of LibRetro? They crash alot. Stable is... well.... way stabilized
     
  17. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    I don't think it was a nightly version. I will post version I have after get home from work.


    Sent from my iPhone using Tapatalk
     
  18. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Hi guys, I am back :)

    I am currently backing up SysNAND and then was going to update System FW to 11.5. Is 11.5 still latest for sure? I just don't want to mess anything up. Thoughts and help appreciated :)
     
  19. Lacius

    Lacius GBAtemp Guru

    Member
    6,120
    2,448
    May 11, 2008
    United States
    As of this post, 11.5 is still currently the latest system version. As I mentioned earlier, the way Luma3DS works, future 3DS system versions are also likely to work with Luma3DS.
     
    Skeet1983 likes this.
  20. Skeet1983
    OP

    Skeet1983 GBAtemp Addict

    Member
    2,679
    187
    Apr 22, 2012
    United States
    Somewhere, out there...
    Ok, here are the Libretro's I am using:

    SNES: 1.3.3- PocketSNES 7.2.0
    GBA: 1.3.3- gpSP v0.91

    Really wish I knew what was causing the Arm11 crashes in Luma 8.x in System FW 11.4. I am now on System FW 11.5 and Luma 8.1.1. Thoughts and help appreciated :)