RIP DSiWare savegame based exploits

Discussion in 'NDS - Emulation and Homebrew' started by WiiUBricker, May 21, 2011.

May 21, 2011
  1. WiiUBricker
    OP

    Member WiiUBricker Insert Custom Title

    Joined:
    Sep 19, 2009
    Messages:
    5,828
    Location:
    Espresso
    Country:
    Argentina
    I wonder why this havent been posted here.

    Source
     


  2. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Since already-existing copies of sudokuhax worked, I guessed people assumed it wasn't blocked.

    EDIT: And since you can't get an exploitable copy of the game this only matters for... well, almost nobody.
     
  3. WiiUBricker
    OP

    Member WiiUBricker Insert Custom Title

    Joined:
    Sep 19, 2009
    Messages:
    5,828
    Location:
    Espresso
    Country:
    Argentina
    I guess the possibility of working DSiWare exploits on 3DS is out of question now.
     
  4. Snailface

    Member Snailface My frothing demand for 3ds homebrew is increasing

    Joined:
    Sep 20, 2010
    Messages:
    4,324
    Location:
    Engine Room with Cyan, watching him learn.
    Country:
    Antarctica
    Am I reading this correctly, or are they saying they're going to release another DSi exploit?! [​IMG]
    I'm staying on 1.4.1u for sure -- whatever the case may be.
     
  5. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    I wouldn't aim for those anyways, since they can be easily pulled and patched. Retail games can't.
     
  6. Sir_Voe

    Member Sir_Voe GBAtemp Fan

    Joined:
    Apr 28, 2007
    Messages:
    318
    Country:
    United States
    Thanks for the heads up. Now I know not to delete the hacked sudoku file from my 1.4.2 DSi.
     
  7. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,747
    Country:
    United Kingdom
    Kind of surprised they still left themselves at least a bit open to save hacks but I suppose we are still in embedded (passively cooled and battery powered) system territory.

    "it’s impossible to obtain your system certs without soldering NAND"

    All those pads and not one hooks up to the NAND?
     
  8. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Yes they are releasing another DSiWare exploit. They haven't announced which title will be, but if you don't already have the game, you will not be able to use the exploit. Or if you update to 1.4.2 you won't be able to use the exploit regardless.
     
  9. WiiUBricker
    OP

    Member WiiUBricker Insert Custom Title

    Joined:
    Sep 19, 2009
    Messages:
    5,828
    Location:
    Espresso
    Country:
    Argentina

    Basically it's a decision between having access to the DSi shop which includes access to a library of DSiWare titles and having limited DSi homebrew capability with a very small library of homebrew applications that are also available as DS homebrews...
    I would go for DSiWare.
     
  10. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Very true. Seeing as pretty much all (decent) flashcarts are already updated, there's little point in not upgrading tbh. But anyone who wants a chance of DSiWareHax should hold off updating.
     
  11. Sora de Eclaune

    Member Sora de Eclaune Baby squirrel, you's a sexy motherfucker.

    Joined:
    Feb 15, 2011
    Messages:
    2,785
    Location:
    123 Fake Street
    Country:
    United States
    I bet they're going to go the way of the PSP and have signed applications made in the future.
     
  12. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Extremely unlikely. PS3 is the only console that has ever had the private key found (and PSP signing only resulted from the PS3 keys), and that was due to a fatal flaw in the way the security system was implemented. There have been several very clever people hacking at the DSi for a long time, if there were a flaw to find any useful keys it would have been found by now.
     
  13. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    If they already have the exploitable version of sudoku, want to make use of it, and have not yet made use of it.

    Which is how many people? [​IMG]
     
  14. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Or if they have the as-of-yet unnamed DSiWare exploit that will be released in the future (at least, that's how I read the HackMii post). Which could be loads of people, we don't know seeing as we don't know what game it is yet.
     
  15. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Oh, that is a good point.
     
  16. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Just re-read and it says most people won't have it. But still, some might, and you won't know until its announced.
     
  17. Snailface

    Member Snailface My frothing demand for 3ds homebrew is increasing

    Joined:
    Sep 20, 2010
    Messages:
    4,324
    Location:
    Engine Room with Cyan, watching him learn.
    Country:
    Antarctica
    The message I'm getting is that you have to have a certain game and 1.4.1 before the new exploit (!) arrives after the 3ds update. Question is: (like you said) how in the hell are we supposed to know what game to get? [​IMG]

    I dunno, check the hackmii post's comments yourselves and see what you guys think ( and leave comments to help clear this up)

    http://hackmii.com/2011/05/dsi-system-update-1-4-2/
     
  18. Cuelhu

    Member Cuelhu КУ!

    Joined:
    May 19, 2010
    Messages:
    536
    Location:
    Fantasy Land
    Country:
    you can't get it without updating your DSi.............. And if you update, you're on 1.4.2 so no exploit possible.......... [​IMG]

    Only those who ALREADY have The Game will be able to use this exploit.
     
  19. Ammako

    Member Ammako GBAtemp Guru

    Joined:
    Dec 22, 2009
    Messages:
    6,372
    Country:
    Canada
    Lets you use nesDS without having to hack your console and without having to buy a flashcart.
     
  20. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    You can't know what game to get, and you can't get it now anyway. You'd have to update to access the DSi Shop, and if you did that, the exploit wouldn't work. You must already happen to own the game to be able to use the exploit.
     

Share This Page