Question Retroarch scummVM core not loading

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by CTBC, Oct 15, 2018.

  1. CTBC
    OP

    CTBC Member

    Newcomer
    3
    Dec 25, 2008
    United Kingdom
    I am unable to get the scummVM core to run from within retroarch, I have scummVM 2.12 and all works brilliantly.
    I "load" the core then "run" the core buy I get a black screen and retroarch freezes, switch does not freeze as I am able to return to the menu screen.
    Other cores seem to work well although I have not tested them all.
    I have re copied the latest build after deleting the originally copied retroarch files (including all .cfg files) without success.
    Any advice would be appreciated.
     
  2. notimp

    notimp GBAtemp Addict

    Member
    9
    Sep 18, 2007
    Use gamename.scummvm files in the same directory as the game you want to play as the "target" for the load content dialog.

    So - first load the core, then use load content to navigate to a game folder, which has to hold a gamename.scummvm file - you've placed there before.

    You can read up on how to "create" (doesnt take much) a .scummvm file here: https://forums.libretro.com/t/importing-scummvm-games/10153

    Loading that file (while the core is loaded), should load up the game.

    If you want to change the games settings (away from default) read the ScummVM thread in this forum around the current date - because for that you also need a slight workaround.
    -

    If that doesnt work, use yesterdays daily build from here: http://buildbot.libretro.com/nightly/nintendo/switch/libnx/2018-10-14_RetroArch.7z

    I'm running that one without issues.

    Daily builds can be found here:
    http://buildbot.libretro.com/nightly/nintendo/switch/libnx/

    Dont run daily builds if you are still heavily reliant on "support requests" - having everyone around using a different version of retroarch just complicates things.. ;)

    Thats for everyone who might read this and think: "Amazing idea!" right away.. ;)
     
    Last edited by notimp, Oct 15, 2018
    CTBC likes this.
  3. CTBC
    OP

    CTBC Member

    Newcomer
    3
    Dec 25, 2008
    United Kingdom
    Thanks for the help.

    I am using the build http://buildbot.libretro.com/nightly/nintendo/switch/libnx/2018-10-14_RetroArch.7z

    I made a txt file named as per instructions but without any luck (tried on 4 different games)

    I did notice on the https://forums.libretro.com/t/importing-scummvm-games/10153 which states "The only thing is that you would have had to add the game previously in the black/green GUI once, but after that you can open it using the scummvm file." Unfortunately I am unable to get to the GUI.
     
  4. notimp

    notimp GBAtemp Addict

    Member
    9
    Sep 18, 2007
    Yes - I didnt need to do this. Loading the .scummvm file autopropagated (in said menu) and loaded the game.

    .scummvm files might have to have linux (unix) file endings. Try downloading those files from here (using rightclick on the raw option, or via zip export if you are not familiar with git):
    https://github.com/RobLoach/libretro-database-scummvm/tree/master/games

    There are quite a few files in this folder, but usually they have the same "game id" within them - only a slightly different title (title is what shows up in the retroarch level menues) - so finding "a correct one" shoulndt be too hard.

    Games are confirmed loading in other versions of retroarch?

    If not: http://wiki.scummvm.org/index.php/Datafiles and test them on a PC build first.

    If that doesnt help - file corruption on exfat is my next guess.. ;)

    — Posts automatically merged - Please don't double post! —

    Just tested hitting "run" while the scummvm core is loaded and no game is specified. In my case this brings up the scummvm menu. But that is after starting/propagating it for the first time with a .scummvm file.

    So I dont know if that was necessary for it to actually run upon only hitting run.

    You've got the exact version I use - cant think of anything else... I'm using gl as the video driver - maybe thats important as well (but also - its the default).

    I didnt do any scummvm.ini tweaks, or anything of that sort beforehand either. Just a fresh RA install.
     
    Last edited by notimp, Oct 15, 2018
    CTBC likes this.
  5. notimp

    notimp GBAtemp Addict

    Member
    9
    Sep 18, 2007
    Tested with sword1 and dott (CD version). Both work in my case. (For dott, just used the downloaded file (for sword1 I wrote one) - worked. :) )

    (edit: I'm also directly launching the retroarch nro from hbmenu, because Im still on 3.0.0 - shouldnt matter, but... :) )
     
    Last edited by notimp, Oct 15, 2018
  6. CTBC
    OP

    CTBC Member

    Newcomer
    3
    Dec 25, 2008
    United Kingdom
    Thanks again.

    Tried again with listed .scummvm file as you advised but no luck on retroarch version...works on ScummVM v2.12.....works on PC

    I am using FAT32 but am more than happy to try something else.

    I have re copied the latest build after deleting the originally copied retroarch files... are there any other "left over" files that could be corrupted ?

    I am 100% sure it is my fault as no one else has this problem :(
     
    Last edited by CTBC, Oct 15, 2018
  7. notimp

    notimp GBAtemp Addict

    Member
    9
    Sep 18, 2007
    Nope, that should be all the files. I'm also on fat32. And as just stated in an edit - I'm launching the Retroarch nro through hbmenu, as I am on 3.0.0 still.

    If you are on fat32 forget the "file corruption" comment imho.
     
  8. CTBC
    OP

    CTBC Member

    Newcomer
    3
    Dec 25, 2008
    United Kingdom
    Do you mind if I ask what CFW you are using ?
     
  9. notimp

    notimp GBAtemp Addict

    Member
    9
    Sep 18, 2007
    None, thats it. :) 3.0.0 With the switchbrew hack and HBmenu. (Firmware has a software hack open).

    But at this point - let us make this a callout to other users that use Retroarch and the ScummVM core on CFW - or are about to try it.

    - If you are about to run it (for the first time) - try loading the core, and just running it, without loading any games first. Do you get to the scummvm menu that way?

    - If you've already run it - please report back the firmware / CFW version you are on - and any other aspect you can think of, we might have missed so far. :)
     
    Last edited by notimp, Oct 15, 2018
    CTBC likes this.
Loading...