Restoring NAND

Discussion in 'Wii - Hacking' started by brawllegend, Apr 17, 2011.

Apr 17, 2011

Restoring NAND by brawllegend at 7:49 PM (1,148 Views / 0 Likes) 4 replies

  1. brawllegend
    OP

    Newcomer brawllegend Newbie

    Joined:
    Aug 22, 2007
    Messages:
    4
    Country:
    United States
    Hello,

    I recently helped a friend softmod his Wii who had 4.2u and installed the HBC along with Bootmii as boot2. I made a backup of his NAND as well. He accidentally updated to 4.3u (official update), so I figured restoring the NAND would bring it back to its previous state (I realize I could have remodded as if it were a new, 4.3 wii, but I felt like Bootmii would be a simpler, more reliable approach). I went to restore it back to the state it was in when I made the backup and this is the result of the simulation:

    http://i237.photobucket.com/albums/ff86/br.../0416111653.jpg

    I continued with the restoration and it said it was successful. It then booted to the system menu.

    I went to the settings to see if it worked, and it still said the firmware version was 4.3u. So I checked to see what was still there from the 4.3 update and I saw that IOS58 was still there, and cIOS249 along with many others were still stubbed. The Wi-Fi connection settings reverted back to the way they were when I made the NAND backup though. I then did the following:
    -Deleted IOS58 and reinstalled a clean copy (in case it was corrupted)
    -Deleted the stubbed cIOS's through Multi-Mod Manager
    -Reinstalled the cIOS's (236,249,250) with appropriate installers
    -Reinstalled the HBC and Bootmii as boot2
    -Installed StartPatch to prevent future updates.

    Is it now essentially the same as it was with 4.2, or is it unstable? Why didn't the NAND backup restore all of the IOS's to the way they were?
     
  2. FIX94

    Global Moderator FIX94 Global Moderator

    Joined:
    Dec 3, 2009
    Messages:
    6,547
    Location:
    ???
    Country:
    Germany
    It is exactly the same than 4.2. It's very strange that the bootmii restore didn't worked correctly, but that's no problem. I never restored a nand backup so I can't say if it's normal or not. Startpatch is not the very best solution but because the wii has bootmii boot2 it's no problem.
     
  3. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    Bootmii only restores what has changed since you made the backup. You must have made the backup in the middle of the softmodding process, or your friend has played "Your Shape" and installed IOS58 through that.

    I don't know why StartPatch is even still active. Priiloader is far more practical and much easier to use. I suggest you resoftmod with mauifrog's Softmod ANY Wii, since you have a pretty incomplete softmod.

    Just for future, never uninstall an IOS under 200. If you think the installed copy is corrupted for some reason, just reinstall it. It will overwrite the (possibly) corrupt version.
     
  4. brawllegend
    OP

    Newcomer brawllegend Newbie

    Joined:
    Aug 22, 2007
    Messages:
    4
    Country:
    United States
    Yeah the backup was made right away before doing anything with custom IOS's, and I am sure IOS58 was not on it when I made the backup. I'll uninstall StartPatch and use Priiloader following mauifrog's guide though. Thank you both!
     
  5. troy512

    Newcomer troy512 Advanced Member

    Joined:
    Jan 24, 2010
    Messages:
    95
    Country:
    United States
    thats a normal simulation.

    since he did and update you didnt properly hack his wii and install priiloader to block updates.

    there are guides which install IOS58 before running hackmii installer, this way HBC uses IOS58 when installed so you dont have to reinstall HBC to IOS58.

    cIOS are stubbed on virgin 4.2 so this is no indication of problem.

    strange that the system menu version was 4.3, i have no rebuttal for this one. LOL

    ive restored bootmii backups many times, purposely bricked my wii for the hell of it, installed and uninstalled many things out of curiosity and have used ohneswanzenegger [which is an app for creating a new custom nand]

    never had this issue. my backups have always restored properly.

    i know this doesnt help with your problem, just wanted to get it out there.
     

Share This Page