Red Dead Redemption 2 Firmware Requirement

Discussion in 'PS4 - Games & Content' started by onibaku, Oct 27, 2018.

  1. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
    So I got Red Dead Redemption 2 (got it for a good price) and my ps4 is on fw 5.55 but I don't want to update past this due to the potential release of an exploit.

    Could I run Red Dead 2 on 5.55? Otherwise I might just sell it.. Couldnt find any info on the firmware requirement..
     
  2. shano

    shano GBAtemp Regular

    Member
    5
    Aug 27, 2012
    Australia
    Stick the disc in and try?
     
  3. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
    Ive kept the game sealed for now, it would be easier to sell. Thought I'd find out before unsealing it
     
  4. Jay Griggs

    Jay Griggs Member

    Newcomer
    4
    Jan 4, 2016
    United States
  5. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
    Hmm but i think thats the firmware requirement for the game patch v1.02 :unsure:
     
  6. Hayato213

    Hayato213 GBAtemp Guru

    Member
    12
    Dec 26, 2015
    United States
  7. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
  8. Hayato213

    Hayato213 GBAtemp Guru

    Member
    12
    Dec 26, 2015
    United States
    Same rule apply for base game, disc or digital.
     
  9. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
    ah okay, thats a shame... well thx for the info, I will sell it then :(
     
  10. MasterJ360

    MasterJ360 GBAtemp Advanced Maniac

    Member
    7
    Jan 10, 2016
    United States
    Best bet is that pretty much any game coming out now is gonna need 6.0+ as a base game
     
    Girtana1, Panzer_Baboon and KiiWii like this.
  11. EmulateLife

    EmulateLife GBAtemp Psycho!

    Member
    7
    May 30, 2016
    United States
    5.55 probably isn't getting hacked any time soon either. I've heard it could be up to a year. It's up to you but I'd just update and enjoy it and if you can afford it buy another PS4 on 5.05 and hack it.
     
  12. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
    Hmm yeah ur right, Im actually considering whether I really need to have a hacked ps4..
     
  13. Jay Griggs

    Jay Griggs Member

    Newcomer
    4
    Jan 4, 2016
    United States
    Does the game actually need something from the system update or is spoofing possible like the wii u used to be?
     
  14. MasterJ360

    MasterJ360 GBAtemp Advanced Maniac

    Member
    7
    Jan 10, 2016
    United States
    I believe the main issue is that we cannot dump games requiring higher firmwares simply b/c they aren't exploited to allow us. Its different than ps3 or wii u b/c we weren't restricted in dumping games by firmware to make spoofing possible on lower firms
     
    Girtana1 likes this.
  15. cypekis11

    cypekis11 Newbie

    Newcomer
    1
    Oct 28, 2018
    Poland
    So did you test it? If it works it would be great.
     
  16. onibaku
    OP

    onibaku GBAtemp Regular

    Member
    4
    Aug 15, 2007
    Yup I tested it, it requires 6.00 :/
     
    Girtana1 likes this.
  17. protivakid

    protivakid Advanced Member

    Newcomer
    2
    May 6, 2014
    United States
    So even if we use a lower PS4 FW as an entry point, we can't then upgrade to a higher version CFW like on the PS3 or spoof a higher version to boot newer games?
     
  18. osaka35

    osaka35 Instructional Designer

    Moderator
    12
    GBAtemp Patron
    osaka35 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 20, 2009
    United States
    Silent Hill
    Nah, we don't have ps4 CFW yet. no way to spoof and no way to update without losing the entry-point. It's a "wait-and-hope" situation right now.
     
    protivakid likes this.
  19. Girtana1

    Girtana1 Advanced Member

    Newcomer
    3
    Jun 22, 2016
    United States
    New York
    Is a dumper that force reads the disc not possible?
     
  20. osaka35

    osaka35 Instructional Designer

    Moderator
    12
    GBAtemp Patron
    osaka35 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 20, 2009
    United States
    Silent Hill
    the games are encrypted using keys unique to those firmwares, and those keys haven't been cracked (more or less).
     
    Last edited by osaka35, Dec 12, 2018
    Girtana1 likes this.
Quick Reply
Draft saved Draft deleted
Loading...