R4i SDHC 'v1.4'

Discussion in 'R4 DS' started by raiderscrusade, Feb 28, 2011.

Feb 28, 2011

R4i SDHC 'v1.4' by raiderscrusade at 7:13 AM (936 Views / 0 Likes) 2 replies

  1. raiderscrusade
    OP

    Member raiderscrusade GBAtemp Fan

    Joined:
    Jun 30, 2009
    Messages:
    433
    Country:
    Australia
    Hello,

    I have an R4i SDHC v1.4 from r4i-sdhc.com which I have had since I bought my DSi on v1.4 firmware.

    I've been keeping an eye out on the R4i SDHC website waiting for a v1.4.1 update that doesn't involve purchasing a new cart, which has left me at square 1. The manufacturer seems to just say that v1.4 R4i cards do not work on v1.4.1 DSi firmware, and state that they are 'working on an update' - the same statement they have had for a long time.

    Lately, with the release of the 3DS, I have heard about all these options stating things such as 'an update to the bootstrap is all that is needed'. This brings me to my question.

    Is there any way to update the R4i SDHC v1.4 bootstrap myself, so that I can get it to work on v1.4.1 DSi, or should I just stick with v1.4 DSi firmware and the latest update that is compatible with v1.4 cards?

    I just want to outweigh my options, you see.

    I hope someone can help.

    Thanks [​IMG]
     
  2. Qtis

    Member Qtis Grey Knight Inquisitor

    Joined:
    Feb 28, 2010
    Messages:
    3,762
    Location:
    The Forge
    Country:
    Antarctica
    All carts with an updatable bootloader can be updated to work on the 1.4.1 fw. In your case, it looks like your R4i SDHC v1.4 can't be upgraded. It's like trying to get an old DS/DSL compatible flash cart to work on a DSi. It just doesn't work since the DSi blocks them. If you want a cart that works with 1.4.1 and want it cheap, get an AK2i or R4i Gold. Both have updatable bootloaders IIRC.

    Updating the loader in a cart that doesn't have an updatable bootloader would require soldering a few times and then you'd have to create a loader which isn't feasible. Just go with a new cart in that case (they go for around 10-15 dollars).


    -Qtis
     
  3. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    I'm not sure if the R4i Gold has an updateable bootloader. While it is one of the better R4-named carts (official Wood support) I haven't actually seen anybody talk about updating theirs since they came out with Wood support for them after 1.4.1 and they could just ship pre-flashed.

    But yes, the AK2i can be updated, as can the Supercard DSTwo, and EZ-Flash VI.
     

Share This Page