R4DS on a DSi?

Discussion in 'R4 DS' started by Rhymey, Aug 11, 2009.

Aug 11, 2009

R4DS on a DSi? by Rhymey at 5:43 PM (1,395 Views / 0 Likes) 5 replies

  1. Rhymey
    OP

    Newcomer Rhymey Newbie

    Joined:
    Aug 3, 2009
    Messages:
    3
    Location:
    Your closet.~
    Country:
    United States
    So... Many posts on this forum say that the R4DSi and all other DSi-specific flashcarts run in normal DS mode as DSi mode hasn't been cracked/hacked/whatever.. Does this mean, if you own a REGULAR R4DS, and just apply the firmware on the flashcarts homepage, it will run properly, but when DSi Mode is hacked/whatever, it would be best to upgrade to an R4DSi?

    Thanks. ^^

    Rhymey~
     
  2. Depravo

    Global Moderator Depravo Jaded curmudgeon

    Joined:
    Oct 13, 2008
    Messages:
    5,076
    Location:
    Purgatory
    Country:
    United Kingdom
    No. Flashcarts designed for the DS Lite/Phat will not work on the DSi with ANY firmware.

    PS 'Upgrade to' and 'R4' should never be used in the same sentence unless said sentence is preceded by the words 'Do not' or 'Never'.
     
  3. RupeeClock

    Member RupeeClock Colors 3D Snivy!

    Joined:
    May 15, 2008
    Messages:
    6,307
    Country:
    United Kingdom
    Rhymey, the R4 is a very outdated flashcart, even if it's the most popular flashcart to the uneducated public. There is also no guarantee that you will receive an authentic R4 these days.

    Trust me on this, don't get an R4i, get something like an M3i Zero, it is superior in many ways.
     
  4. luke_c

    Member luke_c Big Boss

    Joined:
    Jun 16, 2008
    Messages:
    3,587
    Location:
    Land of England
    Country:
    United Kingdom
    No current DS/DSL Flashcarts will work on a DSi due to the fact that it needs a different code signature to bypass which the current cards do not have. It's Hardware which needs to be changed. Not Software/Firmware.
     
  5. DrOctapu

    Member DrOctapu Magnificent Bastard

    Joined:
    Dec 23, 2008
    Messages:
    1,207
    Location:
    Hell.
    Country:
    United States
    Get an Acekard2i, I upgraded to one after the r4 started to piss me off.
     
  6. cturtle

    Newcomer cturtle Member

    Joined:
    Sep 16, 2008
    Messages:
    25
    Country:
    Canada
    Yeah, definitely go with an Acekard. I bought the R4i because I owned an authentic R4 that worked perfectly for me for over a year. However, I was not so lucky with the R4i. It would randomly delete or corrupt save games, which meant started games over every time I play them. A week later I bought an Acekard and haven't looked back. They just released a fix for the 1.4 update from Nintendo, so you've got nothing to worry about. [​IMG]
     

Share This Page