R4 Custom Firmware or Hacked firmware

Discussion in 'R4 DS' started by beve, Aug 10, 2008.

Thread Status:
Not open for further replies.
Aug 10, 2008
  1. beve
    OP

    Banned beve Banned

    Joined:
    May 31, 2008
    Messages:
    108
    Country:
    Australia
    I need help, im trying to stop my poor ds from being bricked and i need a new firmware. here are the ones i have tryed

    M3DSS:stoped using it because they are releasing a bricking firmware

    YSmenu:Cannot boot Homebrew

    M3 Sakura:Carnt boot games

    And these are the ones that i haven't tried

    R4 III.....very updated would be nice

    R4 SDHC.....sdhc would be great

    Cyclo DS Evo.....would be nice

    M3 Real.....most favored

    Supercard...not very favored but if it means no brick i'm with ya

    thank you for reading and i thank you SO SO SO SO MUCH if you can help me out [​IMG]
     


  2. matrix121391

    Member matrix121391 GBAtemp Fan

    Joined:
    Feb 5, 2008
    Messages:
    377
    Country:
    United States
    Uhh... I'm not really understanding what you've asked, but I'm going on a limb and assume that you're asking what firmware you should download. Download the official 1.18 firmware for the R4. It won't brick your DS and works perfectly fine... (I think). I think the firmware you are thinking of that will brick your DS is 1.19, which isn't out yet and when it will, you'll probably read threads about it and how someone will have hacked it and made it safe. But like I said, firmware 1.18 is the way to go. I think there are several games that don't work with the 1.18 firmware (Trauma Center 2?), but there's a patcher for it, and even a patched version... 1.18.
     
  3. Sir-Fritz

    Member Sir-Fritz GBAtemp Maniac

    Joined:
    May 4, 2008
    Messages:
    1,336
    Location:
    Brisbane, Australia
    Country:
    Australia
    I know for a fact that the cyclods firmware has no chance of running on an R4 without beeing heavily modded, like what the edge firmware is like. and for the last time, r4sdhc firmware wont make your r4 sdhc.
     
  4. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom

    use the original R4 1.18 KERNEL and run YSMENU as an NDS FILE and dont set it as the main KERNEL loader then you can boot homebrew in R4 and swap to YSMENU for games that dont work in 1.18 [​IMG]
     
  5. seedvt

    Member seedvt GBAtemp Regular

    Joined:
    Mar 19, 2008
    Messages:
    225
    Location:
    Vancouver, BC
    Country:
    Canada
    In terms of future compatibility, YSMenu seems to be the only candidate.

    I'm sure Yasu will develop a DLDI for it eventually.
     
  6. matrix121391

    Member matrix121391 GBAtemp Fan

    Joined:
    Feb 5, 2008
    Messages:
    377
    Country:
    United States
    Maybe it'd be easier to find the patch version... but I did not know that method!
     
  7. beve
    OP

    Banned beve Banned

    Joined:
    May 31, 2008
    Messages:
    108
    Country:
    Australia
    skrew R4 team im not running the risk i have a brand new ds lite and its not happening

    UPDATE:SDHC DOSENT WORK stuck on loading screen

    im not running the new firmware no matter what and please dont leave no shit Sherlock answers like matrix

    so please people dont leave answers on telling me to run the stinking r4 firmware IM NOT!
     
  8. beve
    OP

    Banned beve Banned

    Joined:
    May 31, 2008
    Messages:
    108
    Country:
    Australia
    ysmenu is crap i cannot boot hb and i heard there a teendev or something flashcard OS
     
  9. seedvt

    Member seedvt GBAtemp Regular

    Joined:
    Mar 19, 2008
    Messages:
    225
    Location:
    Vancouver, BC
    Country:
    Canada
    Well, you're SOL then if you're not satisfied with either YSmenu and the regular R4 kernel.
     
  10. Dark^'^Knigh

    Member Dark^'^Knigh GBAtemp Maniac

    Joined:
    Apr 25, 2007
    Messages:
    1,043
    Location:
    Paradise
    Country:
    Australia
    Beve,

    No doubt about it, you love chasing your own tail! [​IMG]
    My Gee-O-Dee, you are extremely lucky no one has flamed you yet! ...they must be having the day off [​IMG]

    Although you already know the answer, there are your ONLY two options:
    1. R4DS firmware, latest is 1.18 (hacked Sakura is only useful for music/movie files)
    2. YSMenu hack - ROM (better compatability) & direct boot to expansion pack. No homebrew works yet.

    I already know you are not going to like the answer, but you need to face facts. If you are that sh*t scared of bricking your DS for a possible future R4 firmware update, you should look to purchase another cheap slot-1 and use it until ALL of the other R4 users brick there ds (or not!).
     
  11. Holaitsme

    Member Holaitsme 10/10 would be loyal again

    Joined:
    May 14, 2008
    Messages:
    846
    Country:
    United States
    well i want to flame him but i just cant think of anything.
     
  12. Joey R.

    Banned Joey R. Banned

    Joined:
    Jul 7, 2008
    Messages:
    291
    Location:
    Oviedo, Asturias
    Country:
    Spain
    Then why on Earth did you buy an R4? You should have bought another card if you wanted to run other cards' firmwares... Your point was valid enough when you started this topic, but your QQ attitude is starting to irritate people.
     
  13. Sir-Fritz

    Member Sir-Fritz GBAtemp Maniac

    Joined:
    May 4, 2008
    Messages:
    1,336
    Location:
    Brisbane, Australia
    Country:
    Australia
    I really really want to flame him as he is starting to piss me off but i dont flame so yeah...
     
  14. Holaitsme

    Member Holaitsme 10/10 would be loyal again

    Joined:
    May 14, 2008
    Messages:
    846
    Country:
    United States
    if urza read this ....
     
  15. Sjaool

    Newcomer Sjaool Advanced Member

    Joined:
    Aug 19, 2007
    Messages:
    52
    Location:
    Noordoostpolder
    Country:
    Netherlands
    He could always buy a flashcard with REAL support.

    If you don't like R4 so why use it?
     
  16. littlestevie

    Member littlestevie GBAtemp Regular

    Joined:
    Jun 15, 2008
    Messages:
    234
    Location:
    under a bridge
    Country:
    Australia

    1) its a DS light they have a bootblock that cant be overwritten without shorting SL1 i believe it is....

    2) sorry but i cant handle people like you who buy something then fucking bitch about it...

    if its so much of a fucking problem throw the fucking R4 in the bin and oh.... i dont know buy a card that runs the firmware that you like

    seriously

    you are a douche
     
  17. TrolleyDave

    Former Staff TrolleyDave Philosolosophising

    Joined:
    Jan 1, 2007
    Messages:
    7,762
    Location:
    Wales, UK
    Country:
    United Kingdom
    Did the thought ever cross your mind that he bought the card a while back while the support was still good?
     
  18. Narin

    Former Staff Narin The Cheat Master, kupo!

    Joined:
    Feb 19, 2008
    Messages:
    2,624
    Country:
    United States
    I suggest not getting the R4 and if you already have one, you really should think about getting a new flashcard, there are plenty of flashcards out there that are far cheaper and have better support, compatibility and features. The R4 has stopped being manufactured which means that it has reached the end of its life. You can expect only minor updates if any at all from the R4 team though right now, it doesn't look promising.

    Several games, even some that came out over a year ago don't work on the R4. Also many newer games coming out have problems on the R4 either not running the game at all or the game is extremely buggy and freeze often. Also games with the new save type are not supported on the R4 so any games coming out with the new save type will not save. Also there are a few homebrew apps that have trouble on the R4 as well.

    The R4 overall, is extremely limited and buggy. The cheat system has many flaws and can cause games to freeze or simply nt work when using cheats on some games. Also a few cheat types are not supported leaving you with a good many cheats not working on the R4. Also the R4 limits the number of cheats and games that gets displayed on the cheats page.

    So basically, the R4 is on life support ans has been for quite a long time now. Many newer flashcards have surpassed the R4 in many ways, including compatibility. The R4 is showing its age, thanks to hardware limitations (The R4 Firmware not being flashable), features like SDHC support and many others can never be added. The R4 was a fine cart when it first came out, but now its just an old, over prices flashcard.

    I also want to know that the R4 has many clones as well, some supporting SDHC cards. These are not enhanced R4s nor improved, they simply had the hardware added to support SDHC cards while the loader/firmware they use is the exact same as the real R4DS byte to byte. This means that the clones have the same problems of the real R4DS and if the R4DS stops getting updated, so will the clones. So the R4 Upgrade V2, N5, R4DS III and so on are just all cheat knockoffs and should be avoided at all costs as the R4 Team is planning one last update that will brick the clones and possibly the DS that they are on.
     
  19. littlestevie

    Member littlestevie GBAtemp Regular

    Joined:
    Jun 15, 2008
    Messages:
    234
    Location:
    under a bridge
    Country:
    Australia
    the OP has a brand new ds lite...

    Nuff said
     
  20. ENDscape

    Member ENDscape REBORN! I will post with my Dying Will!!!

    Joined:
    Dec 14, 2007
    Messages:
    1,488
    Location:
    ``orz
    Country:
    Philippines
    Id like to make my flame reality and burn you...LOL. So please accept the truth and listen to them about ysmenu or buy a new flashcart.
     
Thread Status:
Not open for further replies.

Share This Page