Quick Firmware Update Confirmation

Discussion in '3DS - Homebrew Development and Emulators' started by vgplayer54, Oct 11, 2016.

  1. vgplayer54
    OP

    vgplayer54 GBAtemp Regular

    Member
    203
    12
    Feb 4, 2010
    Canada
    Hello,
    Just a quick confirmation - I have a New 3DS with Luma3DS and arm9loaderhax installed. I am at firmware 11.0.0-33U. Is it safe for me to update via System Settings? (the official method?) or would that break the homebrew?
     
  2. metroid maniac

    metroid maniac An idiot with an opinion

    Member
    1,800
    718
    May 16, 2009
    It's safe. In general you can assume it's safe to update, but seeking out confirmation is ideal.
     
  3. vgplayer54
    OP

    vgplayer54 GBAtemp Regular

    Member
    203
    12
    Feb 4, 2010
    Canada
    That's all I needed to hear. And yes, that is why I quickly went to seek some confirmation here. Thank you very much.
     
  4. xXDungeon_CrawlerXx

    xXDungeon_CrawlerXx GBAtemp Maniac

    Member
    1,195
    527
    Jul 29, 2015
    Liverpool
    For me, the Update over the system Settings always stops with an error.
    Using SysNAND 11.0 (A9LH + Luma).
    Is there a way to install the newest update without searching for the reason why it won't update?
     
  5. vgplayer54
    OP

    vgplayer54 GBAtemp Regular

    Member
    203
    12
    Feb 4, 2010
    Canada
    I unfortunately just had the same thing - "an error has occurred. Unable to update. The system will now be restarted"
     
  6. xXDungeon_CrawlerXx

    xXDungeon_CrawlerXx GBAtemp Maniac

    Member
    1,195
    527
    Jul 29, 2015
    Liverpool
    Yea, that's the same error I have :/
    I thought about download 11.1.0-34EUR for N3DS through 3DNUS and install it with SysUpdater but I'm not sure if this is safe or if it will kill Luma or A9LH.
    Any Ideas?
     
  7. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Any CFW with FIRM0/1 protection are safe to update to the latest OFW.
     
  8. suzsuzuki

    suzsuzuki GBAtemp Regular

    Member
    273
    110
    Aug 25, 2016
    Brazil
    Change theme and try to update again.
     
  9. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Do you have any custom fonts or homemenus installed? if so delete them
     
  10. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Do you have any custom fonts or homemenus installed? if so delete them
     
  11. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Do you have any custom fonts or homemenus installed? if so delete them
     
  12. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Do you have any custom fonts or homemenus installed? if so delete them
     
  13. xXDungeon_CrawlerXx

    xXDungeon_CrawlerXx GBAtemp Maniac

    Member
    1,195
    527
    Jul 29, 2015
    Liverpool
    I don't
     
  14. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Have you changed the theme at all? (custom theme or official themes)
     
  15. vgplayer54
    OP

    vgplayer54 GBAtemp Regular

    Member
    203
    12
    Feb 4, 2010
    Canada
    I attempted to turn off the themes and tried to update. Unfortunately the error persists. And no I do not have any custom fonts or home menus installed
     
  16. Manurocker95

    Manurocker95 Game Dev & Pokémon Master

    Member
    665
    176
    May 29, 2016
    Spain
    Madrid
    One more time, google is your friend and this question has been answered so many times. Yes, it is safe to update. If your homebrew apps break after updating, just update them to the newest versión of them. If you cannot update by the settings, check with 3dsident your kernel, native firm and firmware. Update Luma to be sure it isn't that the problem.
     
    Xiphiidae likes this.
  17. xXDungeon_CrawlerXx

    xXDungeon_CrawlerXx GBAtemp Maniac

    Member
    1,195
    527
    Jul 29, 2015
    Liverpool
    Well, i disabled my custom theme but now when I try to update, the error persists...

    Can I just update through SysUpdater with the newest update downloaded through 3DNUS or will it break anything?
     
  18. Manurocker95

    Manurocker95 Game Dev & Pokémon Master

    Member
    665
    176
    May 29, 2016
    Spain
    Madrid
    If you have the correct update cias it will be ok.
     
  19. vgplayer54
    OP

    vgplayer54 GBAtemp Regular

    Member
    203
    12
    Feb 4, 2010
    Canada
    I might have to go this route too, I turned off themes, updated Luma3DS and still error... Not sure what 3Dsident is, but if it can help I'll try to learn about it.
     
  20. vgplayer54
    OP

    vgplayer54 GBAtemp Regular

    Member
    203
    12
    Feb 4, 2010
    Canada
    Hey did this work for you? I tried downloading the latest firmware 11.1.0-34 using 3DNUS original as well as the 3DNUS Mod by Dr. Hacknik and both are giving me these results:

    Downloading 0004003000009E02 v1031...
    Title has 0 contents
    Packing as .cia ...
    Done.

    This occurs for a lot of different files, but they all say "Title has 0 contents". Does anyone know either how to fix this, or a different way of gaining the .cia files so I can update my firmware?