Questions About DSi Flashkarts

Discussion in 'NDS - Flashcarts and Accessories' started by Haggar, Sep 15, 2013.

  1. Haggar
    OP

    Haggar Member

    Newcomer
    26
    0
    May 21, 2011
    United States
    I know there's a thread that helps you choose a flashcart but it's a bit outdated and I have a few other questions as well.

    My friend lost her AceKard 2i and I was planning on getting her another one but I was browsing these forums and a few people have mentioned that firware 1.4.5 does not work. The stores I've been browsing use 1.4.4. Does this work?

    The other flashcart I'm considering buying is the R4i 3DS Card but this one comes with version 1.4.5. Can this cart run this firmware? This cart also seems to be able to play 3DS games. My friend is going to buy a 3DS but will also keep her DSi. How does it work when a cart has 2 different types of firmware on it? Will she be able to pop it unto a 3DS and have the system automatically detect the 3DS firmware and then later pop it into her DSi and have that system detect the 1.4.5 firmware?

    Which cart is more stable?

    Thanks.
     
  2. ipwndeveloper

    ipwndeveloper GBAtemp Regular

    Member
    276
    68
    Jun 3, 2013
    United States
    San Fransisco, CA
    DSTwo, PLEASE get a DStwo its practically update proof and has GBA!(although gbaemu4ds works ok on acekard) avoid ALL r4's and Acekards if you are the type to accedently update. I can verify that the last fw for ak2i hw 81 is 1.4.4, and hw 44 is 1.4.3(mainly clones i think).

    SuperCard DSTwo is the best.
     
  3. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,107
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    No it's not. You can see the changelog at the bottom of the post. I've been updating it any time anything interesting happens.

    AK2i stopped updating and doesn't work on the latest DSi or 3DS firmware.

    Yes.

    No, look at the chart. Only the gateway plays 3DS games.

    That's not how it works, just know that it'll work fine in both systems as long as you always keep the cart updated first.

    If you want to know how it works, read up on this.
    http://hackmii.com/2010/02/lawsuit-coming-in-3-2-1/
    Basically when a flash cart has "1.4.5" firmware, it actually means "a bootloader that passes the right data to pass the boot check that was updated with nintendo system software 1.4.5".

    But that's a mouthful, so they just say the version it works with and leave it at that.

    The DSTwo. The ONLY cart to have not needed a new model (read: make you buy a second or third cart to get updates).
     
    ipwndeveloper likes this.
  4. Haggar
    OP

    Haggar Member

    Newcomer
    26
    0
    May 21, 2011
    United States
    Thanks to both of you for the info.

    The DSTwo might cost more than the amount she wants to spend but I'll let her know about this cart.

    Rydian, you're right it's not out of date. I didn't notice the changelog at the bottom. I also misunderstood what 3DS compatibility for the R4 meant. I believe that her DSi's firmware is 1.4.1 and has never been updated so the R4 or AceKard 2.1 should work fine along with the DSTwo. I'll take a closer look at the DSTwo since it's so highly recommended.
     
  5. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,107
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    If it's a DSi (and she does not intend to upgrade to a 3DS later!), we're pretty sure that's stopped getting firmware updates so an R4i Gold for r4ids.cn would be a cheap alternative that would work even if she updated the DSi to the latest (1.4.5 at the moment).