Hacking PSVR Woes on 6.72

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
I'm not sure what happened but I am no longer able to use PSVR. I have a console on 6.72 using Leeful's PS-Phive! exploit that I am hosting on an ESP8266. This console has NEVER been online though I have put in a retail disc with a higher firmware accidentally but selected to not update and ejected the game.

If I turn on the PSVR running Base 6.72 (no HEN) it says "Update the System Software to use Playstation VR" The PSVR software says ver 5.00 in settings so it probably wants my PS4 firmware to match.

If I enable HEN v2.1.3 and turn on the PSVR it says "You must update the Playstation VR device software. In settings the Playstation VR Software says version 255.255. So despite being on 5.00, and spoofed to 255.255 it wants me to "update" it to 4.10....

If I select "update now" and it says "The following version of the Playstation VR device software is available" Version 4.10. I hit next again but it says "Cannot complete the update. Update the system software to use Playstation VR".

If I enable HEN v2.1.3 and turn on the PSVR it says "An error has occurred CE-40170-2"

I am at a loss on what to do. I have used this PSVR processor unit on this offline console back in January and it hasn't been connected to any other PS4 or PS5 since.
 
Last edited by protivakid,

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
24,321
Trophies
1
XP
15,363
Country
United States
I think you can update if you have spoofed or with an updated ps4 or ps5. I don't own a psvr though, so I'm just relaying the info.
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
I think you can update if you have spoofed or with an updated ps4 or ps5. I don't own a psvr though, so I'm just relaying the info.

I edited my original post, the PSVR I believe is on the latest, it just thinks it needs 4.10 for some reason...
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
Use hen 2.1.4 on v10 host.

I updated my PSVR to 5.00 on my PS5 (latest firmware) and it works fine on 6.72 via leefuls host.

I thought Leeful's PS-Phive! was newer than v10 but I can try that tonight if you think it will help. Any idea what might be going on?
 

KiiWii

Editorial Team
Editorial Team
Joined
Nov 17, 2008
Messages
13,298
Trophies
2
Website
defaultdnb.github.io
XP
16,724
Country
United Kingdom
With 2.1.3 it says it spoofs PSVR. When I enable HEN in system settings I see ver 255.255 for PSVR device Software. Wouldn't this mean I'm spoofed properly?
Hmm. I don’t think that’s right.

Usually you can activate the spoof, come out browser, go back in and see what the host says... alternatively go into and out of rest mode and see the system version. Should say 9.00 or whatever.
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
Hmm. I don’t think that’s right.

Usually you can activate the spoof, come out browser, go back in and see what the host says... alternatively go into and out of rest mode and see the system version. Should say 9.00 or whatever.

Yep went back in the menu and it says 9.00 was the firmware detected. I checked the PSVR version in the system menu and it said 5.00. I then Powered it on, still it said it needed to update to 4.10. That failed and in the system menu it now said the PSVR was on 255.255.

Not sure what is going on, but do you think trying v10 will fix this or is there a deeper issue here?
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
You just need a spoof, maybe try send GoldHEN to binloader.

Just sent GoldHen over and confirmed it said Hen 6.72 in my system menu. Still the same issue, powered on the PSVR and it said I needed to update my System Software (I assume the PS4 firmware since it wanted to go online) to use the PSVR. I FTP'd in and deleted everything in the update folder, I've tried update blocker, neither making any difference.
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
Are you turning your VR on first? Try leave it off, run hen, when the pop up notification for hen goes off: turn on your VR.

It's off, the light on the processing unit is white but the headset is off. If I turn it on ahead of time it says that my PS4 needs to update to use the PSVR and powers off immediately. I'm guessing it's because my PSVR is on 5.00 but my PS4 is on 6.72, and for whatever reason Hen is not able to get around this.
 

Leeful

GBAtemp Member
Developer
Joined
Sep 4, 2015
Messages
1,715
Trophies
1
XP
5,275
Country
United Kingdom
It's off, the light on the processing unit is white but the headset is off. If I turn it on ahead of time it says that my PS4 needs to update to use the PSVR and powers off immediately. I'm guessing it's because my PSVR is on 5.00 but my PS4 is on 6.72, and for whatever reason Hen is not able to get around this.
should the light on the processor unit not be red when it is off? try unplugging the power and plug it in again while your PS4 is turned off.
 
  • Like
Reactions: KiiWii

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
should the light on the processor unit not be red when it is off? try unplugging the power and plug it in again while your PS4 is turned off.

As soon as the processor detects an HDMI signal from the ON PS4 the light becomes white, at least on the V2 processor. I even tried unplugging the USB cable from Processor to Console yet that made no difference. Then when you power on the headset you'll get an additional beep and the lights on the headset become blue.
 
  • Like
Reactions: KiiWii and Leeful

Leeful

GBAtemp Member
Developer
Joined
Sep 4, 2015
Messages
1,715
Trophies
1
XP
5,275
Country
United Kingdom
As soon as the processor detects an HDMI signal from the ON PS4 the light becomes white, at least on the V2 processor. I even tried unplugging the USB cable from Processor to Console yet that made no difference. Then when you power on the headset you'll get an additional beep and the lights on the headset become blue.
yes it's the same on my PSVRv2. Sorry I got confused. LOL its only red when the PS4 is tured off.
 
  • Like
Reactions: KiiWii

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
yes it's the same on my PSVRv2. Sorry I got confused. LOL its only red when the PS4 is tured off.

I'm at a loss as to what to do here... I might back up my PS4, wipe it, and restore my apps / saves after. I feel like one of those discs that contained FW above 6.72, despite saying NO, still messed with the console.

Otherwise I'm stuck in a recursive loop. PS4 says I need to update past 6.72 to use my 5.00 PSVR. When HEN is enabled my PS4 says the PSVR needs to be updated to 4.10 but because it's already on 5.00 that update fails. Not sure what else I can try
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
Well I just threw a spare blank HDD into my PS4 and restored it to factory defaults using a 6.72 full update file. Still having the same exact issue. While I am happy it means it's nothing I did to the console like accidentally downloading an update or something, I'm even more confused how this was working fine in January via PS-Phive! / HEN 2.1.3 and now no longer works.

As soon as I power on the PSVR with Hen enabled it wants to install the 4.10 update... to a PSVR already on 5.00 which fails.
 

protivakid

Well-Known Member
OP
Member
Joined
May 6, 2014
Messages
170
Trophies
0
Age
36
XP
429
Country
United States
General chit-chat
Help Users
  • No one is chatting at the moment.
    KennieDaMeanie @ KennieDaMeanie: Well I bought the 20th anniversary Xbox controller should be here tomorrow