PS Vita 1000 PS Home/Power botton not working correctly

Discussion in 'PS Vita - Console, Accessories and Hardware' started by toze3, Jan 18, 2019.

  1. toze3
    OP

    toze3 Newbie

    Newcomer
    2
    Jan 17, 2019
    Portugal
    Hi there,

    I got a used Vita that works ok until I get in a app/game.

    When I enter a app/game, I can't exit with PS HOME botton, so my only way to exit is to press the power botton for around 20-30 seconds and they I enter in safe mode.

    Already tried all option without sucess.

    When it's on sleep mode i can turn on by pressing the home botton, but after that the home botton doesn't work anymore.

    Also opened and clean all bottons ( the flex of power and L+R triggers to remove the glue) , even tested without L & R triggers and same problem.

    What could be the problem? What more tests can I do to check the cause?

    Best regards
     
  2. kaymynd

    kaymynd GBAtemp Advanced Fan

    Member
    4
    Sep 19, 2018
    United States
    Same issue started happening on my 2k vita a few weeks ago, except for me the power, home and x buttons aren't working. After testing out various things I managed to get it working after cleaning the power ribbon flex cable with alcohol, after a few days though the issue came back. I've deduced that i have a faulty battery and power flex cable. I ordered and recieved new battery and power flex cable but have yet to replace them. I'll try to make some time to do so after work today and post my results. Hopefully replacing the faulty items fixes the issue, If it doesn't work, it will most likely be a problem on the motherboard and it will need to be replaced.
     
  3. toze3
    OP

    toze3 Newbie

    Newcomer
    2
    Jan 17, 2019
    Portugal
    Thanks,
    Please update me with your workout solution.
    I will order a power button to check if I also get things working

    Enviado do meu Mi A1 através do Tapatalk
     
  4. kaymynd

    kaymynd GBAtemp Advanced Fan

    Member
    4
    Sep 19, 2018
    United States
    Ok so after replacing both battery and power flex cable the issue is still there, removing and replugging in the battery will sometimes turn on the vita automatically, almost like the power button is stuck pushing down. I'm beginning to think the issue lies in the motherboard unfortunately, I'm going to try to find a cheap replacement motherboard to see if that works next. I will update with the results when i replace the mobo.
     
  5. toze3
    OP

    toze3 Newbie

    Newcomer
    2
    Jan 17, 2019
    Portugal
    I repeat the tests, but now also without the power flex cable(and L and R triggers off the console) the same problem...

    I can turn on from sleep mode with home button, but inside a app/game I can't exit with home button.

    So believe it's not a problem in the triggers or power button. Maybe some of the bottom side PCB, possible the home left side PCB. Will try to replace and hopping not be a problem of the main board...

    Enviado do meu Mi A1 através do Tapatalk
     
  6. kaymynd

    kaymynd GBAtemp Advanced Fan

    Member
    4
    Sep 19, 2018
    United States
    I see, it's been a hit or miss for me sometimes it works with no problem for a few days then it will act up again and home amd power buttons won't work. I tried turning it on today to try out the downgrade but no luck i usually just leave it battery unplugged for a day or 2 and when i come back to test it, it just works, not sure what it means but sounds to me like there might be a short somewhere on the motherboard that may be causing this. Still waiting to find a new mobo at a decent price. I look forward to your updates hope swapping the pcbs works!
     
  7. toze3
    OP

    toze3 Newbie

    Newcomer
    2
    Jan 17, 2019
    Portugal
    Só finally had time to do more tests.

    First tried again without the joysticks attached and same results.

    Than tried to change the flex cables

    Changed the left PCB where is the home bottom, and nothing...

    And finally changed the right PCB and voilà, found the problem.

    Also checked that the right joystick is faulty, with a fixed ghost movement, but that doesn't mess with applications and can run. Now have to check how to disassemble the joystick to try a repair.

    Any tips to do it??


    Enviado do meu Mi A1 através do Tapatalk
     
  8. kaymynd

    kaymynd GBAtemp Advanced Fan

    Member
    4
    Sep 19, 2018
    United States
    Before you disassemble it try using some dust cleaner spray and see if that helps,

    I've bought replacement analog sticks in the past but i didn't like the way they looked compared to the original ones, so i recommend if you do look to get replacements, get them from a broken vita or someone selling the original vita ones.
     
Loading...