Problem with GBA backlight mod.

Discussion in 'GBA - Hardware, Devices and Utilities' started by montiebro, Oct 12, 2016.

  1. montiebro
    OP

    montiebro Member

    Newcomer
    13
    0
    Mar 30, 2016
    United States
    I've made 4 of these so far and the last two didn't work. The red one starts to get horizontal lines at the bottom of the screen after a minute of being on then just gets worse and picture inverts or goes all white or top half on bottom and bottom half on top, making it unplayable. This one seems to react with pressure exerted on or around the screen. Turning this one off and right back on makes the lines go away but only for a minute so I don't think it's a heating thing. It's 40 pin with white ribbon.
     

    Attached Files:

  2. slaphappygamer

    slaphappygamer GBAtemp Advanced Fan

    Member
    960
    129
    Nov 30, 2008
    United States
    California
    Have you tried cleaning the contacts at the end of the ribbon cable?
     
  3. montiebro
    OP

    montiebro Member

    Newcomer
    13
    0
    Mar 30, 2016
    United States
    I cleaned one of the contacts I'll try cleaning both.
     
  4. montiebro
    OP

    montiebro Member

    Newcomer
    13
    0
    Mar 30, 2016
    United States
    You know that rubber sticker stuff on the edge of the screen? I took that out and did some sanding on the battery compartment and now it works!
     
  5. slaphappygamer

    slaphappygamer GBAtemp Advanced Fan

    Member
    960
    129
    Nov 30, 2008
    United States
    California
    Oh man, yes. That foam around the front screen needs to go. I also did some sanding there too. Seems like your screen was taking on too much pressure. Glad to hear it works now.
     
  6. koffieleut

    koffieleut GBAtemp Fan

    Member
    341
    38
    Jan 22, 2009
    Netherlands
    probably at home
    You could have a faulty cable. Had the same issue back in the day. That One guy sended me a new cable and the problem was solved.