Problem with Edge & 8GB micro sdhc card

Discussion in 'EDGE' started by berty123, Mar 26, 2009.

Mar 26, 2009
  1. berty123
    OP

    Newcomer berty123 Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United Kingdom
    I've got an Edge card and a Sandisk 8GB micro sdhc.

    I've recently come across a problem when filling up more than half of the sd card (ie. using more than about 4GB).

    Let's say I've used up 3.9 GB of the card and I then put another title on it that takes it over 4GB.
    When I switch the DS on, the new title will not show up in the menu.

    If I then delete an older title (taking the contents of the card back down below 4GB) the new title will now show up in the menu and can be loaded.

    So basically, it seems that, though I can fill the card to it's 8GB capacity if I want, the Edge/DS will only read the first 4GB that was put on it.

    Anyone else come across a problem like this or have any idea why this might be happening ?

    Cheers.
     
  2. W.I.C.K.E.D.

    Member W.I.C.K.E.D. GBAtemp Regular

    Joined:
    Feb 12, 2009
    Messages:
    210
    Country:
    United States
    first question I'd like to ask is have you ever filled the 8gb card completely? There are fakes out there and it might not be a true 8gb card. I say this because I have 4 sandisk 8gb cards and I've filled each one to capacity and they work fine. Have you backed up your files and tried to reformat it? The card itself might be corrupt. I'll check back to see if you get any results. Good luck

    p.s. There are programs to test the quality(read and writes speeds, and the actual capacity of sd and micro sd cards). Here's a link.
    http://www.heise.de/ct/Redaktion/bo/downlo...h2testw_1.4.zip
    Just...
    1. download it and unzip file
    2. put sd or micro sd card in usb reader and place in usb drive
    3. execute the h2testw file
    3. select the english language
    4. go to select target
    5. select your removable drive
    6. click all available space (unless you only wanna check speeds then pick the "only" box and enter how much to test)
    7. click write and verify (it will then write text data to card and verify it following)
    8. when done, the program will give you the write and read speed, the actual size of card and tell you any problems
    9. delete the files it created off of the sd card and you're on your way

    for best results, I recommend you backup any files from your sd card and reformat the card prior to testing to receive the best speeds and results. If you have any question there is a readme file in the download that should be of help. Once again, good luck [​IMG]
     
  3. Ahua_Keren

    Newcomer Ahua_Keren Member

    Joined:
    Jul 20, 2008
    Messages:
    38
    Country:
    Indonesia
    Hmmm... maybe your 8GB is a fake one, just do your test with drwir's recommendation software.
     
  4. jenngcia

    Member jenngcia GBAtemp Regular

    Joined:
    Apr 14, 2007
    Messages:
    139
    Country:
    Singapore
    I reckon it's too many titles in one folder. I had the same problem on a 4GB SDHC Card. Since most of my homebrews are of the 'brain' variety they are small, and when I put another it just didn't shows up.

    Create another folder and move some of the new homebrews in it. That should solve your problem.
     
  5. kahsajara

    Newcomer kahsajara Member

    Joined:
    Dec 26, 2008
    Messages:
    48
    Country:
    Australia
    I have the exact same problem as the thread starter. And now my 8 gig SD has corrupted into a cheap 3.9 gig one. Ive tryed to reformat it and still it only says theres 3.9 gb of space on it.

    Edit: Just reformatted my card again using a different card reader. i now have my 8 gig back. woot now to see if it will read all the games i put on over 3.9
     
  6. berty123
    OP

    Newcomer berty123 Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United Kingdom
    Hello !

    Apologies for delay replying to this thread (that I started), but I've been having computer problems over the past week or so (finally back to normal today).

    Thanks for the replies.

    drwrir : In answer to your 1st question, no, I'd never previously filled the card up to capacity.
    I've had it a couple of months and have been gradually filling it up. It was only once it recently passed the 4GB mark that I noticed the problem.
    I downloaded the program you suggested (thanks for the link) and ran my card through it (after formatting it first).
    It all came up fine showing that it was a genuine 8GB card with no errors.
    Tried putting all my files back on it again, and hey presto!, the same problem occured.
    I purposely copied around 4.5GB of files to it in alphabetical order and when I checked them on my DS, several of the files starting with "W" were missing, as were all the files starting with X, Y and Z.
    That just confirmed that the Edge card is ignoring all further files once the 4GB mark has been reached.

    jenngcia : I do have everything in one folder so will try splitting them across 2 or more tomorrow and see if that helps.

    kahsajara : That's interesting (especially if jenngcia's solution doesn't work). What card reader did you use ?
    I only have the one that came with my Edge card.
    My mother has an R4 on her DS so I could borrow the reader that came with that next time I see her (but since the R4 doesn't accept sdhc cards will it be able to format my card ?)
     
  7. berty123
    OP

    Newcomer berty123 Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United Kingdom
    Whoops ! Double-post.....
     
  8. berty123
    OP

    Newcomer berty123 Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United Kingdom
    jenngcia : Tried putting some stuff in a new folder, and it's working fine now.

    I guess the Edge card doesn't like too many files to be in the same folder (or on the root of the sd card, as was the case for me).


    Cheers !
     

Share This Page