RELEASE pPlay: switch video player

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by cpasjuste, Dec 14, 2018.

  1. Grand-Master

    Grand-Master Advanced Member

    Newcomer
    2
    Oct 1, 2018
    United States
    God bless you!
    Hmm... well dont hesitate, sooner or later there will be a solution, the author of the program is making his best effort and replied to me whats the issue, he may fixed it soon!
     
  2. zdotx00

    zdotx00 Member

    Newcomer
    2
    Mar 11, 2018
    New Zealand
    You're probably better off with a default Apache install than with xampp, though you could try deleting the index.html file and see if it gives you a directory listing when you browse to the server.
    https://httpd.apache.org/docs/trunk/urlmapping.html - useful info, ensure that mod_autoindex is turned on, delete index files & place videos in your root web directory.
     
  3. cirojr82

    cirojr82 Member

    Newcomer
    1
    Apr 12, 2017
    Brazil
    So, actually I use LINUX, I don't know but probably you use Windows?!

    But it waa pretty straightforward. To test, I just installed appache, deleted the html file the comes in the first install and created a .htaccess file in the same folder, including the information Options +Indexes (this allow directory listing) . Then, I put the videos in this folder and it's done.

    I don't remember everything that I did, it took some time but I got it working.

    After the test, I moved to my raspberry server, installed Xamp or Lamp (I don't recall which one). The trick part this time, was to changen the default directory to point it to my Downloads folder. After I manage it, everything worked as a charm. I was just watching the old Zelda cartoon hosted in my local server. The only drawback is theat still takes a good time to load the videos when you hit to play it..it seems that freeze, but actually is loading...you just have to wait.
     
    Billy Acuña and cpasjuste like this.
  4. BlackTSQ

    BlackTSQ Member

    Newcomer
    2
    Oct 9, 2018
    Austria
    Would it be possible to add support for playlists (.pls) files? In my case the .pls files would have a bunch of URLs inside.
     
    Last edited by BlackTSQ, Jan 8, 2019
  5. ChunkyRabbit

    ChunkyRabbit Newbie

    Newcomer
    1
    Jan 8, 2019
    Bangladesh
    Amazing app. I love it man. Would it be possible to make it full touch based though? Because that way I could just leave the joycons at home and enjoy some kino films and tv shows on the go.
     
  6. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Yep, this was almost ready for release, but didn't had the time to polish it. It will be finalized in the future.
     
  7. cirojr82

    cirojr82 Member

    Newcomer
    1
    Apr 12, 2017
    Brazil
    Cpasjuste,

    Quick doubt: still talking about the network feature, is it possible to access two local sites at same time?

    I mean, to inform two IPs in pplay cfg file. Like 192.***.*.**1 and 192.***. *.**2?

    I have two raspberries, so it's like two different IPs to access which one.
     
    Last edited by cirojr82, Jan 8, 2019
  8. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Unfortunately no, but this is again on my (big) to do list :/
    If you want to be sure I don't forget about it you can open a github issue for that!
     
    Cybernatus likes this.
  9. TenkoIntoOrochi

    TenkoIntoOrochi Newbie

    Newcomer
    1
    Jan 9, 2019
    United States
    I've been using this app quite a bit and really love it so far. But one thing that I was wondering was if there were any plans to add more rewind/fast-forward scrubbing options? Sometimes I just want to rewind/fast-forward a video like 5-10 seconds and the shortest jump that I can make currently always pushes the video forward or back about 1 minute.
     
  10. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Hi, i just released pPlay version 1.3: https://gbatemp.net/download/pplay.35351/ or https://github.com/Cpasjuste/pplay/releases/tag/v1.3

    • improve audio decoding (fix some audio desynchronization, most 720p media seems to works fine even with medium buffering, this also fix some audio seeking problem in some media)
    • add status bar (time and battery)
    • add crappy "pPlay" title image
    • fix some random crashes when scanning media folder
    Unfortunately, i didn't had the time to add all your requests as my time is currently limited, but the work will continue :)
     
    Last edited by cpasjuste, Jan 9, 2019
    Ninn, JJTapia19, Azel and 14 others like this.
  11. ReikaRin

    ReikaRin Advanced Member

    Newcomer
    2
    Mar 21, 2018
    Indonesia
    i got some issue with some 720p mkv video, audio is off after 10-12 seconds playing.
    video h264@750kbps
    audio aac@0kbps
     
  12. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Yep, I guess this one "should" not be too demanding. May I ask you your buffer and cpu settings in pPlay? Also it seems ffmpeg can't determine the audio bitrate which may be strange. If possible, could you PM me a sample?
     
  13. ReikaRin

    ReikaRin Advanced Member

    Newcomer
    2
    Mar 21, 2018
    Indonesia
    cpu boost set to enabled, buffer on medium. Will pm you the sample later
     
  14. Elalexyzoner

    Elalexyzoner Member

    Newcomer
    1
    Jun 5, 2016
    Mexico
    Thanks for your hard work, how can i help you a little bit? i don't have PayPal, can i donate with an Oxxo deposit?
     
    cirojr82 likes this.
  15. Dan-the-Rebirth

    Dan-the-Rebirth GBAtemp Fan

    Member
    5
    Jan 5, 2014
    Australia
    so i tryed 2 videos one sd mp4 with 2 audiostreams, it palyed fine for 15min than it freezes, i can still fastforward, but it never continues the playback, always it jusat shows a frozen frame no audio.

    the second was an 1080p mkv with 3 audiostreams and it palyed in slowmotion
     
  16. CampofMusic

    CampofMusic Member

    Newcomer
    2
    Jun 7, 2018
    Israel
    i tried 1 video but for some reason i can choose subtitle..
    how can i use an SRT. SUB. IDX. ????
     
  17. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    You can't, currently. As stated in the readme it only supported embedded subtitles in ass format.
     
  18. AllisonAI

    AllisonAI Newbie

    Newcomer
    1
    Jan 10, 2019
    United States
    So I tried to set up a media server using Apache on my windows machine, and I can browse through the browser and other devices' browser just fine, but when trying to connect to the network on the switch, I get "OOPS timeout was reached" (almost instantly too)
    Unsure why this would happen nor how to fix. It wouldn't happen to be something with 90dns, would it?

    Edit: Removed forward slash after IP and it worked!

    Edit2: Movies will randomly close after a while of watching
     
    Last edited by AllisonAI, Jan 10, 2019
  19. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Hi @AllisonAI , do you know if the problem of randomly closing movies happen from sdcard too?
     
  20. sunnybwoy

    sunnybwoy Newbie

    Newcomer
    1
    Feb 4, 2017
    United States
    running perfect no cpu boost. mp4,h264@9k 720p with no issues.
     
Loading...