RELEASE pPlay: switch video player

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by cpasjuste, Dec 14, 2018.

  1. Grand-Master

    Grand-Master Advanced Member

    Newcomer
    1
    Oct 1, 2018
    United States
    God bless you!
    Thanks! for the reply! Good work and outstanding! for the beginning!
     
  2. Zumoly

    Zumoly GBATemp Analyst

    Member
    6
    Apr 27, 2018
    Mali
    Yorosso
    Sounds like a plan.
    Actually I was referring to that one: https://gbatemp.net/threads/homebrew-menu-loader-legal-nsp.518433/
     
  3. OvOvOv

    OvOvOv Member

    Newcomer
    1
    Oct 7, 2018
    Spain
    How can unleash all switch memory from albums sx os to use it?
     
  4. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    If you're using atmosphere you can set the titleid (a game or demo) that HBL will use in a config file (not sure where anymore but I'm sure someone will help us).
     
  5. NANASHI89

    NANASHI89 GBAtemp Advanced Maniac

    Member
    9
    May 3, 2012
    United States
    Music files with album art don't seem to wanna start. Stuck at 0:00
     
  6. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Did you get more luck with "no album art" musics? Else, a better music support is planned. You can also add a github issue if you can for that!
     
  7. tyler004

    tyler004 GBAtemp Regular

    Member
    3
    Jun 6, 2018
    Canada
    with sx os u can hold R when launching any game and it makes it the hbmenu with full ram access
     
    Csmrcc and cpasjuste like this.
  8. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Thanks, didn't remember about this, but this is what I was looking for.. I'll update the readme as soon as possible.
     
  9. OvOvOv

    OvOvOv Member

    Newcomer
    1
    Oct 7, 2018
    Spain
    Hold R when lauching the pplay?
     
  10. zdotx00

    zdotx00 Member

    Newcomer
    2
    Mar 11, 2018
    New Zealand
    No, launch a normal game from the standard OS' home menu while holding R

    That will launch hbmenu instead of the game, and will have full access to ram.
     
    OvOvOv likes this.
  11. cirojr82

    cirojr82 Member

    Newcomer
    1
    Apr 12, 2017
    Brazil
    Anyone here manage to get the web sever working on Pplay?

    I need some assistance to setup one server here. Does PLEX do the trick?

    The app is awesome but transfer videos to the card everytime you want to watch something is sometimes painful.
     
    Last edited by cirojr82, Jan 6, 2019
    Billy Acuña likes this.
  12. zdotx00

    zdotx00 Member

    Newcomer
    2
    Mar 11, 2018
    New Zealand
    I had a lot of trouble, I think part of the problem was that the videos themselves weren't compatible - I gave up for the time being waiting for both more performance and better compatibility, for some reason anything I tried to run from SD would run at about 5fps and buffer for 30s every 10s of video (yes, I read the readme, they were all 720p videos and I tried messing with all the settings). Anyway what you need is a web server which can post an open directory listing, in a very default state - so no making it look good. Most web servers can do this, just config can be a pain in the ass.

    Apache can do it.
     
  13. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Hi @zdotx00. I think this is the first report of a problem like this (5fps, buffering every 30s etc..). Could you provide more information? Like your switch firmware, how do you launch pPlay, but also the video/audio bitrate/codecs etc? Maybe you could send me a sample of a media causing this problem?
     
  14. zdotx00

    zdotx00 Member

    Newcomer
    2
    Mar 11, 2018
    New Zealand
    Oh, really? I had thought it was just a case of expected issues with early releases. I'll take another look over the next couple of days and get back to you with specifics. For vague general answers: pPlay was launched within SXOS both by the normal sx route of album > homebrew and also via holding R on a system title. I recently upgraded from 5.10 to 6.1.0 and think it was done post-upgrade. The media was anime, so probably had that weird 10bit colour thing going, I'll let you know the bitrate & codecs when I get a chance to check it out again.
     
  15. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    10 bit could be the (is probably) the problem yes, it's really hard to decode via software on the switch. I had some luck with some 10 bits hevc 720p medias thought.
     
  16. cirojr82

    cirojr82 Member

    Newcomer
    1
    Apr 12, 2017
    Brazil
    Yes Apache did the trick. I installed in my notebook, just for test, an Apache web server for local access purposes. I changed the pplay config file and voilá. It worked, I just tried with two mkv's, but it worked.

    It takes some time to scan the file and start playing the video...but hey, this is just 1.2 version. ;)
     
    Last edited by cirojr82, Jan 7, 2019
  17. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    11
    Aug 27, 2015
    France
    Cool :)
    Keep in mind that http streaming is still WIP, so you'll probably have a few bugs (like slow buffering).
     
    cirojr82 likes this.
  18. cirojr82

    cirojr82 Member

    Newcomer
    1
    Apr 12, 2017
    Brazil
    Yes, I had slow buffering, but as you said it's just the begining. Congratulations anyway for this piece of work. Fantastic job.
     
  19. Billy Acuña

    Billy Acuña GBAtemp Addict

    Member
    10
    Oct 10, 2015
    Mexico
    Can you tell me how did you managed it to work? Perhaps your apache config file?
    I'm trying with xampp btw.
     
  20. bodyXY

    bodyXY GBAtemp Regular

    Member
    5
    May 15, 2018
    Germany
    Im still on 5.1 :/
     
Loading...