Question please help!!! sd card bootloader problems on switch

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by jennice, Nov 1, 2018.

  1. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    i used h2testw but tbh i dunno what im looking for with that application
     
  2. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    19
    Aug 6, 2017
    United States
    New York City
    If it finished without any errors, the SD card is real. If the SD card is real, it might be worth speaking to a developer who works very closely with the Switch such as CTCaer.
     
  3. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    ok well there was no errors so is it because its only a 32gb? its not big enough?

    — Posts automatically merged - Please don't double post! —

    or maybe because its updated?
     
  4. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    19
    Aug 6, 2017
    United States
    New York City
    Nah, any SD card larger than 4 GB should work with CFW. There was someone who had a similar-esque issue in this thread. They used a weird trick to get it to work before sending it to Nintendo for repair. Maybe you could try this trick and see if it works for you.
     
    comput3rus3r likes this.
  5. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    your problem lies within this thread. Has nothing to do with what you're doing and all to do with your switches sd card reader.

    https://gbatemp.net/threads/how-to-fix-sx-os-boot-dat-error.510109/

    — Posts automatically merged - Please don't double post! —

    lol you actually posted my thread minutes before I did.
    I didn't actually use any trick to get it to work. What happened was that one of the symptoms my switch had was that if i pressed on the kickstand the system would detect the sd card as being removed. So it was an actual defect. However if yours doesn't have this problem I doubt you can send it to nintendo saying your switch won't load custom paylods. What you might have to do is make sure your sd card reader is seated properly by opening it up and re-connecting it.
     
    Last edited by comput3rus3r, Nov 2, 2018
    Draxzelex likes this.
  6. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    so the seating would make a difference on ofw and cfw? it works on ofw
     
  7. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    yeah, the only issue i was having is that it wouln't load sx-os. I would get boot.dat? error. or if using hekate it would fail to initialize sd card. But otherwise ofw will detect sd card normally. Of course I also had the weird problem that if I pressed on the back of the switch kickstand it would eject the sd card.
     
  8. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    ok well i open it up later today (its past 12 now) and make sure no connectors are lose and try with a 64gb sd card and report back. i might have to buy a new sd card reader and get my soldering iron out!
     
  9. paulzheng

    paulzheng GBAtemp Regular

    Member
    3
    Dec 10, 2013
    China
    format microsd card into exfat/32kb by desktop.
    extract and copy sdfiles v10.1.1 files on it . use hekate4.2 inject into your switch, then it works
     
  10. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    tried still doesn't work
     
  11. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    there's only 1 solution to your problem fixing the sd card reader issue. either re-connect sd reader or replace it. My thread has multiple people that solved their issue that way.
     
  12. itsme2

    itsme2 Newbie

    Newcomer
    4
    Jun 10, 2018
    Israel
    did u format the sd from the switch system os?
     
  13. Zumoly

    Zumoly GBATemp Analyst

    Member
    8
    Apr 27, 2018
    Mali
    Yorosso
    Hi OP
    Sorry to see you're having the same issue I experienced a few days ago.
    I asked CTCaer for help and my issue got fixed.
    You could try and see if it solves yours: https://gbatemp.net/threads/rcm-payload-hekate-ctcaer-mod.502604/page-115#post-8357555

    ------------------------

    This should be stickied so that people having this issue can easily find help. I was at my wits' end when it happened to me.
     
  14. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    Yes I did
     
  15. jennice
    OP

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    i resolved the issue....it was the sd card.i bought a 64gb and its working a charm
    :grog::toot::gun:
     
    a9lh-1user likes this.
  16. a9lh-1user

    a9lh-1user Newbie

    Glad you solved it :hrth:
     
Quick Reply
Draft saved Draft deleted
Loading...