1. Xplic1T

    OP Xplic1T GBAtemp Regular
    Member

    Joined:
    May 26, 2006
    Messages:
    252
    Country:
    Get the update now if you havent yet before Nintendo updates their latest fw to 2.4. Pega may be blocked if they figure it out.

    https://hackinformer.com/2017/06/10/pegaswitch-updated-2-3-switch-news/

    !!!! Update to 3.0 At Your Own Risk - Stay On 2.3 If You Can Help It !!!!

    [​IMG]

    [​IMG]
    PSA - This Does Not Mean They Have A Jailbreak!

    PegaSwitch is a Javascript Toolkit that lets users poke around in ram and execute certain commands outside of normal user space. Team ReSwitched ported a web-kit (internet browser component) vulnerability that has been discovered to jailbreak IOS 9.3.5 on the iPhone. They ported that implementation and had it working on the Switch's 2.0 web browser, but Nintendo then quickly patched the vulnerability in 2.1 and many of us have been not able to use it. As of 6/9/2017, team ReSwitched announced they had a new implementation of the vulnerability that works on 2.3 in addition to 2.0, 2.1, 2.2. This post was made in order to aid in getting people on to 2.3 while it is still active as the latest firmware version for the Switch. We don't know if they will patch this in 2.4 or 2.5 or 4.x but at-least you will be ready and still have the option to download from the store or play online for the time being.

    Team ReSwitched is keeping the new method private for now and will most likely release when Nintendo themselves have patched it.

    fw 1.0 Definitely Update to Current FW 2.3

    fw 2.0 Stay - Old/Current PegaSwitch Compatable

    fw 2.1 Your Choice - Exploit Will Still Work

    fw 2.2 Your Choice - Exploit Will Still Work

    fw 2.3 Stay - 3.0 Works But They May Have Changed Internals

    fw 3.0 Pegasus Works But Update 3.0 fixes a known vulnerability in the NS sysmodule (originally found by @qlutoo in April)
     
    Last edited by Xplic1T, Jun 20, 2017
  2. sks316

    sks316 (Future) VTuber - Princess Lillie of the Stars
    Member

    Joined:
    Nov 28, 2013
    Messages:
    2,870
    Country:
    United States
    Wow, that's a change. We went from "DON'T UPDATE!" to "Update now!"
     
    NoNAND, SoyAlexPop, ogioto and 10 others like this.
  3. hexcode99

    hexcode99 Advanced Member
    Newcomer

    Joined:
    Nov 17, 2013
    Messages:
    94
    Country:
    United States
    My Switch is on 2.0 firmware. We should definitely update you are saying or will "Pegaswitch" work on lower firmware too?
     
  4. Xplic1T

    OP Xplic1T GBAtemp Regular
    Member

    Joined:
    May 26, 2006
    Messages:
    252
    Country:
    They mentioned 2.3 specifically in the tweet ... I'm on 1.0 so I HAVE TO but if you can't get PegaSwtich running currently ... I would update. That means 1.0 and 2.2 should definitely do it. If you're on 2.0 you should be ok to just coast until the next major announcement. If the devs are working on that fw version, I would just stick to that. Next to nobody has it on 2.0 still.

    2.3 should be safe for the big exploit
     
    Last edited by Xplic1T, Jun 11, 2017
  5. hexcode99

    hexcode99 Advanced Member
    Newcomer

    Joined:
    Nov 17, 2013
    Messages:
    94
    Country:
    United States
    You forgot 2.0 in your OP? But you think 2.0 would be okay too as it also has the webkit. He should make clear what firmware work and don't work.
     
  6. adrifcastr

    adrifcastr GBAtemp Addict
    Member

    Joined:
    Sep 12, 2016
    Messages:
    2,038
    Country:
    Germany
    Whatever "Hackinformers" is, they are late, Daeken alraeady announced this 2 days ago in the reswitched discord:
     
  7. EpicLPer

    EpicLPer Nice unless you give me a reason to hate you ;)
    Member

    Joined:
    Mar 13, 2015
    Messages:
    1,056
    Country:
    Austria
    So I'm still on 2.0, I'll definitely stay on that one for now :D
     
  8. spotanjo3

    spotanjo3 GBAtemp Legend
    Member

    Joined:
    Nov 6, 2002
    Messages:
    10,600
    Country:
    Portugal
    If 3rd party fully supporting and we will be getting one this fall. Then we will stay with FW 2.0 anyway.
     
  9. Xyphoseos

    Xyphoseos Hack or no games
    Member

    Joined:
    Jun 29, 2016
    Messages:
    1,766
    Country:
    France
    Just for be sure, its good to be in 2.3 ?
     
  10. adrifcastr

    adrifcastr GBAtemp Addict
    Member

    Joined:
    Sep 12, 2016
    Messages:
    2,038
    Country:
    Germany
    And here are some Discord logs:
     
  11. BlastedGuy9905

    BlastedGuy9905 where's the updated autopsy report
    Member

    Joined:
    Apr 13, 2017
    Messages:
    2,323
    Country:
    United States
    THIS IS AWESOME!
     
    Last edited by BlastedGuy9905, Jun 11, 2017 - Reason: Some people like complaining about how I write, so I changed "dis" to "this".
  12. adrifcastr

    adrifcastr GBAtemp Addict
    Member

    Joined:
    Sep 12, 2016
    Messages:
    2,038
    Country:
    Germany
    my gosh nt u again, well the more awesome thong is that this exploit is a 100% "homebrew entrypoint" since like he said in the annnouncement it seems to give arbitrary code exec.
     
  13. BlastedGuy9905

    BlastedGuy9905 where's the updated autopsy report
    Member

    Joined:
    Apr 13, 2017
    Messages:
    2,323
    Country:
    United States
    ... *sigh*
    What's your problem with me again? I stopped posting stuff in the wrong sections. Now, if you excuse me, I wanna go on and live my life.
     
    Blake5100 likes this.
  14. Xplic1T

    OP Xplic1T GBAtemp Regular
    Member

    Joined:
    May 26, 2006
    Messages:
    252
    Country:
    Hence the urgency
     
  15. Jayro

    Jayro MediCat Dev and Gameboy Modder
    Developer

    Joined:
    Jul 23, 2012
    Messages:
    9,403
    Country:
    United States
    I'm on 2.0 still, and refusing to update unless it breaks Splatoon.
     
  16. Xplic1T

    OP Xplic1T GBAtemp Regular
    Member

    Joined:
    May 26, 2006
    Messages:
    252
    Country:
    For sure, stay on 2.0 as it currently works with Pegaswitch... but for others out there that maybe on 1.0(like myself) ... it may be the last hope to being on a f/w that will work with Pegaswitch. Others on 2.1 and 2.2 can choose to go to 2.3 to load up on some demos, download games from the store and play friends online in Mario Kart etc.
     
    Last edited by Xplic1T, Jun 11, 2017
  17. Jayro

    Jayro MediCat Dev and Gameboy Modder
    Developer

    Joined:
    Jul 23, 2012
    Messages:
    9,403
    Country:
    United States
    I just feel caught between a rock and a hardplace... 2.0 is better NOW, but Ninty might release 2.4 before Splatoon 2, and block PegaSwitch... :unsure:
     
  18. peteruk

    peteruk GBAtemp Addict
    Member

    Joined:
    Jun 26, 2015
    Messages:
    2,678
    Country:
    United Kingdom
    In the same boat here, not sure if to stick or twist
     
  19. Xplic1T

    OP Xplic1T GBAtemp Regular
    Member

    Joined:
    May 26, 2006
    Messages:
    252
    Country:
    Cat and mouse game at this point. Splatoon most likely will work with 2.1+ (I'm sure they wont make it compatible with 2.0 since they quickly platched 2.0 to 2.1). If Splatoon is more important to you that what you can do right now with your switch on 2.0 (which isn't a whole lot) ... I'd update it.
     
    Last edited by Xplic1T, Jun 11, 2017
    peteruk likes this.
  20. urherenow

    urherenow GBAtemp Psycho!
    Member

    Joined:
    Mar 8, 2009
    Messages:
    3,875
    Country:
    United States
    Well, shoot. I can't possibly have an internet connection on my switch for at least 3 weeks. But... oh, looks like I'm on 2.2 already. Internet settings deleted just in case 2.4 is out before I get to some free wifi.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Pegaswitch, Everyone, Should