Firmware Atmosphère 0.8.8 released, now compatible with firmware 8.0.0

Discussion in 'GBAtemp & Scene News' started by RattletraPM, Apr 20, 2019.

  1. Clockdryve

    Clockdryve Advanced Member

    Newcomer
    2
    Mar 10, 2019
    United States

    What I mean is....if updating my Atmosphere files from 0.8.4 to higher version = It will not effect anything homebrew or NSP game play after the payload update (old stuff on card still work)? And IF I update to firmware (cfw) Switch OS 8.0 "new" = will this cause my previous nsp games (currently cfw 6.2.0) to not play now while on v8.0 switch? *Version 4.2.0 "mentioned above" was just the old original firmware of my switch - before I updated with ChoiDujourNX with the AutoRCM. "above mention" SD card is fine - just putting it out there that I am using ExFat on a 256gb card - in case the exfat might be another issue. noobie input - totally ;-) *I've read something about "keys" and updates causing some changes....maybe it's tools that must be upgraded/made, I don't know. I thought it caused some awful crap that boogered up our running of nsp backups from earlier firmwares. So -- Updating my Payloader "same" to same "higher version" will cause no ill effects (understand some homebrew might 'break" occasionally) ....... roms and homebrew normally not affected - Updating Nintendo OS "base" when CFW "approved" causes no issues with my NSP backups (keys are always the same) *I do understand that sometimes some homebrew can be occasionally broken in early updates (normally later fixed).

    *store keys along with nand backup in multiple SAFE storage places?? All is good?


    I am a 56 year old truck driver - Just capable enough on PC to "hurt myself".....

    Only playing around with Switch for around 3 weeks and waiting half that time for "tools".
    Just put CFW on my old 3Ds a few days ago. It's been laying around (out in truck) for years (few hours to find info and install cfw on it = cool) CIA's are DS files/

    Have had CFW on PSP and PSPGo (PSP since back when we needed to use jig battery and custom SD format tools) *made "many" PSP & Go cfw installs.
    Had the HDD backup of games on PS2 back in the day with a CD bootloader. Fun Times. LOL

    Oh....and used "strike objects" near coin slots (registered as a coin drop) on the old coin op consoles back in the day - AND the quarter on a string (dental floss) trick, as needed :-)

    I edited (immediately) my post where I said "CIA Files".....that was a mistake = CIA files are Nintendo 3DS format. My bad....was hot and heavy on the 3DS most recently. Nightly

    You had to have replied "very quickly" to miss the CIA edit....Thanks for the quick reply - no doubt (thumbsup).
     
    Last edited by Clockdryve, Apr 21, 2019
  2. rockMan83

    rockMan83 Member

    Newcomer
    2
    Aug 3, 2018
    United States
    no luck with the hotfix for me. All previous installed games (.NSPs) are corrupt. I'm running everything from a maxed out 400GB exFat card. I'll have to reInstall it all again...what a bummer and yes my 5 year old updated when I was at work and I didn't bother to create a nand backup. It's airplane mode all the way when the new OFW hits.
     
  3. DuveltjeDG

    DuveltjeDG GBAtemp Regular

    Member
    3
    Apr 5, 2019
    Netherlands
    I think you installation of NSP's is the issue. Did you use tinfoil maybe?

    My setup
    • Latest Atmosphere with hotfix
    • Latest ES and FS patches
    • Latest Hekate with autoboot profile for Atmosphere 0.8.8
    • All games (XCI->NSP, NSP Eshop, DLC etc) installed with GoldLeaf 0.5 and Goldtree.
    No issues what so ever. It should be something with the way your games were installed.

    Try to remove a game that does not work and reïnstall with goldleaf. I'm almost certain it will work. In another threat this was the solution for the games that didn't work.
     
    Last edited by DuveltjeDG, Apr 21, 2019
  4. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Well while the CFW itself supports firmware 8.0, the same cannot be said for the various homebrew applications and other software projects on the Switch. We have already discovered certain things do not work on firmware 8.0 such as themes or amiibo emulation. Not to mention that Atmosphere utilizes firmware-based patches for piracy. They have now been updated and can either be grabbed from this thread or the CFW and homebrew bundle known as Kosmos so you will need those if you're going to be moving to firmware 8.0. You should also be using FAT32 as unlike exFAT, it won't corrupt your SD card.

    Keys are a bit of a more complicated topic but generally, a user doesn't need to update his or her keys. Keys are either brought up when it comes to decrypting Switch content (e.g. converting .XCI files, repacking .NSP files, making themes) or for booting CFW. As newer and newer content come out, they are often encrypted with keys found on higher firmwares. Thing is, these keys are already embedded into your console whenever you update. The purpose of these keys are to perform functions outside of the Switch like on your computer because your computer doesn't naturally have access to these keys. The other keys, ones used to boot CFW, are rarely provided or utilized. These just hamper CFW from booting newer firmwares but are handled in ways that don't require noobs to do anything. The CFW handles key derivation for them so they don't have to provide the keys themselves (which would be illegal).
     
    Clockdryve likes this.
  5. rockMan83

    rockMan83 Member

    Newcomer
    2
    Aug 3, 2018
    United States
    Yes, games were installed by various methods (romMenu, tinFoil, Lithium, Goldleaf). None seem to work anymore, however reinstalling via the latest Goldleaf does resolve. It's just a pain to have to delete and reInstall every game, but so be it. I'm just happy to be back in action on 8.0!
     
    DuveltjeDG and naddel81 like this.
  6. vanir29

    vanir29 Member

    Newcomer
    2
    Jan 11, 2019
    Philippines
    wait, I didn't know that it is possible to boot CFW without a dongle, I still use tegrarcmgui or a dongle to boot Atmosphere even on 7.0.1, how is that possible if your autoRCM is enabled?
     
  7. xfighter11

    xfighter11 Advanced Member

    Newcomer
    4
    Oct 18, 2015
    Gambia, The
    Great news, thant to ScresM for this quick release :)
     
    Last edited by xfighter11, Apr 22, 2019
  8. naddel81

    naddel81 GBAtemp Addict

    Member
    8
    Dec 14, 2009
    United States
    so goldleaf fixes game installs? I thought the corrupting was due to old 4NXCI conversions being invalid?!
     
  9. smf

    smf GBAtemp Psycho!

    Member
    9
    Feb 23, 2009
    United Kingdom
    You can use dejavu to boot it, although not from 7.0.1 (yet). Not with autorcm though.

    But what I was referring to is you can downgrade any switch to any version, but if the fuses are burnt then you need a dongle for it to boot at all whether you use autorcm or not as the fuse count won't match. I was trying to find out whether the fuse count for 8 was the same for 7.
     
    Last edited by smf, Apr 22, 2019
    vanir29 likes this.
  10. xenon

    xenon GBAtemp Regular

    Member
    3
    May 19, 2006
    Italy
    Since a few Atmos releases, I can't play ACA (Arcade Archives) games anymore. I'm "blaming" Atmos because my firmware is always the same, 7.0.1, and I was able to run those games when I first got started with CFW (mid-March). I started with Kosmos + Hekate + 90NDS and slimmed down to just Atmos + Incognito. Asking in the Incognito thread whether it could cause my issue, I was told not and that a recent Atmos patch would fix it, but it doesn't seem to be the case. Just, with Atmos 0.8.8 crash management, instead of a hard freeze I get an error screen mentioning a "Data Abort" error and Title ID 0100000000000004

    Does anybody have an idea? Just to be clear, I am still on 7.0.1 and running Atmos 0.8.8 with all the patches from the "sweet patches" thread. And of course I have tried reinstalling the games.

    I forgot to mention, the error occurs right after I select my user, after the first ACA screen when you pick the version and press "+". I either get the Atmos error which forces me to reboot or a Switch-managed error message which takes me back to the home screen.

    Last edit: other non-ACA games which also force you to pick a user before they start do work correctly. It seems the issue is strictly limited to ACA games, both SNK and Nintendo.

    Thanks in advance!
     
    Last edited by xenon, Apr 22, 2019
  11. codezer0

    codezer0 Gaming keeps me sane

    Member
    9
    Jul 14, 2009
    United States
    The Magic School Bus
    Wait wait wait... What's this i hear about being able to get cfw on hardware patched Switch consoles? I deliberately held off on buying one because of the (unlikelihood) of getting one that could be jigged to be modded this way.
     
  12. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    You should still hold off on buying a patched unit until the exploit is actually released. Its not like patched units are going anywhere anytime. If you want to invest time, look for an unpatched unit. There are still some in the market.
     
  13. Denni93

    Denni93 GBAtemp Regular

    Member
    4
    Apr 3, 2016
    Germany
    Hey guys, if I want to use Incognito with Atmosphere, do I have to install it every time when I updated my firmware with ChoiDujourNX or do I only have to do it once?

    Thanks in advance!
     
  14. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    You cannot use Incognito with Atmosphere.
     
  15. Denni93

    Denni93 GBAtemp Regular

    Member
    4
    Apr 3, 2016
    Germany
    Before updating to 8.0.0 I installed it with sxos, shouldn´t it ´work when I installed it with an other cfw?
     
  16. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    I guess since nothing is supposed to write to PRODINFO in the first place.
     
  17. codezer0

    codezer0 Gaming keeps me sane

    Member
    9
    Jul 14, 2009
    United States
    The Magic School Bus
    If i have to hold off, I'd rather just save up for a Switch Pro.

    Around here, nobody carries anything old enough to be vulnerable from what i could find.
     
  18. TomSwitch

    TomSwitch Newbie

    Newcomer
    2
    Jan 10, 2019
    United States
    Just go airplane mode and you should be fine.
     
  19. Wario

    Wario Member

    Newcomer
    1
    Mar 11, 2019
    United States
    If deja vu is the last known exploit that doesn't require hardware RCM and only did 8.0 patch it, wouldn't a patched nVidia Tegra unit still have value because whatever is on the store shelves now isn't going to have OFW 8.0.

    I'll wait for the new updated consoles this summer and use that for going online, but it's so hard not to so I can buy and download all my favorite games now on my early firmware Switches. I really want to play Sega Outrun and Dragon's Lair which are digital only.
     
  20. fst312

    fst312 GBAtemp Advanced Fan

    Member
    6
    Nov 4, 2008
    United States
    New York
    I have the same issue as @xenon but in my case it’s super smash bros when I select stage builder or amiibo I get this error.
    I believe it’s the same title id. Even though I doubt it’s going to fix the issue, I may need to get a different 3.0 update.
     

    Attached Files:

Quick Reply
Draft saved Draft deleted
Loading...