PastaCFW with rxtools emunand FBI errors

Discussion in '3DS - Flashcards & Custom Firmwares' started by yelever74, Jun 13, 2015.

  1. yelever74
    OP

    yelever74 Advanced Member

    Newcomer
    65
    7
    Jun 13, 2015
    United States
    So I have managed to install Pastacfw on my o3ds 4.2.0.u and have emunand rxtools installed all done with cubic ninja and gateway webexploit but cannot install any cia files through FBI as I get a signature error or

    Install failed
    Could not install app
    Module: FS (x11)
    Level: Permanent (0x1b)
    Summary: Wrong arguement (0x8)
    Description: Invalid description (0x189)

    I have tried everything. I don't have a gateway or DS flashcart, only cubic ninja. The spider exploit has never worked for me so at a total lose on how to install any cia on sysnand
     
  2. zoogie

    zoogie simple pimp tool

    Member
    6,321
    7,993
    Nov 30, 2014
    United States
    You need to run ninjhax twice for FBI.3dsx to be able to install cia's. Your FBI version needs to be recent too.
     
  3. yelever74
    OP

    yelever74 Advanced Member

    Newcomer
    65
    7
    Jun 13, 2015
    United States
    If I run ninjahax once I get the signature error. If I run it twice I get the second error. Have the latest FBI.3dsx
     
  4. tehrzky

    tehrzky Member

    Newcomer
    36
    2
    May 5, 2015
    i think you should install the CIA installer first on Palastine/Pasta before you upgrade to Rxtools(signature patch)..
     
  5. yelever74
    OP

    yelever74 Advanced Member

    Newcomer
    65
    7
    Jun 13, 2015
    United States
    Tried that and still get same errors
     
  6. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Have you done the title.db step? Because that is really important
     
  7. yelever74
    OP

    yelever74 Advanced Member

    Newcomer
    65
    7
    Jun 13, 2015
    United States
    Yes. Did that straight away
     
  8. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Strange.
    I had the same problem, even after doing the title.db step. It kind of just fixed itself. I'd go to install a cia, it would throw an error, then I'd either try again, or exit FBI and reenter and it would work.
     
  9. innercy

    innercy GBAtemp Advanced Fan

    Member
    752
    131
    Oct 22, 2006
    are u sure are installing in SD?
     
  10. -LuCas-

    -LuCas- Member

    Newcomer
    34
    12
    Dec 6, 2014
    Italy
    On your SD card navigate to "Nintendo 3DS/<id0>/<id1>/". Create one folder named "dbs" then create one or two files in this folder named title.db and import.db . Put the SD card back in your 3ds and go to System Settings, and attempt to manage the SD software. Let the 3DS do its repair process.
    This worked for me
     
  11. Suiginou

    Suiginou (null)

    Member
    565
    588
    Jun 26, 2012
    Gambia, The
    pc + 8
    Doesn't rxMode emuNAND use a recent NATIVE_FIRM (firmware.bin)? If so, you can't use FBI via ninjhax to install non-well-signed (aka legitimate) CIAs, because the kernel hacks it does to acquire the privileges required to install CIAs are blocked by the newer NATIVE_FIRM.

    Instead, use FBI/DevMenu on sysNAND to install FBI/DevMenu as CIA, and only then create the emuNAND.
     
  12. Ompet

    Ompet Member

    Newcomer
    26
    1
    Jan 1, 2010
    What they meant (if you didn't understand that) was that you need to run PastaCFW through ninjhax, then run Ninjhax again (this time you're in PastaCFW, so your system can run unsigned CIAs), and install FBI (or any similiar like BigBlueMenu).

    If you have done that (first time I hadn't), follow all the other tips and tricks in this thread.
     
  13. yelever74
    OP

    yelever74 Advanced Member

    Newcomer
    65
    7
    Jun 13, 2015
    United States
    I run PastsCFW and ninjhax again get the second error

    Install failed
    Could not install app
    Module: FS (x11)
    Level: Permanent (0x1b)
    Summary: Wrong arguement (0x8)
    Description: Invalid description (0x189)

    I have tried title db an import db.

    Here's the strange thing though. I have a second sd card with it all setup from another console (I don't own) and I can install cia's on emunand and sysnand so right now I'm not complaining lol. It's only an 8gb card but it works, just can't do it on my console. Should be getting a N3DS this month and if it is 0n 9.2 or less I'll try that.