PAL GC on NTSC Wii, problems with launchers

Discussion in 'Wii - Backup Loaders' started by dkp, Nov 25, 2010.

Nov 25, 2010
  1. dkp
    OP

    Newcomer dkp Newbie

    Joined:
    Nov 25, 2010
    Messages:
    6
    Location:
    USA
    Country:
    United States
    So, I apologise if this is an inappropriate place, please move/delete/whatever if necessary. If redundant, sorry. Whenever I try using the search button, something seems to eat my input. I haven't found this by manual look up.

    If this is too much, a tldr version will be bulleted at the end.

    My problem is, whenever I try to load a PAL GC backup on my Wii, it either gives a green screen, empty black screen, or only plays black and white.

    The backups I'm trying to play are said to be supported (namely German (PAL) Zeldas, with a strong preference for the Wind Waker). I've tried multiboot, wiped, and unaltered. The images themselves are fine- running fine with emulators and such. The media I'm using are verbatim DVD-Rs. So I'm positive it's not a media/image issue.

    My system menu is ver. 4.1U. My Wii was also one of the first off the assembly line for the US, so I know she's capable of backup launching; especially because North American and Japanese backups do work.

    NA and JAP backups DO work, just to repeat.

    My cIOS is cIOS56rev20 (slot 249). The MIOSes I've tried are cMIOS v4 and v10 (or whatever they are named)

    In any case, when I boot PAL games using Neogamma (r8, r7, r9b47), I keep getting errors. When I try the recommended options (internal/disc) I get a black and white screen. On my older TV, it skips up and down the screen and my newer it stays put. When I try to force it to Wii, I get a green screen. Trying to force it to anything else just gets me that green screen or it causes the wii to out right go to the "nothing's plugged into the av slots" screen. Changing whether to patch the game or not doesn't seem to work.

    I get the same results when I try the gamecube backup launcher, and similar results for the other things I've tried, which were generally outdated launchers and GCOS (which... isn't really a wii thing). Generally, anything I could find here or on Eurasia.


    As for the multigame discs, I've heard that there's been a lot of problems with most of the assemblers(?) making the isos PAL. I haven't been able to find any that don't seem to default to PAL, except a really old one that... well, it doesn't seem to create a region code at all.

    I've also been told not to use the wii cables- but I just don't know what this means. The wii only has one audio-video out. I don't think that a (raw) PAL signal can be sent through an NTSC wii anyways.


    So, to recap:

    *Need (for homework, actually) to boot PAL GC backups on NTSC Wii using sys menu 4.1U, cIOS56rev20, cMIOS v4 or v10, preferably with Neogamma

    *NTSC (NA and JAP) games *do* work

    *PAL games green screen, refuse to boot, or do the black and white flickering thing. Patching doesn't work.

    *Other Gamecube Backup launchers fail similarly.

    *??Wii cables??

    *??Multigame issues??? - Note that this shouldn't affect the booting of an unchanged gamecube backup.


    What I'm currently attempting to do is edit the PAL rom to boot NTSC. That's... Not going well.
     
  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    It's the common video mode problem. If recommend cMIOS + NeoGamma in GC mode internal + force NTSC480i + GC video mode patches don't help, then i don't think there's a solution for this yet. When(if) SD-Boot is released, there might be new options for this.

    With NeoGamma it doesn't matter if the game is on a multi game disc, nor if the multi game disc itself is PAL or NTSC.
     
  3. Sao Mortel

    Member Sao Mortel GBAtemp Advanced Fan

    Joined:
    Jul 23, 2008
    Messages:
    533
    Location:
    Montreal
    Country:
    Canada
    Save yourself troubles and buy a modchip, i dont think theres any modchip that has that problem
     
  4. dkp
    OP

    Newcomer dkp Newbie

    Joined:
    Nov 25, 2010
    Messages:
    6
    Location:
    USA
    Country:
    United States
    Thank you very much for your replies.
     
  5. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Sorry, but you don't understand. This is the common video mode issue if you have a (crappy/NTSC-U) tv that only supports the video mode from your region. A modchip + disc channel would just result in a freeze, not even black&white playback for those games btw.
     

Share This Page