Omega Labyrinth (Menu) Translation [Help Needed]

Discussion in 'PS Vita - Hacking & Homebrew' started by AlternativeZero, May 12, 2017.

  1. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    Move your plugins and config.txt to ur0:tai/ and delete the ux0:tai/ folder. Make sure everything points to where it should, including your SD2Vita config, otherwise it won't even load your SD as ux0. Simply put, don't use ux0:tai/ if you are using kernel-level plugins that mess with certain things, like rePatch does.

    Restart your Vita after all of the above.

    If setup correctly, rePatch should be working and loading the contents (encrypted/decrypted) from the respective folders.
     
  2. SkyRaider

    SkyRaider Member

    Newcomer
    1
    May 17, 2019
    France
    Hi RikuNoctis, and thanks and lot for your suggestion !
    I tried to put all the files in ur0:tai and delete the ux0:tai folder, but all games topped working then. I think that's because I use ux0 for the SD2VIta... No clue again !
     
  3. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    Did you edit your config.txt then restarted your Vita so it reflects that your plugins are now located on ur0:tai/ and not on ux0:tai/?

    Using ux0: for the SD2Vita has nothing to do with it as that's exactly how it works (or, how most people want it to as ux0 is the only partition used to play Vita games). Your config.txt is likely to be wrong somewhere.

    The only other thing that comes to mind that may be happening is that you are using the old rePatch (unlikely, but it's possible) that required rePatch AIDS to properly work sometimes.
     
  4. SkyRaider

    SkyRaider Member

    Newcomer
    1
    May 17, 2019
    France
    Yep all the config.txt was edited with the specific line after KERNEL, and the Vita was restarted many times. I tried about 15-20 times but allways arrived at the fact that the games stopped working completely ("You need to download the game from the PS Store to play it").
    Now I also thought that rePatch AIDS was possibly a solution, but I have another problem, wich can in fact be the main problem: when I put (with USB connection or FTP doesn't matter) the vpk file in the vita, I see it on my PC, but it doesn't appear onscreen on the vita ! (I'm using Vitashell 1.98). Maybe there is a problem with the refreshing of the vita ?
     
  5. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    This sounds like the fake license file is not being loaded/created by the NoNpDrm plugin, which doesn't really have anything to do with rePatch nor SD2Vita.

    Do you have NoNpDrm correctly installed and listed on your config.txt?

    Don't use rePatch AIDS. It's not needed anymore as the latest versions of the plugin (like, the last 2 or 3 released) work with both encrypted and decrypted content on their respective folders. rePatch AIDS is obsolete now, technically.

    What .VPK are you talking about? rePatch is not a .VPK; SD2Vita isn't either.

    Are you talking about games in .VPK format? About homebrews/apps/emulator?
     
  6. SkyRaider

    SkyRaider Member

    Newcomer
    1
    May 17, 2019
    France
    In fact it's when it put the tai folder in ur:0 that I have this problem, even if I edit the config as required... When it's in ux:0 I have don't have any problem at all.

    The vpk was rePatch AIDS, but I know that it's obsolete and just wanted to see if it has any impact. I have some other vpk files (enso and vitashell) wich I wanted to remove (to see if the refreshing worked) but they didn't disapear from vitashell...

    I tried also with the latest rePatch manually a minute ago and that didn't do anything...
     
  7. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    Can you post your config.txt as it is right now? You can copy + paste it here in the post.

    Yeah, AIDS is not needed. rePatch works fine in it's latest update. Those other .VPKs don't need to be on your card, so you can remove them; think of them as "installers" for that homebrew.

    BTW, can you provide a link for that patch for Omega Labyrinth that you are trying to use? I could test in the morning and see what is the problem, or at least test it and see if it works as your issue still sounds like it's config related. Maybe that way we can troubleshot it and/or pin-point where it is (believe me, it can be something so trivial like a wrong character on your config.txt).
     
  8. SkyRaider

    SkyRaider Member

    Newcomer
    1
    May 17, 2019
    France
    I just saw something ! I've installed the rePatch plugin another time, verified the config.txt on Vitashell to see if all was okay, opened it on my PC, and here's what I see :

    # For users plugins, you must refresh taiHEN from HENkaku Settings for
    # changes to take place.
    # For kernel plugins, you must reboot for changes to take place.
    *KERNEL
    ur0:tai/gamesd.skprx
    ux0:tai/nonpdrm.skprx
    # henkaku.skprx is hard-coded to load and is not listed here
    *main
    # main is a special titleid for SceShell
    ur0:tai/henkaku.suprx
    *NPXS10015
    # this is for modifying the version string
    ur0:tai/henkaku.suprx
    *NPXS10016
    # this is for modifying the version string in settings widget
    ur0:tai/henkaku.suprx

    As you can see, the rePatch plugin line is missing ! And in attachment you can see what I can see on Vitashell. That's quite tricky, I think my Vita doesn't refresh at all...

    Same as before, I tried to remove them, and on my PC they removed, but in Vitashell I still see them ! That's the first timemy Vita do that, and maybe that's the cause of all the problems...

    I simply use the link at the first page of this forum, which is:

    https://mega.nz/#!G4FBDaiZ!CyfOUO7gNe8fXsZcklTzcMIETKBpqc0DMtskEh9ynaw
     

    Attached Files:

  9. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    Here is your first problem.

    It should be:
    Code:
    ur0:tai/nonpdrm.skprx
    You have it listed on ux0:/tai.
    Like I said, you need to make sure everything is listed correctly on your config.txt.
    So, if you put the nonpdrm.skprx plugin on ur0:tai/, your config.txt should reflect that. That's why your Vita isn't refreshing anything.


    As for the patch, I'll test it in the morning, but first check on your end what I mention above; if it works, your patch should be working now too as the license is now actually being generated by NoNpDrm.
     
  10. SkyRaider

    SkyRaider Member

    Newcomer
    1
    May 17, 2019
    France
    Okay, so I changed that line as you said, but that didn't do anything... Furthermore, the Vita still doesn't refreshing... Just a thing : the nonpdrm.skprx file is on ux0:tai/, because if I put it in ur0: and change the line code as required, the games stop working...
    Although, when I change the config file to ur0: and let the nonpdrm.spkrx file in ux0:, it still works... And in both cases, the Vita isn't refreshing!

    Thanks a lot ! But I really think that it's because of something in my Vita's config, because almost everyone here can use it without problem...
     
  11. bloodfalco

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
    Hi everyone, I cannot play this game. I downloaded the game from NoPayStation, put into folder app. I downloaded dlcs and put into addcont folder, I downloaded updates and put into rePatch folder and put the translation into the rePatch folder by overwriting the files. I am using 3.65 Enso and using rePatch REDUX 3.0. Whenever I start the game, it shows C1-2613-2. Inside my config.txt in tai folder looks like this.

    # For users plugins, you must refresh taiHEN from HENkaku Settings for
    # changes to take place.
    # For kernel plugins, you must reboot for changes to take place.
    *KERNEL
    ur0:tai/repatch.skprx
    *KERNEL
    ux0:tai/nonpdrm.skprx
    # henkaku.skprx is hard-coded to load and is not listed here
    *main
    # main is a special titleid for SceShell
    ur0:tai/henkaku.suprx
    *NPXS10015
    # this is for modifying the version string
    ur0:tai/henkaku.suprx
    *NPXS10016
    # this is for modifying the version string in settings widget
    ur0:tai/henkaku.suprx
    *KERNEL
    ux0:tai/ref00d.skprx
    *KERNEL
    ur0:vitacheat/vitacheat.skprx

    Any helps for me? Tips or tricks?
     
  12. k7ra

    k7ra GBAtemp Fan

    Member
    3
    Dec 11, 2016
    Mos likely cheat plugin fault, but you have 2 conflict configs... 1 in ur0 and 1 that you use in ux0, because ux0 main it overwrite ur0. Move all things to ur0 and save my config.
    PS: I disable cheat plugin, other things not needed on 3.65


    # For users plugins, you must refresh taiHEN from HENkaku Settings for
    # changes to take place.
    # For kernel plugins, you must reboot for changes to take place.
    *KERNEL
    ur0:tai/repatch.skprx
    ur0:tai/nonpdrm.skprx
    ur0:tai/ref00d.skprx
    #ur0:vitacheat/vitacheat.skprx
    # henkaku.skprx is hard-coded to load and is not listed here
    *main
    # main is a special titleid for SceShell
    #ur0:tai/henkaku.suprx
    #*NPXS10015
    # this is for modifying the version string
    #ur0:tai/henkaku.suprx
    #*NPXS10016
    # this is for modifying the version string in settings widget
    #ur0:tai/henkaku.suprx


    [MOVE ALL PLUGIN FROM UX0 ux0:tai/ TO UR0 ur0:tai/ AND DELETE ux0:tai/]
    Then save my config
    Recommended add oclockvitaminimal plugin and shellbat plugin
     
    Last edited by k7ra, Jun 2, 2019
  13. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    I tested the game, and it works without issues. Have you tried using Storagemgr instead of gamesd? that plugin is inferior and buggy compared to Storagemgr, and they serve the same purpose.

    I don't really know what is causing your problem at this point, besides that. Some other plugin besides the ones you listed already? It's either that or you need to rebuild the DB, refresh LiveArea from Vitashell (because your bubbles will be gone; make sure you can run vitashell from your sony memory card if you are using SD2Vita, as after the rebuild SD2Vita may not load), reset config.txt and makeing sure you are using the latest version for the plugins.

    Updates don't go (and don't need to anymore) into rePatch folder, but into the "patch" folder, which is the location where the Vita stores the patches normally.

    It's recommended you simply update your games from LiveArea. Patches for games are usually very small in size (except PSO2... lol), and NoNpDrm dumps work perfectly.

    Kernel-level plugins don't cause issues like this unless you are setting it up really, really, wrong (like wrong mounting points on Storagemgr).
    User plugins do.

    Besides, I've already tested the game, with the same config, and it works, on FWs 3.65, 3.67 and 3.68 using rePatch's latest version. Something else may be causing this issue, but we can't see it yet. Other people have stated that the game does indeed work with the patch and same config, too.
     
  14. k7ra

    k7ra GBAtemp Fan

    Member
    3
    Dec 11, 2016
    Tell me stories, I meet 5 games that give me this error with it
     
  15. bloodfalco

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
    Bros, thanks for replying me. I tried moving the patch from repatch folder to patch folder, it gave me C2 error. Corrupted data or so. Btw, is the patch need to be overwritten by the one in repatch folder? And I am using only vita memory card, no sd2vita
     
  16. RikuNoctis

    RikuNoctis GBAtemp Regular

    Member
    4
    Jul 4, 2018
    Japan
    Millenium Castle Brunestud
    Really? Probably 5 games where your setup is wrong. This may be caused when the SD is formatted wrong, even though it works from the beginning, for example.

    The thing you needed to move from "rePatch" folder to the "patch" folder is the game update, not the patch for the game. That's why it asks you to overwrite. Once again, the patch from this thread goes into the "rePatch" folder, while the official game update goes into the "patch" folder.

    rePatch only needs to have the Omega Labyrinth patch on it's folder. You don't need to download the official game update from NPS Browser nor PKGi/j; you can let your Vita do that from LiveArea.
     
  17. bloodfalco

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
    Alright bro. Everything working properly. Thanks for the advice and helps
     
  18. SkyRaider

    SkyRaider Member

    Newcomer
    1
    May 17, 2019
    France
    Yeah the game works fine for me too, but it's just the translation that doesn't... The only plugins I have are those I have listed.

    By rebuilding the Database, you mean Factory Reset and ? I think I will try to hack the Vita all over again, that's a good solution imo. I'll do something smoother and cleaner so that I can work on it with more ease.

    So you think I should use Storagemgr instead of gamesd ?
     
  19. aw013

    aw013 Member

    Newcomer
    2
    Apr 20, 2013
    does anybody have a cheat for caligula effect?
     
  20. dushbadge

    dushbadge Member

    Newcomer
    2
    Jul 23, 2013
    Canada
    Thank you for YOUR WONDERFUL contribution. Perhaps we would see your efforts applied towards Z in the future, given that Z has no hope (unless PQube ported Z to Switch).
     
Loading...