Okay to update modded wii?

Discussion in 'Wii - Hacking' started by Lilbee17, Sep 1, 2012.

Sep 1, 2012

Okay to update modded wii? by Lilbee17 at 7:21 AM (11,908 Views / 0 Likes) 34 replies

  1. Lilbee17
    OP

    Newcomer Lilbee17 Member

    Joined:
    Sep 1, 2012
    Messages:
    13
    Country:
    Canada
    Just recently got a modded wii from someone and recently tried to play Mario galaxy but it said that the system needed to be updated. It's currently 2.2U and it's modded with wiikey. Is it safe to update or can that brick the wii?

    Thanks
     


  2. jonthedit

    Member jonthedit GBAtemp Advanced Maniac

    Joined:
    May 30, 2011
    Messages:
    1,691
    Country:
    Bermuda
    It's on 2.2!?! Damn! I can't help you here! What region is it?
     
  3. godreborn

    Member godreborn GBAtemp Advanced Fan

    Joined:
    Oct 10, 2009
    Messages:
    691
    Country:
    United States
    it should be fine. the wiikey 1 (which I'm assuming u have since ur on that old of a system menu) was last updated when super mario galaxy came out. I've burned a few games (have wiikey as well) since then, and I haven't had any problems. updating will not brick the wiikey nor the system. I think nintendo gave up on hard mods when the soft mod came out.
     
  4. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    Don't update past 4.1, otherwise you will lose region free on your modchip.
     
  5. Lilbee17
    OP

    Newcomer Lilbee17 Member

    Joined:
    Sep 1, 2012
    Messages:
    13
    Country:
    Canada
    Yup...it basically only plays games from 2007 and down. And it's US


     
  6. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    I strongly suggest you update via ModMii and not through Nintendo. Go through the Softmod process. It won't conflict with your modchip.
     
    1 person likes this.
  7. godreborn

    Member godreborn GBAtemp Advanced Fan

    Joined:
    Oct 10, 2009
    Messages:
    691
    Country:
    United States
    yeah, stick with 4.1. 4.2 and 4.3 seem to be all ap garbage. though, mario kart should require a system menu before 4.0. if ur playing from discs, u may need to update the wiikey. I think the last update was 1.9s for galaxy. though, u might want to soft mod the system, so u don't have to waste discs.

    edit: for galaxy, u can update from the disc. however, with the wiikey, u need to burn a wiikey update disc along with padding. the update is very small, so the wii won't read the disc normally (the reason for the added padding). however, soft modding will eliminate the need to update the modchip.
     
  8. Lilbee17
    OP

    Newcomer Lilbee17 Member

    Joined:
    Sep 1, 2012
    Messages:
    13
    Country:
    Canada
    I'm a total noob and have no idea what this means or how I do it...lol
     
  9. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    http://modmii.zzl.org/
     
  10. Lilbee17
    OP

    Newcomer Lilbee17 Member

    Joined:
    Sep 1, 2012
    Messages:
    13
    Country:
    Canada
    I'm on a mac


     
  11. godreborn

    Member godreborn GBAtemp Advanced Fan

    Joined:
    Oct 10, 2009
    Messages:
    691
    Country:
    United States
    it won't matter. the update for the wiikey came out after the game did. originally, the game could detect the modchip, but the fix prevents that.
     
  12. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,188
    Location:
    Michigan, USA
    Country:
    United States
    @godreborn 4.3 has some bug-fixes in it too. I used dopmii to update to 4.3 and it fixed a message board error that gave a "system files are corrupted" which was apparently caused by some random games a while back. (Wii fit plus, Tetris party deluxe, Wii music i think) Also you can ignore all that AP crap with Priiloader or start patch (Priiloader is recommended)

    @[member='Lilbee17']
    At this point in time, Softmod>Hardmod. Use ModMii to softmod your wii and set up all your cIOS and whatnot for USB Loaders. You'll be glad you did it.
     
  13. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    4.2/4.3 don't have any bugfixes. It was just re-installing your System Menu that fixed the problem.
     
  14. Lilbee17
    OP

    Newcomer Lilbee17 Member

    Joined:
    Sep 1, 2012
    Messages:
    13
    Country:
    Canada
    What would happen if I pressed OK to the system update prompt from the Mario galaxy game?
     
  15. godreborn

    Member godreborn GBAtemp Advanced Fan

    Joined:
    Oct 10, 2009
    Messages:
    691
    Country:
    United States
    I'm not sure what update is on the disc, but it has to be 3.2 or less. it wouldn't negatively impact anything. u would need to update ur wiikey, but u wouldn't be able to play the game without updating unless u softmod the system.
     
  16. Lilbee17
    OP

    Newcomer Lilbee17 Member

    Joined:
    Sep 1, 2012
    Messages:
    13
    Country:
    Canada
    Okay. So if I soft mod it with modmii I'll be able to play newer games? As well as the old backup games I have?
     
  17. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    Yes.
     
  18. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,188
    Location:
    Michigan, USA
    Country:
    United States
    @joostinonline I reinstalled 4.1 about 5 times with dopmii, but to no avail.
    It had to be a message board bug, because i could boot into maintenance mode no problem. As soon and i used dopmii to update to 4.3 the problem dissapeared. So 4.3 had to of changed something.
     
  19. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    Installing 4.3 wouldn't do anything to your message board, nor are there any fixes included at all. The only ways to fix a mail box brick are by
    1. Replacing the appropriate files with something like FS Toolbox.
    2. Formatting your system.
    I generally stay away from Dop-Mii since it's unstable.
     
  20. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,188
    Location:
    Michigan, USA
    Country:
    United States
    @JoostinOnline Well, i'm not the one with a problem here. I already fixed my problem a few months back. All i know is what I did proved effective. >_>
     

Share This Page