Nintendo 3ds Sysnand and Emunand problems

Discussion in '3DS - Flashcards & Custom Firmwares' started by Spellmansp, Dec 27, 2015.

  1. Spellmansp
    OP

    Spellmansp Newbie

    Newcomer
    9
    0
    Dec 27, 2015
    Argentina
    First of all, thanks for your time guys and sorry for my poor english.

    I will try to explain the most detail as I can.
    My Goal (or what I want to)

    1.-Have Sysnand 4.2 with DS Profile Exploit with RXtools installed (So I can boot my Emunand without internet)
    2.- Emunand up to date with FBI inyected through H&S App. In order to play CIA Games (Emunand)
    3.- I dont want to use ANY KIND OF FLASH CARDS (Gateway, R4, etc)
    -------------------------------

    So, Grab some Pop Corn and listen the story of my life:

    I had mi Old 3Ds with 9.0 Sysnand. I decided to downgrade to 4.2, Install Ds Profile exploit, Run Gateway Launcher and make a emunand (4.2)

    From here:

    -Sysnand 4.2 (With DS profile exploit)
    -Emunand 4.2
    Rxtools and Gateway launcher boot emunand without problems.

    I decided to update my Emunand up to date (10.3 At the moment of this post) In RXMode

    So:

    -Sysnand 4.2 (With Ds Profile exploit)
    -Emunand 10.3 (Updating with RXtools)

    Rxtools and Gateway launcher WON’T boot at all. (Browser and profile exploit)

    I tried to update my Sysnand to 7.1 Using a Zelda Majora's Mask Cartridge.

    So:

    -Sysnand 7.1 (Without DS Profile exploit, because they patched that bulnerability)
    -Emunand 10.3 (Updated thanks to RXtools)

    Rxtools boot emunand without problems (Using browser) BUT Gateway launcher WON’T boot emunand at all.

    I used FBI to inject H&S app and I was be able to install cia games (Emunand)

    So, I decided downgrade my Sysnand to 4.2 Again and my Emunand Stops booting. But if I update (again) My sysnand to 7.1, My Emunand Works again.

    I don’t know why this happens. Why I can’t boot my up to date emunand having a 4.2 Sysnand.

    Note:
    I tried using, every version of RXtools, Every version of Gateway launcher without success.
    I tried reformating my SD card many times.
    I tried restoring mi Nand many times.
    I searched a lot’s of post without getting any solution, So I decided to make this post.

    Hope you can help me guys.

    Thanks in advance.
     
    Last edited by Spellmansp, Dec 28, 2015
  2. Pikasack

    Pikasack What is a title

    Member
    633
    203
    Apr 27, 2015
    Canada
    You could just install 4.0 MSET on 7.1, right?
     
  3. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    895
    Sep 17, 2010
    Belfast
    you could have stayed on 9.0 and just auto booted into emunand

    cant you restore that far back
     
    Ammako likes this.
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,080
    5,154
    Mar 17, 2010
    Norway
    Alola
    I would recommend restoring your 9.0 NAND backup (you do have one, right?)
    Since 9.0-9.2 is required for menuhax autoboot, which you will probably want. It's easier to restore the NAND backup from before you started messing with the NAND.
    Menuhax is the preferred method of launching CFW nowadays as it can launch automatically when you power on the 3DS :)
     
  5. Spellmansp
    OP

    Spellmansp Newbie

    Newcomer
    9
    0
    Dec 27, 2015
    Argentina
    Thank you guys for all your replys. The problem is that I don't have any 9.0 Nand backup (only 4.2 And 7.1) And I didn't stayed on 9.0 because in that time I was a Noob in 3Ds scene (well I'm Still a noob) And I thought that downgrading to 4.2 was the best of the World. Hm so, the only solution is getting a Game Cartridge with 9.0-9.2 system update.
     
  6. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
    If you have a way to actually successfully boot into rxtools's menu still, you can run devmode and install sysupdater to sysnand, and use a 9.2 update pack that you will have to find online to update to a full proper 9.2 firmware.
     
  7. anonymoose

    anonymoose Lannister

    Member
    168
    67
    Nov 15, 2015
    Germany
    Kashyyyk
    are they unlinked?
     
  8. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    895
    Sep 17, 2010
    Belfast
    would be amazing that they are still linked considering his EmuNand and SysNand are on 2 vastly different firmwares.

    [​IMG]
     
  9. anonymoose

    anonymoose Lannister

    Member
    168
    67
    Nov 15, 2015
    Germany
    Kashyyyk
    well, then explain to me why he can't boot into emuNAND
     
  10. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
    Do you have slot0x25keyX.bin at the root of your SD card?
    You need it if you want to boot an emunand 7.x or higher when your sysnand is lower than 7.x
    That may be why you can boot your emunand when you update to 7.1 but cannot boot it when downgraded to 4.2

    You can be on linked nands just fine while still being on two different firmwares, you know.
    nands are only unlinked once you format one of the two (usually it is sysnand that will be formatted.)
    If you updated emunand without unlinking nands then they would still be linked. I recommend against it though because I've read that some people reported sysnand getting updated when they attempted to update emunand while nands were still linked.
     
    Last edited by Ammako, Dec 27, 2015
    anonymoose likes this.
  11. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    895
    Sep 17, 2010
    Belfast
    yeah thats why im saying about it, the amount of times he has updated both his nands theres no way he has them linked lol also because he would lose all his titles from emunand if he relinked them to a new subfolder
     
  12. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
    Updating nand has nothing to do with unlinking them.
    Judging by their post, it is highly likely their nands are still linked. Not that it would really matter anyway.

    They downgraded from 9.0 to 4.2, and then they created their emunand right then. Meaning they were linked at that point. It worked until they updated it to 10.3
    Then they updated sysnand to 7.1 with Majora's Mask 3D and it was working again.
    Then they downgraded back to 4.2 and not working anymore.

    They never mentioned formatting sysnand or emunand in system settings which would unlink them.

    I find it very likely they simply don't have slot0x25keyX.bin at the root of their SD card.
     
    Last edited by Ammako, Dec 27, 2015
  13. Spellmansp
    OP

    Spellmansp Newbie

    Newcomer
    9
    0
    Dec 27, 2015
    Argentina
    Thank you again guys.

    Yes, I have slot0x25keyX.bin on the root of my SD card (and I tried using "diferents" slot0x25keyX.bin)

    I tried to unlink the systems once (I checked If it created the two folders inside "3DS" folder on my SD Card) But without success.

    Now, I don't think that Sysnand and Emunand are unlinked because the things that install on the Emunand, appears on the Sysnand too (But if I try to run them, it don't work)

    I will try to unlink again and see what happens.

    And I will try to learn about Sysupdater (because I don't Know) and try to run it and update my Sysnand.
     
  14. Spellmansp
    OP

    Spellmansp Newbie

    Newcomer
    9
    0
    Dec 27, 2015
    Argentina
    So, I tried to downgrade Mset (in order to use DS profile hack on 7.1) As a result I cannot enter to Gateway menu anymore from web browser. It's crashes every time no matter what.

    I can't use the sysupdater because I can't inyect FBI on Sysnand (because I need a newer firmware) and if I install as a Cia from FBI on Emunand It will no appear as a "gift" on sysnand.

    I got stuck, and now I can't backup or restore Nand using Gateway menu. (Yeah, I tried changing the Launcher.Dat, deleting cookies, formating SD, etc)